Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030249
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2015-06-25 15:512017-02-02 11:24
ReporterNaroaIriarteView Statuspublic 
Assigned Toplatform 
PrioritynormalResolutionopenFixed in Version
StatusacknowledgedFix in branchFixed in SCM revisione45f0f903a95
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030249: An error is get in the chrome console when executing a Process Definition.

DescriptionWhen executing the process definition "Set New Currency", an error is retrieved:

"Uncaught TypeError: Cannot read property '$1162' of null"

I the "https://code.openbravo.com/erp/mods/org.openbravo.userinterface.smartclient.dev/" [^] module is in development, the message is this:

"Uncaught TypeError: Cannot read property '_handleSelect' of null"
Steps To Reproduce1- Log in as System Admin.
2- Go to "Process Definition" window and open "Set New Currency" record.
3- Open "Rate" in the "Parameter" tab.
4- Set the default value as 1.

5- Log in as F&B Admin.
6- Go to "Business Partner" window and select any record.
7- Click on the "Set New Currency" button.
8- Click on the "Done" button.
9- An error is retrieved in the chrome console:
"Uncaught TypeError: Cannot read property '_handleSelect' of null"
TagsNo tags attached.
Attached Filesdiff file icon issue30249.diff [^] (950 bytes) 2015-06-25 17:05 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0031532 acknowledgedplatform It is raises a exception when closing a tab which has an editing row. 
related to design defect 0034656 acknowledgedplatform An error is shown in Chrome console after executing a process 
has duplicate defect 0035135 closedplatform An error is shown in chrome console when clicking the "done" button of the "Add Payment" process in some circumstances 
causes defect 0030324 closedalostale process definition invoked from menu remains in processing status after completion 

-  Notes
(0078641)
hgbot (developer)
2015-07-03 17:46

Repository: erp/devel/pi
Changeset: e45f0f903a9522adc6ef50bc0c9902944cbcb44e
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Thu Jun 25 17:04:28 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/e45f0f903a9522adc6ef50bc0c9902944cbcb44e [^]

Fixed issue 30249: Error get when the Set New Currency process def. is executed

The problem was that a error was got when clicking the "Done" button of the "Set New Currency"
process definition.

"Uncaught TypeError: Cannot read property '_handleSelect' of null"

The problem was in the "ob-parameter-window-view.js" in the handleResponse function.
It was executing "this.showProcessing(false)" even when the "retryExecution" parameter
was false.
Now the "this.showProcessing(false)" is executed only if the "retryExecution" parameter is true.

This affected to the process definition execution because as we were executing the "this.showProcessing(false)"
even when the retryExecution parameter was false, an ob-selector was deleted and after that, it was trying to
get the "._handleSelect" of that selector.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-parameter-window-view.js
---
(0078689)
hgbot (developer)
2015-07-07 09:31

Repository: erp/devel/pi
Changeset: 8adae72ecaeee2a88ac610a36bbd4f02536a7988
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Jul 07 09:30:33 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/8adae72ecaeee2a88ac610a36bbd4f02536a7988 [^]

fixed bug 30324, related to bug 30249 (backed out)

  Backed out changest e45f0f903a952 because introduced regression 0030324.

  It only took into account case of process definitions executed as a popup but
  not when they are executed as a full tab.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-parameter-window-view.js
---
(0078691)
alostale (developer)
2015-07-07 09:32

Reopening: current changeset causes regression 0030324
(0079453)
hudsonbot (developer)
2015-08-20 23:15

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test
(0079478)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-06-25 15:51 NaroaIriarte New Issue
2015-06-25 15:51 NaroaIriarte Assigned To => NaroaIriarte
2015-06-25 15:51 NaroaIriarte Modules => Core
2015-06-25 15:51 NaroaIriarte Triggers an Emergency Pack => No
2015-06-25 15:52 NaroaIriarte Assigned To NaroaIriarte =>
2015-06-25 15:53 NaroaIriarte Assigned To => NaroaIriarte
2015-06-25 16:32 NaroaIriarte Review Assigned To => alostale
2015-06-25 16:32 NaroaIriarte Issue Monitored: alostale
2015-06-25 17:05 NaroaIriarte File Added: issue30249.diff
2015-06-25 17:19 NaroaIriarte Status new => acknowledged
2015-06-25 17:20 NaroaIriarte Status acknowledged => scheduled
2015-07-03 17:46 hgbot Checkin
2015-07-03 17:46 hgbot Note Added: 0078641
2015-07-03 17:46 hgbot Status scheduled => resolved
2015-07-03 17:46 hgbot Resolution open => fixed
2015-07-03 17:46 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e45f0f903a9522adc6ef50bc0c9902944cbcb44e [^]
2015-07-07 09:27 alostale Relationship added causes 0030324
2015-07-07 09:31 hgbot Checkin
2015-07-07 09:31 hgbot Note Added: 0078689
2015-07-07 09:32 alostale Note Added: 0078691
2015-07-07 09:32 alostale Status resolved => new
2015-07-07 09:32 alostale Resolution fixed => open
2015-07-08 16:46 alostale Status new => acknowledged
2015-08-20 23:15 hudsonbot Checkin
2015-08-20 23:15 hudsonbot Note Added: 0079453
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079478
2015-11-11 12:13 alostale Assigned To NaroaIriarte => platform
2017-02-02 11:21 NaroaIriarte Relationship added related to 0031532
2017-02-02 11:24 NaroaIriarte Relationship added related to 0034656
2017-02-02 11:28 NaroaIriarte Relationship added has duplicate 0035135


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker