Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030244
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformminoralways2015-06-09 13:112015-06-25 18:47
ReportermalsasuaView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR15Q2.3
StatusclosedFix in branchFixed in SCM revision5932cc502f4d
ProjectionnoneETAnoneTarget Version3.0PR15Q2.3
OSWindowsDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browserGoogle Chrome
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030244: On windows the 'ant setup' tool writes incorrect source.path to Openbravo.properties (not using \\ for a \)

DescriptionUsing 'ant setup' the tool writes source.path automatically but does not follow proper encoding of java properties files which required \\ to be used when a \ character is wanted as is

Effect of this is that any code using source.path (i.e. MMC, obx module installation and/or updates does not work)

Workaround is to manually edit source.path to have \\ for each \ which is wanted.

Note: Same applies to any path in properties (i.e. also attach.path)
Steps To ReproduceIn Windows OS:
.as system administrator, go to module management window
. select a obx file to install module
. error is returned:

Error: Error
org.openbravo.service.web.ResourceNotFoundException: Source file [C:openbravoerpopenbravo\src-db\database\model\tables\AD_MODULE.xml] can not be found. Verify 'source.path' property is properly set in Openbravo.properties file.
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00301353.0PR15Q3 closedcaristu On windows the 'ant setup' tool writes incorrect source.path to Openbravo.properties (not using \\ for a \) 

-  Notes
(0078514)
hgbot (developer)
2015-06-25 16:18

Repository: erp/backports/3.0PR15Q2.3
Changeset: 5932cc502f4d2b871ffa4baf55f0fd6aa6b250fe
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Jun 25 16:13:13 2015 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR15Q2.3/rev/5932cc502f4d2b871ffa4baf55f0fd6aa6b250fe [^]

Fixes issue 30244: On windows the ant setup tool writes incorrect source.path

The ant setup tool was writing an incorrect source.path because the user.dir property obtained under Windows contains backslashes as file separator in the path.
Now this case is controlled, and in case we are under a Windows operative system, the backslashes are replaced with a slash. The slash can be safely used in all platforms because Java internally can handle it and do the translation into platform-specific paths.

---
M src/org/openbravo/configuration/ConfigurationApp.java
---
(0078521)
AugustoMauch (developer)
2015-06-25 18:47

Code reviewed and verified in [1]@5932cc502f4d

[1] https://code.openbravo.com/erp/backports/3.0PR15Q2.3 [^]

- Issue History
Date Modified Username Field Change
2015-06-25 11:21 caristu Type defect => backport
2015-06-25 11:21 caristu Target Version => 3.0PR15Q2.3
2015-06-25 15:53 dmitry_mezentsev Tag Attached: Approved
2015-06-25 16:17 caristu Issue Monitored: AugustoMauch
2015-06-25 16:17 caristu Review Assigned To => AugustoMauch
2015-06-25 16:17 caristu Web browser Google Chrome => Google Chrome
2015-06-25 16:18 hgbot Checkin
2015-06-25 16:18 hgbot Note Added: 0078514
2015-06-25 16:18 hgbot Status scheduled => resolved
2015-06-25 16:18 hgbot Resolution open => fixed
2015-06-25 16:18 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q2.3/rev/5932cc502f4d2b871ffa4baf55f0fd6aa6b250fe [^]
2015-06-25 18:47 AugustoMauch Note Added: 0078521
2015-06-25 18:47 AugustoMauch Status resolved => closed
2015-06-25 18:47 AugustoMauch Fixed in Version => 3.0PR15Q2.3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker