Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030135
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2015-06-09 13:112015-06-25 18:46
ReportermalsasuaView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revision988d6933a2bd
ProjectionnoneETAnoneTarget Version3.0PR15Q3
OSWindowsDatabasePostgreSQLJava version1.6.0_18
OS VersionCommunity ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browserGoogle Chrome
ModulesCore
Regression levelProduction - QA Approved
Regression date2014-11-18
Regression introduced in release3.0PR15Q1
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/f7b4f6a3f08247b63fa6448a07187614d49de952 [^]
Triggers an Emergency PackNo
Summary

0030135: On windows the 'ant setup' tool writes incorrect source.path to Openbravo.properties (not using \\ for a \)

DescriptionUsing 'ant setup' the tool writes source.path automatically but does not follow proper encoding of java properties files which required \\ to be used when a \ character is wanted as is

Effect of this is that any code using source.path (i.e. MMC, obx module installation and/or updates does not work)

Workaround is to manually edit source.path to have \\ for each \ which is wanted.

Note: Same applies to any path in properties (i.e. also attach.path)
Steps To ReproduceIn Windows OS:
.as system administrator, go to module management window
. select a obx file to install module
. error is returned:

Error: Error
org.openbravo.service.web.ResourceNotFoundException: Source file [C:openbravoerpopenbravo\src-db\database\model\tables\AD_MODULE.xml] can not be found. Verify 'source.path' property is properly set in Openbravo.properties file.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00302443.0PR15Q2.3 closedcaristu On windows the 'ant setup' tool writes incorrect source.path to Openbravo.properties (not using \\ for a \) 
caused by defect 00275423.0PR15Q1 closedinigosanchez Error in executing setup-properties-windows.exe in Windows 7 Ultimate 
has duplicate defect 00302833.0PR15Q3 closedplatform Openbravo does not work in windows 

-  Notes
(0078193)
shuehner (administrator)
2015-06-10 17:59

Custom installation guide now as a special note to remember the \ quoting rule and also points to this (not yet fixed) issue.
(0078504)
hgbot (developer)
2015-06-25 12:40

Repository: erp/devel/pi
Changeset: 988d6933a2bd1809b5f8276533fd3d4191f3ec88
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Jun 25 12:38:04 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/988d6933a2bd1809b5f8276533fd3d4191f3ec88 [^]

Fixes 30135: On windows the ant setup tool writes incorrect source.path

The ant setup tool was writing an incorrect source.path because the user.dir property obtained under Windows contains backslashes as file separator in the path.
Now this case is controlled, and in case we are under a Windows operative system, the backslashes are replaced with a slash. The slash can be safely used in all platforms because Java internally can handle it and do the translation into platform-specific paths

---
M src/org/openbravo/configuration/ConfigurationApp.java
---
(0078520)
AugustoMauch (developer)
2015-06-25 18:46

Code reviewed and verified in pi@431da3d3ec95

Tested both in Linux and in Windows. In windows tested both with and without blank spaces in the source.path.

- Issue History
Date Modified Username Field Change
2015-06-09 13:11 malsasua New Issue
2015-06-09 13:11 malsasua Assigned To => platform
2015-06-09 13:11 malsasua Web browser => Google Chrome
2015-06-09 13:11 malsasua Modules => Core
2015-06-09 13:11 malsasua Triggers an Emergency Pack => No
2015-06-09 13:18 malsasua Web browser Google Chrome => Google Chrome
2015-06-09 13:18 malsasua Severity major => minor
2015-06-10 17:59 shuehner Web browser Google Chrome => Google Chrome
2015-06-10 17:59 shuehner Note Added: 0078193
2015-06-10 17:59 shuehner Summary in windows, obx module can not be installed => On windows the 'ant setup' tool writes incorrect source.path to Openbravo.properties (not using \\ for a \)
2015-06-10 17:59 shuehner Description Updated View Revisions
2015-06-15 10:02 alostale Status new => acknowledged
2015-06-19 11:24 alostale Assigned To platform => inigosanchez
2015-06-24 10:50 inigosanchez Web browser Google Chrome => Google Chrome
2015-06-24 10:50 inigosanchez OS 20 => 10
2015-06-24 10:50 inigosanchez Steps to Reproduce Updated View Revisions
2015-06-24 17:20 inigosanchez Status acknowledged => scheduled
2015-06-24 19:18 caristu Note Added: 0078496
2015-06-24 19:18 caristu Note Edited: 0078496 View Revisions
2015-06-25 08:45 caristu Note Deleted: 0078496
2015-06-25 11:20 caristu Assigned To inigosanchez => caristu
2015-06-25 11:20 caristu Status scheduled => acknowledged
2015-06-25 11:21 caristu Status acknowledged => scheduled
2015-06-25 11:21 caristu Note Added: 0078498
2015-06-25 11:24 caristu Web browser Google Chrome => Google Chrome
2015-06-25 11:24 caristu Regression level => Production - QA Approved
2015-06-25 11:24 caristu Regression date => 2014-11-18
2015-06-25 11:24 caristu Regression introduced in release => 3.0PR15Q1
2015-06-25 11:24 caristu Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/f7b4f6a3f08247b63fa6448a07187614d49de952 [^]
2015-06-25 12:29 caristu Issue Monitored: AugustoMauch
2015-06-25 12:29 caristu Review Assigned To => AugustoMauch
2015-06-25 12:29 caristu Web browser Google Chrome => Google Chrome
2015-06-25 12:40 hgbot Checkin
2015-06-25 12:40 hgbot Note Added: 0078504
2015-06-25 12:40 hgbot Status scheduled => resolved
2015-06-25 12:40 hgbot Resolution open => fixed
2015-06-25 12:40 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/988d6933a2bd1809b5f8276533fd3d4191f3ec88 [^]
2015-06-25 12:40 caristu Web browser Google Chrome => Google Chrome
2015-06-25 12:40 caristu Target Version => 3.0PR15Q3
2015-06-25 15:52 dmitry_mezentsev Relationship added caused by 0027542
2015-06-25 16:35 caristu Note Deleted: 0078498
2015-06-25 18:46 AugustoMauch Note Added: 0078520
2015-06-25 18:46 AugustoMauch Status resolved => closed
2015-06-25 18:46 AugustoMauch Fixed in Version => 3.0PR15Q3
2015-06-30 07:50 alostale Relationship added has duplicate 0030283


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker