Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030138
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2015-06-09 13:402016-02-02 09:35
ReporteraferrazView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision3eaa0f22f0db
ProjectionnoneETAnoneTarget Version3.0PR15Q3
OSLinux 64 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2015-03-17
Regression introduced in release3.0PR15Q1.2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/fb806ae22a47f529125e7528e58c0985b0238898 [^]
Triggers an Emergency PackNo
Summary

0030138: Error in Add Payment when generating credit and adding a negative line

DescriptionError in Add Payment when generating credit and adding a negative line
Steps To ReproduceAs F&B Admin:

- Create a Payment In from "Alimentos y Supermercados" and amount = 10
  Click on Add Details button
  Uncheck all records in Order/Invoice grid
  Add a G/L Item = "Capital social" and Paid Out = 1
  Set Action Regarding Document = "Process Received Payment(s) and Deposit" and Overpayment Action = "Leave the credit to be used later"
  Realize an error is shown: "Credit amount should not be greater than total amount"
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00301393.0PR15Q2.2 closedaferraz Error in Add Payment when generating credit and adding a negative line 
depends on backport 00301403.0PR15Q1.5 closedaferraz Error in Add Payment when generating credit and adding a negative line 
caused by defect 0029145 closedSandrahuguet Used credit is not correct under certain circumstances 
blocks defect 00300773.0PR15Q4 closedaferraz Customer Balance not working properly with multicurrency credit 

-  Notes
(0078158)
aferraz (developer)
2015-06-09 14:12

Test plan:

As F&B Admin:

- Create a Payment In from "Alimentos y Supermercados" and amount = 10
  Click on Add Details button
  Uncheck all records in Order/Invoice grid
  Add a G/L Item = "Capital social" and Paid Out = 1
  Set Action Regarding Document = "Process Received Payment(s) and Deposit" and Overpayment Action = "Leave the credit to be used later"
  Realize no error is shown

- Go to Payment In and create a new payment with this data:
  Paying to: Restaurantes Luna Llena, S.A.
  Amount: 3000.00
  Click Add Details button and complete the pop-up:
  Actual Payment: 3000
  Action Regarding Document: Process Received Payment(s)
  Overpayment Action: Leave the credit to be used later
  Click Done button

- Go to Sales Invoice and create new:
  Organization: F&B España - Región Norte
  Business Partner: Restaurantes Luna Llena, S.A.
  Lines: Cerveza Ale 0,5L ; Qty:1000
  Complete it

- Go to Payment In and create a new payment with this data:
  Paying to: Restaurantes Luna Llena, S.A.
  Amount 0
  Click Add Details button and complete the pop-up:
  Actual Payment: 0.00
  On Credit To Use, check off the credit created in previous step and set payment amount to 3000,00
  In order/invoices grid select the invoice created in previous step (2468.40 amount)
  Action Regarding Document: Process Received Payment(s)
  Overpayment Action: Leave the credit to be used later
  Click Done button
  Realize an error is shown: "Credit amount should not be greater than total amount"

- Repeat the same test with Payment Out flow.
(0078213)
hgbot (developer)
2015-06-11 16:24

Repository: erp/devel/pi
Changeset: 3eaa0f22f0db3c3bfcb3cfad6abbd8bd0e5b1246
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Wed Jun 10 16:55:01 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/3eaa0f22f0db3c3bfcb3cfad6abbd8bd0e5b1246 [^]

Fixes issue 30138: Error when generating credit and adding a negative line

Add Payment was raising an error if credit used was greater than total amount.
Now, this comprobation will only be done if some record has been selected in Credit To Use grid.

---
M modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-addPayment.js
---
(0078216)
vmromanos (developer)
2015-06-11 16:29

Code review + testing OK
(0078225)
hudsonbot (developer)
2015-06-11 22:43

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/559a6242635c [^]
Maturity status: Test
(0083808)
hgbot (developer)
2016-02-02 09:35

Repository: tools/automation/int
Changeset: 0bd4b1d3c8f4bdb75700196c1b33f31d24b52f75
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Fri Sep 25 09:42:47 2015 +0200
URL: http://code.openbravo.com/tools/automation/int/rev/0bd4b1d3c8f4bdb75700196c1b33f31d24b52f75 [^]

Related to issue 30138: Added some automated tests

---
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/RegressionSuite.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/build.xml
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APRRegression023.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APRRegression024.java
---

- Issue History
Date Modified Username Field Change
2015-06-09 13:40 aferraz New Issue
2015-06-09 13:40 aferraz Assigned To => aferraz
2015-06-09 13:40 aferraz Modules => Core
2015-06-09 13:40 aferraz Regression level => Production - Confirmed Stable
2015-06-09 13:40 aferraz Regression date => 2015-03-17
2015-06-09 13:40 aferraz Regression introduced in release => 3.0PR15Q2
2015-06-09 13:40 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/fb806ae22a47f529125e7528e58c0985b0238898 [^]
2015-06-09 13:40 aferraz Triggers an Emergency Pack => No
2015-06-09 13:41 aferraz Relationship added blocks 0030077
2015-06-09 13:42 aferraz Steps to Reproduce Updated View Revisions
2015-06-09 13:42 aferraz Relationship added caused by 0029145
2015-06-09 13:58 aferraz Status new => scheduled
2015-06-09 14:12 aferraz Note Added: 0078158
2015-06-11 16:24 hgbot Checkin
2015-06-11 16:24 hgbot Note Added: 0078213
2015-06-11 16:24 hgbot Status scheduled => resolved
2015-06-11 16:24 hgbot Resolution open => fixed
2015-06-11 16:24 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3eaa0f22f0db3c3bfcb3cfad6abbd8bd0e5b1246 [^]
2015-06-11 16:29 vmromanos Review Assigned To => vmromanos
2015-06-11 16:29 vmromanos Note Added: 0078216
2015-06-11 16:29 vmromanos Status resolved => closed
2015-06-11 19:59 dmitry_mezentsev Regression introduced in release 3.0PR15Q2 => 3.0PR15Q1.2
2015-06-11 22:43 hudsonbot Checkin
2015-06-11 22:43 hudsonbot Note Added: 0078225
2016-02-02 09:35 hgbot Checkin
2016-02-02 09:35 hgbot Note Added: 0083808


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker