Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030134
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2015-06-09 12:492015-06-30 00:54
ReporteraferrazView Statuspublic 
Assigned ToNaroaIriarte 
PriorityhighResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revisione28ea5f9e072
ProjectionnoneETAnoneTarget Version3.0PR15Q3
OSLinux 64 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030134: Error when executing a Process Definition if a parameter has defined a numeric default value

DescriptionError when executing a Process Definition if a parameter has defined a numeric default value
Steps To ReproduceAs System Admin:

- Open "Set New Currency" in Process Definition window
  Open "Rate" in Parameter tab
  Realize default value is = 1 (if not, set it)

As F&B Admin:

- Select any record in Business Partner window
  Click on "Set New Currency" button
  Realize in chrome console the following exception is raised: "Uncaught TypeError: numberStr.match is not a function"
Proposed SolutionIn ob-utilities-number.js check if numberStr is a number instead of a string and in this case convert it to string before accessing to numberStr.match and to numberStr.substring
TagsNo tags attached.
Attached Filesdiff file icon issue30134.diff [^] (1,901 bytes) 2015-06-25 16:33 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00300773.0PR15Q4 closedaferraz Customer Balance not working properly with multicurrency credit 

-  Notes
(0078538)
hgbot (developer)
2015-06-26 14:25

Repository: erp/devel/pi
Changeset: e28ea5f9e072de849b72e2b815c140cd5a2ae54f
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Thu Jun 25 16:37:07 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/e28ea5f9e072de849b72e2b815c140cd5a2ae54f [^]

Fixed issue 30134: Error executing a process definition if a param. is numeric

The problem was that if a parameter was defined as default with a numeric value,
an error was got.

The problem was in the "ob-parameter-window-view.js", there is a function called
getTypeSafeValue which was not taking into account the fact of having the "value"
argument as a numeric value. That was why it was not working fine.

To fix this a new condition has been added. Now it is checked if the "value" parameter
is a number.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-parameter-window-view.js
---
(0078539)
caristu (developer)
2015-06-26 14:28

Code review + tested OK
(0078578)
hudsonbot (developer)
2015-06-30 00:54

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8d846f99ad0b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-06-09 12:49 aferraz New Issue
2015-06-09 12:49 aferraz Assigned To => platform
2015-06-09 12:49 aferraz Modules => Core
2015-06-09 12:49 aferraz Triggers an Emergency Pack => No
2015-06-09 12:52 aferraz Relationship added related to 0030077
2015-06-18 09:18 alostale Priority normal => high
2015-06-18 09:18 alostale Status new => acknowledged
2015-06-18 09:18 alostale Assigned To platform => NaroaIriarte
2015-06-24 19:10 caristu Status acknowledged => scheduled
2015-06-25 16:31 NaroaIriarte Issue Monitored: alostale
2015-06-25 16:31 NaroaIriarte Review Assigned To => alostale
2015-06-25 16:33 NaroaIriarte File Added: issue30134.diff
2015-06-26 14:16 NaroaIriarte Review Assigned To alostale => caristu
2015-06-26 14:16 NaroaIriarte Issue Monitored: caristu
2015-06-26 14:25 hgbot Checkin
2015-06-26 14:25 hgbot Note Added: 0078538
2015-06-26 14:25 hgbot Status scheduled => resolved
2015-06-26 14:25 hgbot Resolution open => fixed
2015-06-26 14:25 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e28ea5f9e072de849b72e2b815c140cd5a2ae54f [^]
2015-06-26 14:25 caristu Fixed in Version => 3.0PR15Q3
2015-06-26 14:28 caristu Note Added: 0078539
2015-06-26 14:28 caristu Status resolved => closed
2015-06-30 00:54 hudsonbot Checkin
2015-06-30 00:54 hudsonbot Note Added: 0078578


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker