Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030096
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2015-06-04 14:072015-06-15 09:21
ReporterngarciaView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revisionba6a63e37880
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030096: Cannot filter the business partner field by ' symbol in selector drop down

DescriptionCannot filter the business partner field by ' symbol
Steps To ReproduceAs group admin role:
   Create a Business Partner as Customer and set its name with '
   Go to Sales Order screen and check the business partner is not shown in the selector combo if you enter the ' value
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0035956 closedalostale The numeric field filter does not work with operators in HQL based selectors 

-  Notes
(0078108)
alostale (developer)
2015-06-05 09:02

Quote symbol ['] doesn't work in Sales Order window for:
* BP selector drop down
* BP selector popup filter

Though it works in Sales Order window for:
* Grid filter for BP and other FK fields
* Project selector drop down
* Project selector popup filter

The problem is in Custom Query Selector and the way filter parameters are handled for them.

See java stack traces when this occurs.
(0078167)
hgbot (developer)
2015-06-10 09:07

Repository: erp/devel/pi
Changeset: ba6a63e37880800cc51ee2945a8996b35479dfbf
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Jun 10 09:05:57 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/ba6a63e37880800cc51ee2945a8996b35479dfbf [^]

Fixes issue 30096: Cannot filter the bp field by ' symbol in selector drop down

The CustomQuerySelectorDatasource was not handling the parameters of the query properly. For that reason characters like ' were not replaced as expected.
Now the parameters are mapped into a list, and replaced in the query using the setParameter() method

---
M modules/org.openbravo.userinterface.selector/src/org/openbravo/userinterface/selector/CustomQuerySelectorDatasource.java
---
(0078179)
hudsonbot (developer)
2015-06-10 15:15

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ec9a491fe07d [^]
Maturity status: Test
(0078275)
alostale (developer)
2015-06-15 09:21

code reviewed

Tested:
-Custom query selectors: now parameters are properly used for HQL
-Standard selectors
-Table and TableDir references

- Issue History
Date Modified Username Field Change
2015-06-04 14:07 ngarcia New Issue
2015-06-04 14:07 ngarcia Assigned To => platform
2015-06-04 14:07 ngarcia Modules => Core
2015-06-04 14:07 ngarcia Triggers an Emergency Pack => No
2015-06-04 14:09 ngarcia Issue Monitored: networkb
2015-06-05 08:59 alostale Summary Cannot filter the business partner field by ' symbol => Cannot filter the business partner field by ' symbol in selector drop down
2015-06-05 08:59 alostale Steps to Reproduce Updated View Revisions
2015-06-05 09:02 alostale Note Added: 0078108
2015-06-05 09:03 alostale Assigned To platform => caristu
2015-06-05 09:03 alostale Severity minor => major
2015-06-05 09:03 alostale Status new => scheduled
2015-06-10 09:06 caristu Issue Monitored: alostale
2015-06-10 09:06 caristu Review Assigned To => alostale
2015-06-10 09:07 hgbot Checkin
2015-06-10 09:07 hgbot Note Added: 0078167
2015-06-10 09:07 hgbot Status scheduled => resolved
2015-06-10 09:07 hgbot Resolution open => fixed
2015-06-10 09:07 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ba6a63e37880800cc51ee2945a8996b35479dfbf [^]
2015-06-10 15:15 hudsonbot Checkin
2015-06-10 15:15 hudsonbot Note Added: 0078179
2015-06-15 09:21 alostale Note Added: 0078275
2015-06-15 09:21 alostale Status resolved => closed
2015-06-15 09:21 alostale Fixed in Version => 3.0PR15Q3
2017-05-25 09:03 caristu Relationship added related to 0035956


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker