Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030017
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2015-05-26 16:242015-06-02 03:42
ReportermaiteView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisioneef37b346fe4
ProjectionnoneETAnoneTarget Version3.0PR15Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0030017: Should not be possible to select negative receipts when registering a Landed Cost

DescriptionShould not be possible to select negative receipts when registering a Landed Cost
Steps To Reproduce1. Register Goods Receipt for Bebidas Alegres. Add line for any product and quantity=-2. Process
2. Define Landed Cost Type referencing any account
3. Register Landed Cost document. Create register in Cost tab with amount=2. Access "Receipt" tab and realize that you are able to choose negative receipt
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00299483.0PR15Q3 closedumartirena Wrong landed cost calculation when referencing a negative goods receipt 
related to defect 0033197 closedmarkmm82 / by zero error when processing a landed cost with a goods receipt with more than one line and 0 cost 

-  Notes
(0077882)
aferraz (developer)
2015-05-29 09:42

Test plan:

- Create a Goods Receipt with two lines, one with a negative movement quantity and another with a negative movement quantity. Process it.

- Create a Goods Receipt with two lines, one with a negative movement quantity and another with a positive movement quantity. Process it.

- Run Costing Background process in Process Request window.

- Create a Landed Cost Type with any account and Distribution by Amount algorithm.

- Create a Landed Cost. Add a Landed Cost Cost with any amount.
  
- Move to Receipt tab.
  Realize first receipt does not appear in Goods Receipt selector because all its lines are negative, while second receipt does because it has at least one positive line.
  Select the second receipt in the Goods Receipt selector.
  Realize first receipt line does not appear in Goods Receipt Line selector because it has a negative movement quantity, while second receipt line does because it has at positive movement quantity.
  Keep Goods Receipt Line selector empty.
  Process the Landed Cost.

- Move to Receipt Line Amount tab.
  Realize only one record has been created, related to the positive line of the selected receipt and with the total amount of the Landed Cost Cost.

- Go to Cost Adjustment window.
  Realize an adjustment with only one line has been created, related to the positive line of the selected receipt and with the total amount of the Landed Cost Cost.

- Repeat the same flow, creating the landed cost in Goods Receipt window - Landed Cost tab, while creating the receipts, instead from the Landed Cost window. The results should be the same.
(0077923)
hgbot (developer)
2015-06-01 11:58

Repository: erp/devel/pi
Changeset: eef37b346fe41b64d05219ca8a30cb59b78742ac
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Fri May 29 09:52:37 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/eef37b346fe41b64d05219ca8a30cb59b78742ac [^]

Fixes issue 30017: Landed Cost must not be applied to negative receipt lines

Goods Receipt selector in Landed Cost window - Receipt tab, will not show receipts which does not have any positive line.
Goods Receipt Line selector in Landed Cost window - Receipt tab, will not show negative receipts lines.
Landed Cost process will not consider negative receipt lines to distribute the amount of the landed cost.

---
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_REFERENCE.xml
M src-db/database/sourcedata/OBUISEL_SELECTOR.xml
M src-db/database/sourcedata/OBUISEL_SELECTOR_FIELD.xml
M src/org/openbravo/costing/LandedCostDistributionByAmount.java
M src/org/openbravo/costing/LandedCostProcess.java
---
(0077924)
vmromanos (developer)
2015-06-01 11:59

Code review + testing OK
(0077962)
hudsonbot (developer)
2015-06-02 03:42

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/14de467bd788 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-05-26 16:24 maite New Issue
2015-05-26 16:24 maite Assigned To => Triage Finance
2015-05-26 16:24 maite Modules => Core
2015-05-26 16:24 maite Triggers an Emergency Pack => No
2015-05-26 16:24 maite Assigned To Triage Finance => umartirena
2015-05-26 16:24 maite Issue Monitored: networkb
2015-05-27 12:26 aferraz Assigned To umartirena => aferraz
2015-05-28 19:32 aferraz Status new => scheduled
2015-05-29 08:48 aferraz Status scheduled => acknowledged
2015-05-29 08:48 aferraz Status acknowledged => scheduled
2015-05-29 09:42 aferraz Note Added: 0077882
2015-06-01 11:58 hgbot Checkin
2015-06-01 11:58 hgbot Note Added: 0077923
2015-06-01 11:58 hgbot Status scheduled => resolved
2015-06-01 11:58 hgbot Resolution open => fixed
2015-06-01 11:58 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/eef37b346fe41b64d05219ca8a30cb59b78742ac [^]
2015-06-01 11:59 vmromanos Review Assigned To => vmromanos
2015-06-01 11:59 vmromanos Note Added: 0077924
2015-06-01 11:59 vmromanos Status resolved => closed
2015-06-02 03:42 hudsonbot Checkin
2015-06-02 03:42 hudsonbot Note Added: 0077962
2015-06-03 15:51 umartirena Relationship added related to 0029948
2016-06-17 13:32 aferraz Relationship added related to 0033197


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker