Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0030002
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 03. Procurement managementmajoralways2015-05-25 17:112015-05-28 01:10
ReporterngarciaView Statuspublic 
Assigned Tovmromanos 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revisionf8b937eb67f2
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2015-02-10
Regression introduced in release3.0PR15Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/07f0f908a7eb8af5a08df2c96b3ee827dcc1eb52 [^]
Triggers an Emergency PackNo
Summary

0030002: Cannot create a purchase order from the Requisition To Order window

DescriptionCannot create a purchase order from the Requisition To Order window
Steps To ReproduceAs group admin role:
   Create a Requisition and book it
   Go to the Requisition To Order window, select the line from the first grid, click on Add, select the line for the second grid, click on Create and OK
   The following error is shown:
      Process failed during execution
   And the logs shows:
java.lang.NumberFormatException
    at java.math.BigDecimal.<init>(BigDecimal.java:545)
    at java.math.BigDecimal.<init>(BigDecimal.java:739)
    at org.openbravo.erpCommon.ad_forms.RequisitionToOrder.processPurchaseOrder(RequisitionToOrder.java:570)...
Proposed SolutionIn the following instruction of the RequisitionToOrder.java file, the quantityorder field can be null:

new BigDecimal(lines[i].quantityorder)
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00300103.0PR15Q2.2 closedvmromanos Cannot create a purchase order from the Requisition To Order window 
caused by defect 00287753.0PR15Q2 closedreinaldoguerra "Order quantity" incorrectly set in Purchase Order Line when several requisition line are referenced 

-  Notes
(0077755)
aferraz (developer)
2015-05-26 12:46

Test plan:

As F&B Admin:

- Create a Requisition and book it
- Go to the Requisition To Order window, select the line from the first grid, click on Add, select the line for the second grid, click on Create and OK
- Realize Purchase Order is correctly created
(0077793)
hgbot (developer)
2015-05-27 10:35

Repository: erp/devel/pi
Changeset: f8b937eb67f22440b6ea307d50e7ff41f2641dab
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Tue May 26 18:20:34 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f8b937eb67f22440b6ea307d50e7ff41f2641dab [^]

Fixed bug 30002: Error in Requisition To Order window

When creating a purchase order from the Requisition To Order window, an error was raised when lines[i].quantityorder is empty.
Now the SQL query returns quantityorder = 0 when it's null. Then, when inserting the purchase order line, the process inserts "" if quantityorder = 0

---
M src/org/openbravo/erpCommon/ad_forms/RequisitionToOrder.java
M src/org/openbravo/erpCommon/ad_forms/RequisitionToOrder_data.xsql
---
(0077796)
aferraz (developer)
2015-05-27 10:36

Code review + Testing OK
(0077841)
hudsonbot (developer)
2015-05-28 01:10

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ae25da3bd47f [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-05-25 17:11 ngarcia New Issue
2015-05-25 17:11 ngarcia Assigned To => Triage Finance
2015-05-25 17:11 ngarcia Modules => Core
2015-05-25 17:11 ngarcia Regression level => Production - QA Approved
2015-05-25 17:11 ngarcia Regression date => 2015-02-10
2015-05-25 17:11 ngarcia Regression introduced in release => 3.0PR15Q2
2015-05-25 17:11 ngarcia Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/07f0f908a7eb8af5a08df2c96b3ee827dcc1eb52 [^]
2015-05-25 17:11 ngarcia Triggers an Emergency Pack => No
2015-05-25 17:12 ngarcia Relationship added caused by 0028775
2015-05-25 17:26 ngarcia Issue Monitored: networkb
2015-05-26 11:14 aferraz Assigned To Triage Finance => aferraz
2015-05-26 11:14 aferraz Status new => scheduled
2015-05-26 12:46 aferraz Note Added: 0077755
2015-05-26 18:33 vmromanos Assigned To aferraz => vmromanos
2015-05-27 10:35 hgbot Checkin
2015-05-27 10:35 hgbot Note Added: 0077793
2015-05-27 10:35 hgbot Status scheduled => resolved
2015-05-27 10:35 hgbot Resolution open => fixed
2015-05-27 10:35 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/f8b937eb67f22440b6ea307d50e7ff41f2641dab [^]
2015-05-27 10:36 aferraz Review Assigned To => aferraz
2015-05-27 10:36 aferraz Note Added: 0077796
2015-05-27 10:36 aferraz Status resolved => closed
2015-05-27 10:36 aferraz Fixed in Version => 3.0PR15Q3
2015-05-28 01:10 hudsonbot Checkin
2015-05-28 01:10 hudsonbot Note Added: 0077841


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker