Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029857
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2015-05-12 18:252015-06-01 10:10
ReporterjonalegriaesarteView Statuspublic 
Assigned ToNaroaIriarte 
PriorityhighResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revision1c6069a0eafa
ProjectionnoneETAnoneTarget Version3.0PR15Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029857: Linked items section in Accounting Transactions Details section is not working. It is in "Loading data" status forever

DescriptionLinked items section in Accounting Transactions Details section is not working. It is Loading data forever. It happens also in other windows, like Sales and Purchase invoices, depending on the environment (we can provide one)
Steps To Reproduce- Access to Accounting Transactions Details window
- Select one record
- Access to Linked Items section
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0077363)
alostale (developer)
2015-05-13 08:22

This issue happens whenever there is no linked item. Though the response is correctly an empty json array [], it is not properly rendered in the linked items widget.
(0077871)
hgbot (developer)
2015-05-28 16:21

Repository: erp/devel/pi
Changeset: 1c6069a0eafafd4614edad9642e7b8e5cfb86dd1
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Thu May 28 16:19:09 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/1c6069a0eafafd4614edad9642e7b8e5cfb86dd1 [^]

Fixed issue 29857: When there are not linked items it appears "Loading"

When there are no linked items, the linked items category section shows the message "Loading data..."
instead of the message "No items to show".

The problem was that the fact of not having any item category was not correctly handled.
In the initWidget function, when the linkedItemCategoryListGrid is created, in the function "dataArrived"
there was a condition which called the function that showed the correct message "No items to show" when the
startRow was '0' and when de endRow was '-1', the problem was that in this case of not having any linked Item
category, the endRow and the startRow where both '0', so, the correct message was never shown and it always shows
the message "Loading data...".
To fix this, the condition has been changed, now it is taking into account the length of the data, and if it
is '0' that means that there are not linked items so, the message "No items to show" is shown.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form-linked-items.js
---
(0077880)
hudsonbot (developer)
2015-05-28 23:19

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a95a68264f41 [^]
Maturity status: Test
(0077918)
alostale (developer)
2015-06-01 10:08

code reviewed

tested linked items both with records without linked items (in this case it correctly shows "No items to show" message and with linked items which shows them correctly.

- Issue History
Date Modified Username Field Change
2015-05-12 18:25 jonalegriaesarte New Issue
2015-05-12 18:25 jonalegriaesarte Assigned To => platform
2015-05-12 18:25 jonalegriaesarte Modules => Core
2015-05-12 18:25 jonalegriaesarte Triggers an Emergency Pack => No
2015-05-12 18:26 jonalegriaesarte Summary Linked items section in Accounting Transactions Details section is not working. It is Loading data forever => Linked items section in Accounting Transactions Details section is not working. It is in "Loading data" status forever
2015-05-13 08:22 alostale Note Added: 0077363
2015-05-13 08:22 alostale Status new => acknowledged
2015-05-25 10:26 heccam Issue Monitored: heccam
2015-05-26 13:14 alostale Status acknowledged => scheduled
2015-05-26 13:14 alostale Assigned To platform => NaroaIriarte
2015-05-28 14:56 NaroaIriarte Issue Monitored: alostale
2015-05-28 14:56 NaroaIriarte Review Assigned To => alostale
2015-05-28 16:21 hgbot Checkin
2015-05-28 16:21 hgbot Note Added: 0077871
2015-05-28 16:21 hgbot Status scheduled => resolved
2015-05-28 16:21 hgbot Resolution open => fixed
2015-05-28 16:21 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/1c6069a0eafafd4614edad9642e7b8e5cfb86dd1 [^]
2015-05-28 23:19 hudsonbot Checkin
2015-05-28 23:19 hudsonbot Note Added: 0077880
2015-06-01 10:08 alostale Note Added: 0077918
2015-06-01 10:08 alostale Status resolved => closed
2015-06-01 10:10 alostale Fixed in Version => 3.0PR15Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker