Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029731
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2015-04-29 12:192015-08-20 23:15
ReporterpsanjuanView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisiond42217b81cc7
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabaseOracleJava version1.6
OS VersionUbuntu 8.04.1Database version11.1.0.6.0Ant version1.7.0
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029731: "Value Stock Report" needs to be enhanced.

Description"Value Stock Report" needs to be enhanced.
Steps To ReproduceLaunch the Value Stock Report for a warehouse and product category at a given date.

Realize that there is only one unit "Cost" related column named as "Average Cost".

That is not correct as Openbravo can also manage other costing algorithms as "Standard Cost" for instance.
Proposed SolutionColumn named "Average Cost" needs to be renamed as "Cost".
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0029723 closedaferraz Landed Cost differences must not trigger a cost adjustment and need to be post to a "LCV" for products valued at Standard Cost. 
blocks defect 0029729 closedaferraz Differences between actual cost and standard cost (variances) should not trigger Cost Adjustments. 

-  Notes
(0078616)
hgbot (developer)
2015-07-02 10:55

Repository: erp/devel/pi
Changeset: d42217b81cc7742840158a783850b7cae801bcd5
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Thu Jul 02 10:16:44 2015 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/d42217b81cc7742840158a783850b7cae801bcd5 [^]

Fixes Issue 29731:Value Stock Report needs to be enhanced.

Column name Average cost changed to Cost.

---
M src/org/openbravo/erpCommon/ad_reports/ReportValuationStock.html
---
(0078617)
hgbot (developer)
2015-07-02 10:55

Repository: erp/devel/pi
Changeset: c5dd3e4e82e59350c58780c70d73fcf6b415b8a9
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Thu Jul 02 10:54:26 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/c5dd3e4e82e59350c58780c70d73fcf6b415b8a9 [^]

Related to issue 29731: Updated AD_TEXTINTERFACES

---
M src-db/database/sourcedata/AD_TEXTINTERFACES.xml
---
(0078619)
AtulOpenbravo (developer)
2015-07-02 10:57

Test Plan
- Login as F&B International Group Admin.
- Using quick launch, Run Value Stock Report for a warehouse and product category at a given date.
- Check that there is only one unit "Cost" related column named as "Cost".
(0078620)
vmromanos (developer)
2015-07-02 10:59

Code review + testing OK
(0079450)
hudsonbot (developer)
2015-08-20 23:15

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test
(0079451)
hudsonbot (developer)
2015-08-20 23:15

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-04-29 12:19 psanjuan New Issue
2015-04-29 12:19 psanjuan Assigned To => Triage Finance
2015-04-29 12:19 psanjuan Modules => Core
2015-04-29 12:19 psanjuan Triggers an Emergency Pack => No
2015-04-29 12:20 psanjuan Relationship added caused by 0029729
2015-04-29 12:20 psanjuan Relationship added related to 0029723
2015-04-30 14:13 psanjuan Steps to Reproduce Updated View Revisions
2015-04-30 14:13 psanjuan Proposed Solution updated
2015-04-30 14:14 psanjuan Steps to Reproduce Updated View Revisions
2015-05-04 12:31 dmitry_mezentsev Relationship replaced blocks 0029729
2015-06-24 12:42 AtulOpenbravo Assigned To Triage Finance => AtulOpenbravo
2015-06-24 12:42 AtulOpenbravo Status new => scheduled
2015-07-02 10:55 hgbot Checkin
2015-07-02 10:55 hgbot Note Added: 0078616
2015-07-02 10:55 hgbot Status scheduled => resolved
2015-07-02 10:55 hgbot Resolution open => fixed
2015-07-02 10:55 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d42217b81cc7742840158a783850b7cae801bcd5 [^]
2015-07-02 10:55 hgbot Checkin
2015-07-02 10:55 hgbot Note Added: 0078617
2015-07-02 10:57 AtulOpenbravo Note Added: 0078619
2015-07-02 10:59 vmromanos Review Assigned To => vmromanos
2015-07-02 10:59 vmromanos Note Added: 0078620
2015-07-02 10:59 vmromanos Status resolved => closed
2015-08-20 23:15 hudsonbot Checkin
2015-08-20 23:15 hudsonbot Note Added: 0079450
2015-08-20 23:15 hudsonbot Checkin
2015-08-20 23:15 hudsonbot Note Added: 0079451


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker