Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029729
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2015-04-29 12:002015-08-20 23:16
ReporterpsanjuanView Statuspublic 
Assigned Toaferraz 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionb45cf0559789
ProjectionnoneETAnoneTarget Version
OSLinux 32 bitDatabaseOracleJava version1.6
OS VersionUbuntu 8.04.1Database version11.1.0.6.0Ant version1.7.0
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029729: Differences between actual cost and standard cost (variances) should not trigger Cost Adjustments.

DescriptionDifferences between actual cost and standard cost (variances) should not trigger Cost Adjustments as the "Total Cost" and the "Unit Cost" of a transaction should not change.


Steps To Reproducen/a

Proposed SolutionDifferences between actual cost and standard cost (variances) caused by
- purchase price differences
- backdated transactions
- negative stock correction
- and manual cost correction if any,
should not trigger a cost adjustment transaction.

Above implies that:
- the "Total Cost" and the "Unit Cost" of a transaction valued at standard cost must not change.

- no cost adjustment transaction is created for products valued at "Standard Cost".

- there are some scenarios for which variances can happen even in the case of products valued at "Standard Cost", that is "purchase price differences".
Those variances will no trigger a cost adjustment but would need to be posted to a "PPV" account. For additional information see issues below:

- purchase price differences - issue 29728

Finally,

Inventory amount update - this one is working ok for standard as it creates two physical inventories (closing & opening) which posting is correct. In fact this process is the one to use to change the standard cost of a product.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0029723 closedaferraz Landed Cost differences must not trigger a cost adjustment and need to be post to a "LCV" for products valued at Standard Cost. 
depends on defect 0029728 closedaferraz Purchase price differences need to be post to a PPV account for products valued at "Standard" cost 
depends on defect 0029730 closedaferraz [Cost Adjustments] It should not be possible to manually correct the cost of a transaction valued at Standard Cost. 
depends on defect 0029731 closedAtulOpenbravo "Value Stock Report" needs to be enhanced. 
caused by feature request 0022855 closeddmiguelez It would be fine to have the cost adjustment functionality implemented 
blocks defect 0029702 closedaferraz Java.lang.NullPointerException after launching the Costing Background process in a product under "Standard" algorithm 

-  Notes
(0077018)
psanjuan (manager)
2015-05-05 16:22

When programming the software we should be aware that there are more types of variances than only PPV.

In general, variances occur when there is a difference between the standard and actual costs and this relates to purchased and manufactured goods.
(Implicitly -> variances do not occur when using average costing).
So instead of coding directly towards a PPV, it would structurally be better if the software would be prepared to handle different causes of variances:

·Differences with actual costs coming from purchase invoices - PPV

·Differences with actual costs coming from landed cost invoices - Landed costs variance

· Differences with actual costs coming from manufacturing (work order postings) can have several causes and should be recognized individually:

o Usage variance –> when a different/substitute material was consumed

o Material variance –> when a different qty of the same material was consumed

o Method variance -> when a different routing/machine was used, could have caused 0 cost-difference

o Labor variance –> when a different qty of hours was consumed.

Additionally, if would be good if we could show the cost-element / sub-element that is affected by the variance (can be multiple).

COST ELEMENTS

1 Material = the costs of acquiring (manufactured or purchased) 1 unit of the material.

· SUB ELEMENTS – Only applicable in case of “Landed costs”, and if a) purchased b) specific IncoTerms.

· Duties

· Freight

· Insurance

2 Labor – only manufactured goods. Costs of salaries of direct labor

3 Overhead – Costs of all indirect services: renting of building, salaries of indirect personnel, etc.

4 Burden – only manufacturing - Costs of electricity, water, etc. directly related to the processing of the material.

5 Subcontracting - only manufacturing - Costs of outsourced sub-processes
(0078677)
psanjuan (manager)
2015-07-06 14:43

Differences with actual cost coming from manufacturing - Not implemented yet.

Differences with actual costs coming from purchase invoices (price differences) - Implemented. See issue 29728 - verified it is working properly.

Differences with actual cost coming from landed cost invoices - Implemented. See issue 29723 - Verified it is working properly.

Backdated transactions scenarios does not imply the creation of any cost adjustment when working with products under Standard costing algorithm.

Negative stock correction does not imply the creation of any cost adjustment when working with products under Standard costing algorithm. See issue 29702.

Not possible to manually adjust transactions valued at standard cost. Verified. See issue 29730
(0078678)
hgbot (developer)
2015-07-06 15:56

Repository: erp/devel/pi
Changeset: b45cf0559789653c61099068e3954a76a3bec0b5
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Thu Jul 02 15:12:55 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b45cf0559789653c61099068e3954a76a3bec0b5 [^]

Fixes issue 29729 & Fixes issue 29702 & Fixes issue 29728

Cost Adjustments will not be created in transactions calculated with Standard Algorithm.

---
M src/org/openbravo/costing/CostingServer.java
M src/org/openbravo/costing/PriceDifferenceProcess.java
---
(0079037)
aferraz (developer)
2015-07-23 09:40

Reopened as the fix is not correct
(0079184)
hgbot (developer)
2015-08-04 13:39

Repository: erp/devel/pi
Changeset: db0267697acd7b33bfdb98eae4e88d3dfa2402f3
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Tue Jul 14 14:31:22 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/db0267697acd7b33bfdb98eae4e88d3dfa2402f3 [^]

Related to issue 29729: Change the check in CostingServer

The check of Standard Algorithm in CostingServer should be done after check if landed cost need to be processed

---
M src/org/openbravo/costing/CostingServer.java
---
(0079185)
vmromanos (developer)
2015-08-04 13:41

Code review OK.
Functional test review by psanjuan.
(0079474)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test
(0079522)
hudsonbot (developer)
2015-08-20 23:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8c91718397a5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-04-29 12:00 psanjuan New Issue
2015-04-29 12:00 psanjuan Assigned To => Triage Finance
2015-04-29 12:00 psanjuan Modules => Core
2015-04-29 12:00 psanjuan Triggers an Emergency Pack => No
2015-04-29 12:01 psanjuan Relationship added causes 0029723
2015-04-29 12:02 psanjuan Relationship added causes 0029728
2015-04-29 12:05 psanjuan Description Updated View Revisions
2015-04-29 12:05 psanjuan Steps to Reproduce Updated View Revisions
2015-04-29 12:10 psanjuan Steps to Reproduce Updated View Revisions
2015-04-29 12:10 psanjuan Relationship added causes 0029730
2015-04-29 12:20 psanjuan Relationship added causes 0029731
2015-04-30 09:49 psanjuan Description Updated View Revisions
2015-04-30 09:49 psanjuan Proposed Solution updated
2015-04-30 13:45 psanjuan Description Updated View Revisions
2015-04-30 13:45 psanjuan Steps to Reproduce Updated View Revisions
2015-04-30 13:45 psanjuan Proposed Solution updated
2015-04-30 13:56 psanjuan Description Updated View Revisions
2015-04-30 13:56 psanjuan Steps to Reproduce Updated View Revisions
2015-04-30 13:56 psanjuan Proposed Solution updated
2015-04-30 13:57 psanjuan Relationship added causes 0029702
2015-04-30 13:58 psanjuan Relationship deleted causes 0029702
2015-04-30 13:58 psanjuan Relationship added blocks 0029702
2015-04-30 14:40 psanjuan Proposed Solution updated
2015-05-04 12:30 dmitry_mezentsev Relationship replaced depends on 0029723
2015-05-04 12:30 dmitry_mezentsev Relationship replaced depends on 0029728
2015-05-04 12:31 dmitry_mezentsev Relationship replaced depends on 0029730
2015-05-04 12:31 dmitry_mezentsev Relationship replaced depends on 0029731
2015-05-04 12:40 dmitry_mezentsev Relationship added caused by 0022855
2015-05-05 16:22 psanjuan Note Added: 0077018
2015-05-29 14:47 psanjuan Summary Differences between actual cost and standard cost (variances) should not be managed as Cost Adjustments. => Differences between actual cost and standard cost (variances) should not trigger Cost Adjustments.
2015-05-29 14:47 psanjuan Description Updated View Revisions
2015-05-29 14:47 psanjuan Proposed Solution updated
2015-06-11 16:29 aferraz Assigned To Triage Finance => aferraz
2015-07-06 14:43 psanjuan Note Added: 0078677
2015-07-06 15:46 vmromanos Status new => scheduled
2015-07-06 15:56 hgbot Checkin
2015-07-06 15:56 hgbot Note Added: 0078678
2015-07-06 15:56 hgbot Status scheduled => resolved
2015-07-06 15:56 hgbot Resolution open => fixed
2015-07-06 15:56 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b45cf0559789653c61099068e3954a76a3bec0b5 [^]
2015-07-07 11:32 vmromanos Relationship deleted depends on 0029723
2015-07-07 11:32 vmromanos Relationship added related to 0029723
2015-07-07 11:32 vmromanos Review Assigned To => vmromanos
2015-07-07 11:32 vmromanos Status resolved => closed
2015-07-23 09:39 aferraz Status closed => new
2015-07-23 09:39 aferraz Resolution fixed => open
2015-07-23 09:40 aferraz Status new => scheduled
2015-07-23 09:40 aferraz Note Added: 0079037
2015-08-04 13:39 hgbot Checkin
2015-08-04 13:39 hgbot Note Added: 0079184
2015-08-04 13:40 vmromanos Status scheduled => resolved
2015-08-04 13:40 vmromanos Resolution open => fixed
2015-08-04 13:41 vmromanos Note Added: 0079185
2015-08-04 13:41 vmromanos Status resolved => closed
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079474
2015-08-20 23:16 hudsonbot Checkin
2015-08-20 23:16 hudsonbot Note Added: 0079522


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker