Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029653
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2015-04-21 12:382016-02-02 09:35
ReportervmromanosView Statuspublic 
Assigned Tovmromanos 
PriorityimmediateResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revision0b8b1170fe70
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toumartirena
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-08-21
Regression introduced in release3.0PR14Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/8a0d6c8c1eb1 [^]
Triggers an Emergency PackNo
Summary

0029653: Payments belonging child orgs can't be added to manual transactions

DescriptionThe payments belonging to a child organization can't be added to manual transactions because they aren't shown in the payment selector
Steps To Reproduce1. Create a Purchase Invoice:
IMPORTANT-> Org: España - Region Norte
IMPORTANT-> Payment method: Cheque (ensure Automatic Withdrawn = N in the financial account)
2. Enter any line and complete the invoice
3. Press Add payment and add a new payment. Select "Process Made Payment" to ensure the transaction is not automatically created
4. Go to Financial Account -> Cuenta de Banco and enter a new transaction
5. Select type = BP Withdrawal. Verify the previously created payment is not shown.


You can repeat these steps, but this time creating the invoice for "España" organization and you will see the new created payment
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00296543.0PR15Q2 closedvmromanos Payments belonging child orgs can't be added to manual transactions 
depends on backport 00296553.0PR15Q1.4 closedvmromanos Payments belonging child orgs can't be added to manual transactions 
caused by feature request 0029387 closedSandrahuguet Transaction refactor project 
related to defect 0032093 closedTriage Finance [SERQA 627] Payments done in generic orgs can not be selected from a financial account deffined on its legal entity org 

-  Notes
(0076664)
vmromanos (developer)
2015-04-21 16:35

Test plan I:
1. Follow steps to reproduce
2. Verify the payment is shown in the selector

Test plan II:
1. Follow steps to reproduce, from 1) to 3)
2. Go to Financial Account -> Bank Account 1 and enter a new transaction
3. Select type = BP Withdrawal. Verify the previously created payment is not shown.
(0076688)
hgbot (developer)
2015-04-22 13:05

Repository: erp/devel/pi
Changeset: 0b8b1170fe70d78f312cc0f2a7d57e046bd81dd7
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Tue Apr 21 14:18:22 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/0b8b1170fe70d78f312cc0f2a7d57e046bd81dd7 [^]

Fixed bug 29653: Payment selector now filters by child organizations

The payment selector was incorrectly filtering by child organizations because the order of the parameters in the call to the AD_ISORGINCLUDED function was wrong.

It now gets all the payments belonging to the organization and any child organization of the tab's organization.

---
M src-db/database/sourcedata/OBUISEL_SELECTOR.xml
---
(0076704)
umartirena (developer)
2015-04-22 17:24

Code Review + Testing OK
(0077142)
hudsonbot (developer)
2015-05-07 22:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test
(0083809)
hgbot (developer)
2016-02-02 09:35

Repository: tools/automation/int
Changeset: 39b8428f074523b21aa6e0b95c70f79425b2b64e
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Fri Sep 25 09:44:57 2015 +0200
URL: http://code.openbravo.com/tools/automation/int/rev/39b8428f074523b21aa6e0b95c70f79425b2b64e [^]

Related to issue 29653: Added some automated tests

---
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/RegressionSuite.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/build.xml
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APRRegression025.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APRRegression026.java
---

- Issue History
Date Modified Username Field Change
2015-04-21 12:38 vmromanos New Issue
2015-04-21 12:38 vmromanos Assigned To => Triage Finance
2015-04-21 12:38 vmromanos Modules => Core
2015-04-21 12:38 vmromanos Triggers an Emergency Pack => No
2015-04-21 12:42 vmromanos Regression level => Production - Confirmed Stable
2015-04-21 12:42 vmromanos Regression date => 2014-08-21
2015-04-21 12:42 vmromanos Regression introduced in release => 3.0PR14Q4
2015-04-21 12:42 vmromanos Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/8a0d6c8c1eb1 [^]
2015-04-21 12:42 vmromanos Steps to Reproduce Updated View Revisions
2015-04-21 12:43 vmromanos Status new => scheduled
2015-04-21 12:44 vmromanos Relationship added caused by 0029387
2015-04-21 12:46 vmromanos Assigned To Triage Finance => vmromanos
2015-04-21 16:35 vmromanos Note Added: 0076664
2015-04-21 16:35 vmromanos Steps to Reproduce Updated View Revisions
2015-04-21 18:43 umartirena Review Assigned To => umartirena
2015-04-22 13:05 hgbot Checkin
2015-04-22 13:05 hgbot Note Added: 0076688
2015-04-22 13:05 hgbot Status scheduled => resolved
2015-04-22 13:05 hgbot Resolution open => fixed
2015-04-22 13:05 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/0b8b1170fe70d78f312cc0f2a7d57e046bd81dd7 [^]
2015-04-22 17:24 umartirena Note Added: 0076704
2015-04-22 17:24 umartirena Status resolved => closed
2015-04-22 17:24 umartirena Fixed in Version => pi
2015-05-07 22:16 hudsonbot Checkin
2015-05-07 22:16 hudsonbot Note Added: 0077142
2016-02-02 09:35 hgbot Checkin
2016-02-02 09:35 hgbot Note Added: 0083809
2016-02-08 12:19 vmromanos Relationship added related to 0032093


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker