Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029628
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformminoralways2015-04-16 10:052015-04-22 09:50
ReporterjecharriView Statuspublic 
Assigned Toinigosanchez 
PriorityhighResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revisiona1933ab8b811
ProjectionnoneETAnoneTarget Version3.0PR15Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browserGoogle Chrome
ModulesCore
Regression levelProduction - QA Approved
Regression date2014-11-18
Regression introduced in release3.0PR15Q1
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/f7b4f6a3f08247b63fa6448a07187614d49de952 [^]
Triggers an Emergency PackNo
Summary

0029628: The new way to create to do the setup is not taking into account the context name that users are configuring

DescriptionThe new way to create to do the setup is not taking into account the context name that users are configuring. The context name in eclipse always will be openbravo instead of the name that users decide to configure
Steps To Reproduce-in a environment with higher version than Q1 execute ant setup
-decide to configure step by step
-set the context name as "test"
-set also context URL to "http://localhost/test" [^]
-mount the environment in eclipse
-verify that after running tomcat the URL to go to Openbravo is
http://localhost:8080/openbravo [^]
instead of
http://localhost:8080/test [^]
Proposed SolutionI think that the problem is that the new process is not updating file
org.eclipse.wst.common.component
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00296073.0PR15Q3 closedinigosanchez The new way to create to do the setup is not taking into account the context name that users are configuring 

-  Notes
(0076620)
hgbot (developer)
2015-04-20 09:40

Repository: erp/backports/3.0PR15Q2
Changeset: a1933ab8b811de143739a763477d1a4e40f8412e
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Mon Apr 20 09:31:41 2015 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR15Q2/rev/a1933ab8b811de143739a763477d1a4e40f8412e [^]

Fixed bug 29628: setup application is not taking into account the context name

The setup application is not taking into account the context name that users
are configuring. The values of "deploy-name" and "context-root" properties
of org.eclipse.wst.common.component are not updating.

Now it has been solved and if user set "context-name" in setup application.
this value is updating in org.eclipse.wst.common.component. For example if
a user set the context name as "test" the URL to go to Openbravo is
"http://localhost:8080/test" [^] instead of default one "http://localhost:8080/openbravo". [^]

---
M src/org/openbravo/configuration/ConfigurationApp.java
---
(0076676)
alostale (developer)
2015-04-22 09:50

code reviewed + tested

- Issue History
Date Modified Username Field Change
2015-04-17 14:33 inigosanchez Type defect => backport
2015-04-17 14:33 inigosanchez Target Version 3.0PR15Q3 => 3.0PR15Q2
2015-04-17 15:17 dmitry_mezentsev Tag Attached: Approved
2015-04-20 09:39 inigosanchez Issue Monitored: alostale
2015-04-20 09:40 hgbot Checkin
2015-04-20 09:40 hgbot Note Added: 0076620
2015-04-20 09:40 hgbot Status scheduled => resolved
2015-04-20 09:40 hgbot Resolution open => fixed
2015-04-20 09:40 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/392e1fbd55bfac1b07ad9e26027e66d5d735ba91 [^] => http://code.openbravo.com/erp/backports/3.0PR15Q2/rev/a1933ab8b811de143739a763477d1a4e40f8412e [^]
2015-04-22 09:50 alostale Note Added: 0076676
2015-04-22 09:50 alostale Status resolved => closed
2015-04-22 09:50 alostale Fixed in Version => 3.0PR15Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker