Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029607
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2015-04-16 10:052015-05-07 22:16
ReporterjecharriView Statuspublic 
Assigned Toinigosanchez 
PriorityhighResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revision392e1fbd55bf
ProjectionnoneETAnoneTarget Version3.0PR15Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browserGoogle Chrome
ModulesCore
Regression levelProduction - QA Approved
Regression date2014-11-18
Regression introduced in release3.0PR15Q1
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/f7b4f6a3f08247b63fa6448a07187614d49de952 [^]
Triggers an Emergency PackNo
Summary

0029607: The new way to create to do the setup is not taking into account the context name that users are configuring

DescriptionThe new way to create to do the setup is not taking into account the context name that users are configuring. The context name in eclipse always will be openbravo instead of the name that users decide to configure
Steps To Reproduce-in a environment with higher version than Q1 execute ant setup
-decide to configure step by step
-set the context name as "test"
-set also context URL to "http://localhost/test" [^]
-mount the environment in eclipse
-verify that after running tomcat the URL to go to Openbravo is
http://localhost:8080/openbravo [^]
instead of
http://localhost:8080/test [^]
Proposed SolutionI think that the problem is that the new process is not updating file
org.eclipse.wst.common.component
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00296283.0PR15Q2 closedinigosanchez The new way to create to do the setup is not taking into account the context name that users are configuring 
depends on backport 00296293.0PR15Q1.4 closedinigosanchez The new way to create to do the setup is not taking into account the context name that users are configuring 
caused by defect 00275423.0PR15Q1 closedinigosanchez Error in executing setup-properties-windows.exe in Windows 7 Ultimate 

-  Notes
(0076604)
hgbot (developer)
2015-04-17 12:33

Repository: erp/devel/pi
Changeset: 392e1fbd55bfac1b07ad9e26027e66d5d735ba91
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Fri Apr 17 12:31:27 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/392e1fbd55bfac1b07ad9e26027e66d5d735ba91 [^]

Fixed bug 29607: setup application is not taking into account the context name

The setup application is not taking into account the context name that users
are configuring. The values of "deploy-name" and "context-root" properties
of org.eclipse.wst.common.component are not updating.

Now it has been solved and if user set "context-name" in setup application.
this value is updating in org.eclipse.wst.common.component. For example if
a user set the context name as "test" the URL to go to Openbravo is
"http://localhost:8080/test" [^] instead of default one "http://localhost:8080/openbravo". [^]

---
M src/org/openbravo/configuration/ConfigurationApp.java
---
(0076611)
inigosanchez (developer)
2015-04-17 14:55

NOTE: Remember delete and add a new tomcat server to achieve that system take into account the new context name.
(0076675)
alostale (developer)
2015-04-22 09:49

code reviewed + tested
(0077134)
hudsonbot (developer)
2015-05-07 22:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-04-16 10:05 jecharri New Issue
2015-04-16 10:05 jecharri Assigned To => platform
2015-04-16 10:05 jecharri Web browser => Google Chrome
2015-04-16 10:05 jecharri Modules => Core
2015-04-16 10:05 jecharri Regression level => Production - QA Approved
2015-04-16 10:05 jecharri Regression introduced in release => 3.0PR15Q1
2015-04-16 10:05 jecharri Triggers an Emergency Pack => No
2015-04-16 11:17 alostale Relationship added related to 0027542
2015-04-16 13:14 jecharri Web browser Google Chrome => Google Chrome
2015-04-16 13:14 jecharri Steps to Reproduce Updated View Revisions
2015-04-17 11:37 inigosanchez Assigned To platform => inigosanchez
2015-04-17 11:51 inigosanchez Web browser Google Chrome => Google Chrome
2015-04-17 11:51 inigosanchez Regression date => 2014-11-18
2015-04-17 11:51 inigosanchez Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/f7b4f6a3f08247b63fa6448a07187614d49de952 [^]
2015-04-17 11:54 inigosanchez Relationship replaced caused by 0027542
2015-04-17 12:32 inigosanchez Review Assigned To => alostale
2015-04-17 12:32 inigosanchez Web browser Google Chrome => Google Chrome
2015-04-17 12:33 hgbot Checkin
2015-04-17 12:33 hgbot Note Added: 0076604
2015-04-17 12:33 hgbot Status new => resolved
2015-04-17 12:33 hgbot Resolution open => fixed
2015-04-17 12:33 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/392e1fbd55bfac1b07ad9e26027e66d5d735ba91 [^]
2015-04-17 14:32 inigosanchez Status resolved => new
2015-04-17 14:32 inigosanchez Resolution fixed => open
2015-04-17 14:33 inigosanchez Status new => scheduled
2015-04-17 14:34 inigosanchez Status scheduled => resolved
2015-04-17 14:34 inigosanchez Resolution open => fixed
2015-04-17 14:55 inigosanchez Note Added: 0076611
2015-04-17 15:03 inigosanchez Issue Monitored: alostale
2015-04-22 09:49 alostale Note Added: 0076675
2015-04-22 09:49 alostale Status resolved => closed
2015-04-22 09:49 alostale Fixed in Version => 3.0PR15Q3
2015-05-07 22:16 hudsonbot Checkin
2015-05-07 22:16 hudsonbot Note Added: 0077134


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker