Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029561
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfacemajoralways2015-04-10 13:162015-05-16 05:21
ReportercaristuView Statuspublic 
Assigned Todbaz 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revision5a7da4d16d1d
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029561: Time Fields can't be set as read only

DescriptionTime Fields can't be set as read only
Steps To Reproduce1) Create a new column with time reference
2) Create a field for column in 1). Set it as read only
3) Recompile and restart tomcat
4) Access to the window with the new field. Notice that it is possible to write characters on the field.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00276703.0PR15Q1 closedalostale Time fields do not have the correct style in read only mode 
related to defect 0029878 acknowledgedplatform blur from time field detects a change 

-  Notes
(0077387)
hgbot (developer)
2015-05-13 15:56

Repository: erp/devel/pi
Changeset: 8fc80e4bb1fb17bbddc541a782f873756089e704
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Wed May 13 15:56:05 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/8fc80e4bb1fb17bbddc541a782f873756089e704 [^]

Fixed issue 29561: 'Time' fields now can be set as readonly via AD_FIELD

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-time.js
---
(0077424)
alostale (developer)
2015-05-14 10:07

There is still a case where the behavior is not correct: no uneatable column with editable field. In this case the expected behavior is the field to be editable only when creating a new record but no editable afterwards. In this case it behaves correctly in terms of styling but just after saving it is possible to edit the value though the style looks like read only even after saving the record the value is restored to the original one.

See all cases that have been tested: https://docs.google.com/spreadsheets/d/1fi4VRn4uhlwMcMYs6ZWFRdNi085zQDl-zaYvcuv2cDY/edit#gid=0 [^]
(0077436)
hgbot (developer)
2015-05-14 12:15

Repository: erp/devel/pi
Changeset: 5a7da4d16d1d04f1b75649bcdcc91d835a39ccb4
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Thu May 14 12:15:15 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/5a7da4d16d1d04f1b75649bcdcc91d835a39ccb4 [^]

Fixed issue 29561: 'Time' fields now can be set as no updateable via AD_COLUMN

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-time.js
---
(0077453)
alostale (developer)
2015-05-14 16:44

code reviewed

tested for the cases defined in this sheet: https://docs.google.com/spreadsheets/d/1fi4VRn4uhlwMcMYs6ZWFRdNi085zQDl-zaYvcuv2cDY/edit#gid=0 [^]
(0077457)
hudsonbot (developer)
2015-05-14 17:48

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/3375171dd310 [^]
Maturity status: Test
(0077506)
hudsonbot (developer)
2015-05-16 05:21

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/33b0ebaa36ae [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-04-10 13:16 caristu New Issue
2015-04-10 13:16 caristu Assigned To => platform
2015-04-10 13:16 caristu Modules => Core
2015-04-10 13:16 caristu Triggers an Emergency Pack => No
2015-04-10 13:16 caristu Relationship added related to 0027670
2015-04-10 13:17 caristu Issue Monitored: networkb
2015-04-17 08:35 alostale Priority high => urgent
2015-04-17 08:35 alostale Status new => acknowledged
2015-05-12 18:24 egoitz Priority urgent => immediate
2015-05-12 18:24 egoitz Severity minor => major
2015-05-12 19:07 egoitz Issue Monitored: egoitz
2015-05-13 08:16 alostale Status acknowledged => scheduled
2015-05-13 08:16 alostale Assigned To platform => dbaz
2015-05-13 15:53 dbaz Review Assigned To => alostale
2015-05-13 15:56 hgbot Checkin
2015-05-13 15:56 hgbot Note Added: 0077387
2015-05-13 15:56 hgbot Status scheduled => resolved
2015-05-13 15:56 hgbot Resolution open => fixed
2015-05-13 15:56 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/8fc80e4bb1fb17bbddc541a782f873756089e704 [^]
2015-05-14 10:04 alostale Relationship added related to 0029878
2015-05-14 10:07 alostale Note Added: 0077424
2015-05-14 10:07 alostale Status resolved => new
2015-05-14 10:07 alostale Resolution fixed => open
2015-05-14 12:15 hgbot Checkin
2015-05-14 12:15 hgbot Note Added: 0077436
2015-05-14 12:15 hgbot Status new => resolved
2015-05-14 12:15 hgbot Resolution open => fixed
2015-05-14 12:15 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/8fc80e4bb1fb17bbddc541a782f873756089e704 [^] => http://code.openbravo.com/erp/devel/pi/rev/5a7da4d16d1d04f1b75649bcdcc91d835a39ccb4 [^]
2015-05-14 16:44 alostale Note Added: 0077453
2015-05-14 16:44 alostale Status resolved => closed
2015-05-14 16:44 alostale Fixed in Version => 3.0PR15Q3
2015-05-14 17:48 hudsonbot Checkin
2015-05-14 17:48 hudsonbot Note Added: 0077457
2015-05-16 05:21 hudsonbot Checkin
2015-05-16 05:21 hudsonbot Note Added: 0077506


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker