Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029541
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] Z. Othersminoralways2015-03-13 14:142015-04-13 15:53
ReporterngarciaView Statuspublic 
Assigned Toumartirena 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision9eff7a3a2b9d
ProjectionnoneETAnoneTarget Version3.0PR15Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date2014-07-01
Regression introduced in release3.0PR14Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/b1843f200a9092eea99d431776d029a09868615a [^]
Triggers an Emergency PackNo
Summary

0029541: Payment Out cannot be reactivated if the business partner does not have a purchase price list defined

DescriptionPayment Out cannot be reactivated if the business partner does not have a purchase price list defined and the payment currency is different from the Business partner currency
Steps To ReproduceAs group admin role:
   Create a Payment Out for a business partner
   Change the Business Partner currency to a currency different from the payment currency
   Leave the Purchase Price List empty in the Business Partner - Vendor tab
   Try to reactivate the Payment Out and check you get an empty error message
Proposed SolutionCheck if in getConversionRateDocumentForInvoice function of FIN_PaymentProcess class, the business partner currency could be used in both flows instead of the purchase price list currency
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0029273 closedumartirena Payment Out cannot be reactivated if the business partner does not have a purchase price list defined 

-  Notes
(0076479)
hgbot (developer)
2015-04-13 15:52

Repository: erp/backports/3.0PR15Q2
Changeset: 9eff7a3a2b9dba66c64aaa6c57ff263457dd209e
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Fri Apr 10 11:17:47 2015 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR15Q2/rev/9eff7a3a2b9dba66c64aaa6c57ff263457dd209e [^]

Fixes bug 29541: Payment Out can be reactivated without bp purchase pricelist

The problem is that the method 'getConversionRateDocumentForInvoice' tries to get a conversion using the currency of Purchase PriceList of the business partner, and it could happen to be empty, so it fails.

Starting from 3.0PR14Q4 the Currency field in the business partner is mandatory, so it can be used for Sales/Purchase flow.

It could be that at this point while reactivating the Payment to be the Currency of the Business Partner null, because it was created long time ago and no currency set yet, so, if this is the case an error will be raised to the user in order to fix this.

A last change has been made in 'OBMessageUtils.messageBD' method, adding an extra parameter when it is wanted to avoid doing escape of '\n' and doublequotes characters. In this case it is needed because the message that needs to be displayed needs to maintain them because contains a link. This implementation is similar to the one found in BasicUtility.messageBD.

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/process/FIN_PaymentProcess.java
M src/org/openbravo/erpCommon/utility/OBMessageUtils.java
---
(0076480)
hgbot (developer)
2015-04-13 15:52

Repository: erp/backports/3.0PR15Q2
Changeset: 820ea30197c5205876c182f194460d8b757e486f
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Mon Apr 13 15:50:26 2015 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR15Q2/rev/820ea30197c5205876c182f194460d8b757e486f [^]

Related to issue 29541: Removed unused parameter

Removed unused parameter in getConversionRateDocumentForInvoice method

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/process/FIN_PaymentProcess.java
---
(0076481)
aferraz (developer)
2015-04-13 15:53

Code review + Testing OK

- Issue History
Date Modified Username Field Change
2015-04-09 10:06 umartirena Type defect => backport
2015-04-09 10:06 umartirena Target Version => 3.0PR15Q2
2015-04-10 10:00 dmitry_mezentsev Tag Attached: Approved
2015-04-13 15:52 hgbot Checkin
2015-04-13 15:52 hgbot Note Added: 0076479
2015-04-13 15:52 hgbot Status scheduled => resolved
2015-04-13 15:52 hgbot Resolution open => fixed
2015-04-13 15:52 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR15Q2/rev/9eff7a3a2b9dba66c64aaa6c57ff263457dd209e [^]
2015-04-13 15:52 hgbot Checkin
2015-04-13 15:52 hgbot Note Added: 0076480
2015-04-13 15:53 aferraz Review Assigned To => aferraz
2015-04-13 15:53 aferraz Note Added: 0076481
2015-04-13 15:53 aferraz Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker