Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029481
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 01. General setupmajoralways2015-03-31 17:102015-05-11 21:53
ReporteregoitzView Statuspublic 
Assigned Toaferraz 
PriorityhighResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revision10f0bcd9165b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029481: On an environment with thousends of currency convert, inserting a new conversion takes more than a second.

DescriptionWhen inserting a conversion rate on an environment with thousends of conversion, the inserting action takes more than a second.
That happens becuase the trigger c_conversion_rate_trg2 checks if there exist more than one conversion for the same currencies on the same dates.
Steps To Reproduce-On an enviroment with more than 25.000 rows on c_conversion_rate table, insert a new conversion.

Proposed SolutionChange the trigger c_conversion_rate_trg2 to check duplicated conversion only for the currencies you are inserting/updating.
TagsPerformance
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0077279)
hgbot (developer)
2015-05-11 13:16

Repository: erp/devel/pi
Changeset: 10f0bcd9165b12d0b38661287db9cc4c5e27f4ca
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Thu May 07 16:36:25 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/10f0bcd9165b12d0b38661287db9cc4c5e27f4ca [^]

Fixes issue 29481: Bad performance when inserting a new Conversion Rate

C_CONVERSION_RATE_TRG2.xml trigger has been deleted. Instead, an event handler has been added in order to check for duplicated conversions only for the currencies you are inserting/updating.
C_CONVERSION_RATE_TRG2.xml trigger was not updated because it produced mutating table error in oracle

---
A src/org/openbravo/event/ConversionRateEventHandler.java
R src-db/database/model/triggers/C_CONVERSION_RATE_TRG2.xml
---
(0077280)
Sandrahuguet (developer)
2015-05-11 13:18

Code review + testing OK
(0077318)
hudsonbot (developer)
2015-05-11 21:53

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a55bc3c14e8c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-03-31 17:10 egoitz New Issue
2015-03-31 17:10 egoitz Assigned To => Sandrahuguet
2015-03-31 17:10 egoitz Modules => Core
2015-03-31 17:10 egoitz Triggers an Emergency Pack => No
2015-03-31 17:11 egoitz Tag Attached: Performance
2015-04-14 12:48 Triage Finance Assigned To Sandrahuguet => Triage Finance
2015-05-06 17:54 aferraz Status new => scheduled
2015-05-06 17:54 aferraz Assigned To Triage Finance => aferraz
2015-05-11 13:16 hgbot Checkin
2015-05-11 13:16 hgbot Note Added: 0077279
2015-05-11 13:16 hgbot Status scheduled => resolved
2015-05-11 13:16 hgbot Resolution open => fixed
2015-05-11 13:16 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/10f0bcd9165b12d0b38661287db9cc4c5e27f4ca [^]
2015-05-11 13:18 Sandrahuguet Review Assigned To => Sandrahuguet
2015-05-11 13:18 Sandrahuguet Note Added: 0077280
2015-05-11 13:18 Sandrahuguet Status resolved => closed
2015-05-11 13:18 Sandrahuguet Fixed in Version => 3.0PR15Q3
2015-05-11 21:53 hudsonbot Checkin
2015-05-11 21:53 hudsonbot Note Added: 0077318


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker