Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029479
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementtrivialhave not tried2015-03-31 16:432015-05-07 22:16
ReporteraferrazView Statuspublic 
Assigned Toaferraz 
PrioritynormalResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revision89903b60b441
ProjectionnoneETAnoneTarget Version
OSLinux 64 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Toumartirena
Web browser
ModulesCore
Regression levelPackaging and release
Regression date2015-03-26
Regression introduced in releasemain
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/bb85cbd52ff0 [^]
Triggers an Emergency PackNo
Summary

0029479: Lines still showing when filtering by a wrong value in a number type column in Manage Reservation popup

DescriptionLines still showing when filtering by a wrong value in a number type column in Manage Reservation popup
Steps To Reproduce1- Login into Openbravo ERP
2- As group admin role, set the Enable Stock Reservation preference to 'Y'
3- Logout and login again
4- Go to Sales Order window and create a header.
5- Go to lines and create a new one, select a product that has stock (for example Vino Blanco)
6- Book it
7- Go to the lines tab and open the Manage Reservation pop-up
8- Uncheck all lines
9- Type a wrong filter (a string) in Available Qty column and check all records still shown, while they should not

Note: Same occurs from Stock reservation window
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00294803.0PR15Q2 closedaferraz Lines still showing when filtering by a wrong value in a number type column in Manage Reservation popup 
caused by defect 00290033.0PR15Q2 closedreinaldoguerra Error in log when typing a wrong filter in Manage Reservation Stock pop-up 

-  Notes
(0076329)
hgbot (developer)
2015-04-01 17:44

Repository: erp/devel/pi
Changeset: 89903b60b441cf6a97a5bf430f73cb434d6d765d
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Tue Mar 31 16:47:42 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/89903b60b441cf6a97a5bf430f73cb434d6d765d [^]

Fixes issue 29479: Lines shown when filtering by a wrong value

Lines will not be shown, if they are not checked, when filtering by a wrong value in a number type column, in Manage Reservation popup

---
M src/org/openbravo/common/datasource/StockReservationPickAndEditDataSource.java
---
(0076330)
umartirena (developer)
2015-04-01 17:45

Code Review + Testing OK
(0077108)
hudsonbot (developer)
2015-05-07 22:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-03-31 16:43 aferraz New Issue
2015-03-31 16:43 aferraz Assigned To => aferraz
2015-03-31 16:43 aferraz Modules => Core
2015-03-31 16:43 aferraz Regression level => Packaging and release
2015-03-31 16:43 aferraz Regression date => 2015-03-26
2015-03-31 16:43 aferraz Regression introduced in release => main
2015-03-31 16:43 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/bb85cbd52ff0 [^]
2015-03-31 16:43 aferraz Triggers an Emergency Pack => No
2015-03-31 16:48 aferraz Status new => scheduled
2015-03-31 18:21 aferraz Relationship added caused by 0029003
2015-04-01 17:44 hgbot Checkin
2015-04-01 17:44 hgbot Note Added: 0076329
2015-04-01 17:44 hgbot Status scheduled => resolved
2015-04-01 17:44 hgbot Resolution open => fixed
2015-04-01 17:44 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/89903b60b441cf6a97a5bf430f73cb434d6d765d [^]
2015-04-01 17:45 umartirena Review Assigned To => umartirena
2015-04-01 17:45 umartirena Note Added: 0076330
2015-04-01 17:45 umartirena Status resolved => closed
2015-04-01 17:45 umartirena Fixed in Version => pi
2015-04-14 11:43 psanjuan Relationship added related to 0029406
2015-04-14 11:43 psanjuan Relationship deleted related to 0029406
2015-05-07 22:16 hudsonbot Checkin
2015-05-07 22:16 hudsonbot Note Added: 0077108


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker