Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029441
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2015-03-27 13:012015-03-31 00:07
ReporterNaroaIriarteView Statuspublic 
Assigned ToNaroaIriarte 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revision82682f61da0c
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2014-03-06
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/d8ec9347e127febd5961acedac70ff0cfe52e5b6 [^]
Triggers an Emergency PackNo
Summary

0029441: Exporting to XLS does not work in the new ReportingUtils class

DescriptionTrying to export a report in xls format using a module which uses the new code in the class "ReportingUtils", shows a casting error in the log.
Steps To Reproduce1- Install the following module:

  https://code.openbravo.com/erp/mods/org.openbravo.platform.features [^]

2- Follow the instructions in the following URL and create both PDF and a XLS report exporter buttons.

   http://wiki.openbravo.com/wiki/How_to_create_a_Report_using_Process_Definition [^]

3- Go to F&B Admin and open the "Product Simple Report" window.
4- Click on the "Export to XLS" button.
5- An error of casting is shown in the log.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0029412 closedNaroaIriarte The ReportingUtils.java does not work properly. 
related to defect 0029427 closedNaroaIriarte It is possible to modify the object of the enum class ExporType. 
related to feature request 0026763 closedgorkaion Ability to launch reports from process definitions 
caused by defect 00291573.0PR15Q2 closedalostale code review issues for Process Definition Reporting Tool project 

-  Notes
(0076118)
hgbot (developer)
2015-03-30 10:47

Repository: erp/devel/pi
Changeset: 82682f61da0c0771cc348133d0a143369c32b8ca
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Fri Mar 27 14:02:59 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/82682f61da0c0771cc348133d0a143369c32b8ca [^]

Fixed issue 29441: It is not possible to export a report in XLS format.

Trying to export a report in XLS format, using the following module does not work:
 https://code.openbravo.com/erp/mods/org.openbravo.platform.features [^]

It shows a casting error in the log. The problem is in the ReportingUtils class.
When it tries to export a report of XLS type, the variable "target" is type "File".
The problem is when the JRExporterParameter class of Jasper is used:

exportParameters.put(JRExporterParameter.OUTPUT_FILE_NAME, target);

The target needs to be of type "String" instead of "File" for the correct execution of
the code above.

To fix this the method "getAbsolutePath" of the "File" class has been called for getting
the absolute path which is what is needed, but having the type as "String" instead
of "File".

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/report/ReportingUtils.java
---
(0076119)
alostale (developer)
2015-03-30 10:49

code reviewed + tested

the issue was introduced in the code review refactor [1] where target type was changed from String to File.

[1] https://code.openbravo.com/erp/devel/pi/rev/d8ec9347e127febd5961acedac70ff0cfe52e5b6#l4.48 [^]
(0076162)
hudsonbot (developer)
2015-03-31 00:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/34da08f135b8 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-03-27 13:01 NaroaIriarte New Issue
2015-03-27 13:01 NaroaIriarte Assigned To => NaroaIriarte
2015-03-27 13:01 NaroaIriarte Modules => Core
2015-03-27 13:01 NaroaIriarte Triggers an Emergency Pack => No
2015-03-27 13:37 NaroaIriarte Relationship added related to 0029412
2015-03-27 13:38 NaroaIriarte Relationship added related to 0029427
2015-03-27 14:45 NaroaIriarte Priority immediate => urgent
2015-03-27 14:47 NaroaIriarte Review Assigned To => alostale
2015-03-27 14:47 alostale Relationship added related to 0026763
2015-03-30 10:45 alostale Relationship added caused by 0029157
2015-03-30 10:46 alostale Regression level => Pre packaging ( pi )
2015-03-30 10:46 alostale Regression date => 2014-03-06
2015-03-30 10:46 alostale Regression introduced in release => pi
2015-03-30 10:46 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/d8ec9347e127febd5961acedac70ff0cfe52e5b6 [^]
2015-03-30 10:46 alostale Priority urgent => immediate
2015-03-30 10:47 hgbot Checkin
2015-03-30 10:47 hgbot Note Added: 0076118
2015-03-30 10:47 hgbot Status new => resolved
2015-03-30 10:47 hgbot Resolution open => fixed
2015-03-30 10:47 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/82682f61da0c0771cc348133d0a143369c32b8ca [^]
2015-03-30 10:49 alostale Note Added: 0076119
2015-03-30 10:49 alostale Status resolved => closed
2015-03-30 10:49 alostale Fixed in Version => 3.0PR15Q2
2015-03-31 00:07 hudsonbot Checkin
2015-03-31 00:07 hudsonbot Note Added: 0076162


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker