Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029412
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2015-03-25 17:202015-03-27 14:47
ReporterNaroaIriarteView Statuspublic 
Assigned ToNaroaIriarte 
PriorityurgentResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revision72aaa6991580
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029412: The ReportingUtils.java does not work properly.

DescriptionThere is an enum class called "ExportType" inside the "ReportingUtils" class.
This does not work properly when it is used outside the package in which is defined.
If one try to use it, an error is catched.
Steps To Reproduce1- Open Eclipse an open "About.java".
2- Put the following code line inside the "doPost" method:

    ExportType exportType = ReportingUtils.ExportType.PDF;

3- Go to your Openbravo workspace and click "about" in the "help" tab.

4- You will the error attached in the txt file.
TagsNo tags attached.
Attached Filestxt file icon logerror.txt [^] (3,333 bytes) 2015-03-25 17:20 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0026763 closedgorkaion Ability to launch reports from process definitions 
related to defect 0029441 closedNaroaIriarte Exporting to XLS does not work in the new ReportingUtils class 

-  Notes
(0076015)
hgbot (developer)
2015-03-26 15:30

Repository: erp/devel/pi
Changeset: 72aaa69915807484e30a526991e0b08f0c6fbcc0
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Thu Mar 26 11:02:48 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/72aaa69915807484e30a526991e0b08f0c6fbcc0 [^]

Fixed issue 29412:It is not possible to use the new reporting class everywere.

The problem was that calling the methods of the "ExportType" class inside the "ReportingUtils" class
from some parts of the code (the old code) was not working properly.
The problem was that it was needed to have the AdminMode set to true to access to a table which
was accessed in the constructor of the "ExportType" class.
The new code has the AdminMode set to true, that is why it works.
But in the old code it was not.

For fixing this, the AdminMode has been set to true inside the constructor of the "ExportType" class
itself. It is needed for the download of the report.
Other change that has been made is changing the type of the variable filetype, now it is String. This is
for saving memory.
It has been taken into account to the fact of having a different type of report in the future. This has been
handled with the "fileType = "application/" + extension" code. Now new extensions will be supported.
Now whereever one calls those methods, it works properly.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/report/ReportingUtils.java
---
(0076016)
alostale (developer)
2015-03-26 15:32

code reviewed + tested
(0076045)
hudsonbot (developer)
2015-03-27 02:12

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b8858c8b542b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-03-25 17:20 NaroaIriarte New Issue
2015-03-25 17:20 NaroaIriarte Assigned To => NaroaIriarte
2015-03-25 17:20 NaroaIriarte File Added: logerror.txt
2015-03-25 17:20 NaroaIriarte Modules => Core
2015-03-25 17:20 NaroaIriarte Triggers an Emergency Pack => No
2015-03-26 15:24 alostale Review Assigned To => alostale
2015-03-26 15:30 hgbot Checkin
2015-03-26 15:30 hgbot Note Added: 0076015
2015-03-26 15:30 hgbot Status new => resolved
2015-03-26 15:30 hgbot Resolution open => fixed
2015-03-26 15:30 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/72aaa69915807484e30a526991e0b08f0c6fbcc0 [^]
2015-03-26 15:32 alostale Note Added: 0076016
2015-03-26 15:32 alostale Status resolved => closed
2015-03-26 15:32 alostale Fixed in Version => 3.0PR15Q2
2015-03-27 02:12 hudsonbot Checkin
2015-03-27 02:12 hudsonbot Note Added: 0076045
2015-03-27 13:37 NaroaIriarte Relationship added related to 0029441
2015-03-27 14:47 alostale Relationship added related to 0026763


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker