Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029431
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajorhave not tried2015-03-26 12:272015-03-27 02:12
ReporteradrianromeroView Statuspublic 
Assigned Toumartirena 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision4cfbd5d699d2
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelCode review
Regression date2015-03-11
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/35a4e54c3ffc [^]
Triggers an Emergency PackNo
Summary

0029431: It is not possible to delete an invoice line when using price including taxes

DescriptionWhen trying to delete an invoice line when using price including taxes the following error appears:

ERROR: record "new" is not assigned yet Detail: The tuple structure of a not-yet-assigned record is indeterminate. Where: PL/pgSQL function "c_invoiceline_trg2" line 70 at assignment
Steps To Reproduce* Login in https://livebuilds.openbravo.com/retail_pi_pgsql [^]
* Select Role White Valley Admin Group
* Go to invoices. Create a new invoice and a new line
* Try to delete the line
* The error described in the description appears and cannot be deleted the line

See attached image
Proposed SolutionThe problem is in the following line: https://code.openbravo.com/erp/devel/pi/file/54218273885c/src-db/database/model/triggers/C_INVOICELINE_TRG2.xml#l72 [^]

When deleting this line is reached and "NEW" can only be used whe updating or inserting.
TagsNo tags attached.
Attached Filespng file icon Captura de pantalla de 2015-03-26 12:19:04.png [^] (154,318 bytes) 2015-03-26 12:27

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00290733.0PR15Q2 closedumartirena Review deleting logic of tax lines in C_INVOICELINE_TRG2 

-  Notes
(0076025)
hgbot (developer)
2015-03-26 17:55

Repository: erp/devel/pi
Changeset: 4cfbd5d699d2359289733749c3fef93f34d0f2e9
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Thu Mar 26 16:41:55 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/4cfbd5d699d2359289733749c3fef93f34d0f2e9 [^]

Fixes issue 29431: Add missing inserting to if clause

---
M src-db/database/model/triggers/C_INVOICELINE_TRG2.xml
---
(0076027)
vmromanos (developer)
2015-03-26 17:56

Code review + testing OK
(0076046)
hudsonbot (developer)
2015-03-27 02:12

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/b8858c8b542b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-03-26 12:27 adrianromero New Issue
2015-03-26 12:27 adrianromero Assigned To => Sandrahuguet
2015-03-26 12:27 adrianromero File Added: Captura de pantalla de 2015-03-26 12:19:04.png
2015-03-26 12:27 adrianromero Modules => Core
2015-03-26 12:27 adrianromero Triggers an Emergency Pack => No
2015-03-26 12:30 adrianromero Regression level => Code review
2015-03-26 12:30 adrianromero Regression date => 2015-03-11
2015-03-26 12:30 adrianromero Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/35a4e54c3ffc [^]
2015-03-26 12:31 adrianromero Assigned To Sandrahuguet => umartirena
2015-03-26 17:54 vmromanos Status new => scheduled
2015-03-26 17:55 hgbot Checkin
2015-03-26 17:55 hgbot Note Added: 0076025
2015-03-26 17:55 hgbot Status scheduled => resolved
2015-03-26 17:55 hgbot Resolution open => fixed
2015-03-26 17:55 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/4cfbd5d699d2359289733749c3fef93f34d0f2e9 [^]
2015-03-26 17:56 vmromanos Review Assigned To => vmromanos
2015-03-26 17:56 vmromanos Note Added: 0076027
2015-03-26 17:56 vmromanos Status resolved => closed
2015-03-27 02:12 hudsonbot Checkin
2015-03-27 02:12 hudsonbot Note Added: 0076046
2015-03-27 10:25 umartirena Relationship added related to 0029073


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker