Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029294
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] Z. Othersminoralways2015-01-22 10:582015-03-17 11:34
ReportermaiteView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q3.8
StatusclosedFix in branchFixed in SCM revision125099e2c436
ProjectionnoneETAnoneTarget Version3.0PR14Q3.8
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesAdvanced Payables and Receivables Mngmt
Regression levelProduction - Confirmed Stable
Regression date2013-05-26
Regression introduced in release3.0PR14Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/402d7bca3f774737bf194cb7cbe41d2454a69326 [^]
Triggers an Emergency PackNo
Summary

0029294: Payment Method info should be maintained when using "Modify Payment Plan" functionality

DescriptionPayment Method info should be maintained when using "Modify Payment Plan" functionality
Steps To Reproduce1. Access as System Administrator and display "Modify Payment Plan" button in Payment Plan tab of Sales Invoice window
2. Logout and login
3. Create new Sales Invoice document. Add line and process
4. Access Payment Plan tab and run "Modify Payment Plan" process. Click on Due Date field of existent register to modify the date and realize that Payment Method information has been deleted
Proposed SolutionPayment Method value should be maintained as other values are also maintained
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 00287273.0PR15Q3 closedAugustoMauch Payment Method info should be maintained when using "Modify Payment Plan" functionality 

-  Notes
(0075644)
hgbot (developer)
2015-03-16 17:27

Repository: erp/backports/3.0PR14Q3.8
Changeset: 81ebfd3ac9f82440d940e20bcee38b219150c0e5
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Mar 16 17:22:59 2015 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR14Q3.8/rev/81ebfd3ac9f82440d940e20bcee38b219150c0e5 [^]

Related with issue 29294: Checks if the okButton exists to prevent error in log

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-parameter-window-view.js
---
(0075645)
hgbot (developer)
2015-03-16 17:27

Repository: erp/backports/3.0PR14Q3.8
Changeset: fdf55ad85d6340c97add108fa45e0d010189a4b0
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Mar 16 16:57:41 2015 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR14Q3.8/rev/fdf55ad85d6340c97add108fa45e0d010189a4b0 [^]

Fixes issue 29294: valueMap is properly initialized in pick and execute windows

The problem was that when a line in a pick and execute grid was edited, the valueMap of its OBFKComboItems was not properly initialized. The initialization is done in the OBPickAndExecuteGrid.processColumnValue function.

Before the Openbravo combos was refactored, the columnValue parameter used to contain the full valueMap of the combo in its entries attribute. This atribute was passed to the OBPickAndExecuteGrid.setValueMap, and the valueMap of the combos was initialized. The problem was that since the combos was refactored the columnValue parameter no longer contained the entries attribute, because the FIC now only returns the selected value. To fix this, in this case the valueMap is built manually based on the column value and identifier. This valueMap is passed to the OBPickAndExecuteGrid.setValueMap function to initialize the field valueMap.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
---
(0075655)
hgbot (developer)
2015-03-16 18:52

Repository: erp/backports/3.0PR14Q3.8
Changeset: 125099e2c4369992f506a4bad3c31608b876ec88
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Mar 16 18:49:22 2015 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR14Q3.8/rev/125099e2c4369992f506a4bad3c31608b876ec88 [^]

Fixes bug 29294: valueMap and value of combo item is properly set in P&E window

There were two things missing in the previous fix:
- The attribute names of the valueMap were not proper
- The value of the combo item should be set after defining its valueMap, otherwise the value is lost

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
---
(0075676)
alostale (developer)
2015-03-17 09:08

code reviewed

tested:
-When editing the record in the P&E value in payment method field is kept
-This value can be edited and it is correctly processed

- Issue History
Date Modified Username Field Change
2015-03-16 16:41 AugustoMauch Type defect => backport
2015-03-16 16:41 AugustoMauch Target Version 3.0PR15Q3 => 3.0PR14Q3.8
2015-03-16 17:05 AugustoMauch Regression level => Production - Confirmed Stable
2015-03-16 17:05 AugustoMauch Regression date 2015-03-10 => 2013-05-26
2015-03-16 17:05 AugustoMauch Regression introduced in release => 3.0PR14Q3
2015-03-16 17:05 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/402d7bca3f774737bf194cb7cbe41d2454a69326 [^]
2015-03-16 17:23 AugustoMauch Issue Monitored: alostale
2015-03-16 17:24 AugustoMauch Review Assigned To => alostale
2015-03-16 17:27 hgbot Checkin
2015-03-16 17:27 hgbot Note Added: 0075644
2015-03-16 17:27 hgbot Checkin
2015-03-16 17:27 hgbot Note Added: 0075645
2015-03-16 17:27 hgbot Status scheduled => resolved
2015-03-16 17:27 hgbot Resolution open => fixed
2015-03-16 17:27 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR14Q3.8/rev/fdf55ad85d6340c97add108fa45e0d010189a4b0 [^]
2015-03-16 18:52 hgbot Checkin
2015-03-16 18:52 hgbot Note Added: 0075655
2015-03-16 18:52 hgbot Fixed in SCM revision http://code.openbravo.com/erp/backports/3.0PR14Q3.8/rev/fdf55ad85d6340c97add108fa45e0d010189a4b0 [^] => http://code.openbravo.com/erp/backports/3.0PR14Q3.8/rev/125099e2c4369992f506a4bad3c31608b876ec88 [^]
2015-03-17 09:08 alostale Note Added: 0075676
2015-03-17 09:08 alostale Status resolved => closed
2015-03-17 09:08 alostale Fixed in Version => 3.0PR14Q3.8
2015-03-17 11:34 dmitry_mezentsev Tag Attached: Approved


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker