Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029265
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] I. Performancemajorsometimes2015-03-06 13:372015-03-20 19:23
ReporterlorenzofidalgoView Statuspublic 
Assigned Toumartirena 
PrioritynormalResolutionfixedFixed in Version3.0PR14Q3.8
StatusclosedFix in branchFixed in SCM revisiona7cded5c96cf
ProjectionnoneETAnoneTarget Version3.0PR14Q3.8
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned ToSandrahuguet
Web browserGoogle Chrome, Mozilla Firefox
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0029265: Clicking select all and after that unselect all records in AddPayment window induces browser to get stuck

DescriptionIf there is enough lines (I have tested this with 60 and 90 records and it has been successfully reproduced), clicking "select all" records and after that clicking same button (which is "unselect all" at that moment) induces browser to get stuck. [See screenshots].

I have tested this localhost and livebuilds in pi pgsql context.

Steps To Reproduce[It is adviced to create as many puchase invoice records as possible with at least one product line each one and complete them to test this].

Login ERP using QAAdmin role.
Go to "Financial Account" window.
Select "Spain Cashbook" role.
Go to "Transaction" tab.
Create a new record.
Transaction Type: "BP Withdrawal".
Click "+" in Payment field to add a payment.
In "Add Payment" window:
--
Clear filters.
Click "select all" checkbox and next to that, click it again to "unselect all".
It will probably broke. If it does not, repeat "select all" + "unselect all" several times.
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0029172 closedumartirena Clicking select all and after that unselect all records in AddPayment window induces browser to get stuck 

-  Notes
(0075550)
hgbot (developer)
2015-03-13 13:02

Repository: erp/backports/3.0PR14Q3.8
Changeset: a7cded5c96cff9af029ddfaf5f9a965980f639ce
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Fri Mar 13 13:00:24 2015 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR14Q3.8/rev/a7cded5c96cff9af029ddfaf5f9a965980f639ce [^]

Fixes bug 29265 Improved performance select/deselect all records in OrderInv grid

---
M modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-addPayment.js
---
(0075564)
Sandrahuguet (developer)
2015-03-13 14:00

Code review + testing OK
(0075705)
umartirena (developer)
2015-03-17 19:31
edited on: 2015-03-17 19:33

Reopened because it does not update differences after reload of Order Invoices grid

(0075745)
hgbot (developer)
2015-03-18 17:11

Repository: erp/backports/3.0PR14Q3.8
Changeset: 18bb658d54a0e4dd538750b5e0833939b7a0e143
Author: Unai Martirena <unai.martirena <at> openbravo.com>
Date: Wed Mar 18 17:09:46 2015 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR14Q3.8/rev/18bb658d54a0e4dd538750b5e0833939b7a0e143 [^]

Related to bug 29265: Delete obaprmAllRecordsSelectedByUser in OrderInvoice Load

While executing invalidateCache() function to reload OrderInvoice grid it internally calls to 'OB.APRM.AddPayment.deselectAllRecords' overriden method that sets obaprmAllRecordsSelectedByUser property to true. This property is only needed when manually the select/unselect all checkbox is clicked.

This was causing on certain scenarios that methods to update totals were not being called:
* OB.APRM.AddPayment.updateInvOrderTotal(view.theForm, orderInvoice);
* OB.APRM.AddPayment.updateActualExpected(view.theForm);
* OB.APRM.AddPayment.updateDifference(view.theForm);

So, in order to avoid this in OrderInvoiceOnLoad function, if the property 'obaprmAllRecordsSelectedByUser' exists, it will be deleted.

---
M modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-addPayment.js
---
(0075753)
Sandrahuguet (developer)
2015-03-18 18:49

Code review + testing OK
(0075829)
hudsonbot (developer)
2015-03-20 19:23

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a670497786d1 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-03-12 17:10 Sandrahuguet Type defect => backport
2015-03-12 17:10 Sandrahuguet Target Version => 3.0PR14Q3.8
2015-03-13 13:02 hgbot Checkin
2015-03-13 13:02 hgbot Note Added: 0075550
2015-03-13 13:02 hgbot Status scheduled => resolved
2015-03-13 13:02 hgbot Resolution open => fixed
2015-03-13 13:02 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR14Q3.8/rev/a7cded5c96cff9af029ddfaf5f9a965980f639ce [^]
2015-03-13 14:00 Sandrahuguet Review Assigned To => Sandrahuguet
2015-03-13 14:00 Sandrahuguet Note Added: 0075564
2015-03-13 14:00 Sandrahuguet Status resolved => closed
2015-03-13 14:00 Sandrahuguet Fixed in Version => 3.0PR14Q3.8
2015-03-13 17:35 dmitry_mezentsev Tag Attached: Approved
2015-03-17 19:31 umartirena Note Added: 0075705
2015-03-17 19:31 umartirena Status closed => new
2015-03-17 19:31 umartirena Resolution fixed => open
2015-03-17 19:31 umartirena Fixed in Version 3.0PR14Q3.8 =>
2015-03-17 19:33 umartirena Note Edited: 0075705 View Revisions
2015-03-18 09:54 hgbot Checkin
2015-03-18 09:54 hgbot Note Added: 0075722
2015-03-18 17:11 hgbot Checkin
2015-03-18 17:11 hgbot Note Added: 0075745
2015-03-18 17:19 umartirena Note Deleted: 0075722
2015-03-18 18:12 umartirena Status new => scheduled
2015-03-18 18:12 umartirena Status scheduled => resolved
2015-03-18 18:12 umartirena Fixed in Version => 3.0PR14Q3.8
2015-03-18 18:12 umartirena Resolution open => fixed
2015-03-18 18:49 Sandrahuguet Note Added: 0075753
2015-03-18 18:49 Sandrahuguet Status resolved => closed
2015-03-20 19:23 hudsonbot Checkin
2015-03-20 19:23 hudsonbot Note Added: 0075829


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker