Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0029029
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementminoralways2015-02-23 17:002015-04-01 08:47
ReporteraferrazView Statuspublic 
Assigned Toaferraz 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revision59ef94f00815
ProjectionnoneETAnoneTarget Version
OSLinux 64 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2013-01-30
Regression introduced in release3.0MP20
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/ddafe117203b20b2319a0f81db5a836af99bc44c [^]
Triggers an Emergency PackNo
Summary

0029029: SL_Journal_Period raises an exception when it is called from G/L Journal Batch tab

DescriptionWhen SL_Journal_Period callout is called from G/L Journal Batch tab, it raises an exception because acctSchema is null.
Steps To ReproduceAs group admin role:

Create a record in the GL Journal window
Change the Document date
Realize a NullPointerException is raised in the log of Openbravo.
Proposed SolutionSLJournalPeriodData.getCurrencyRate should be call only if acctSchema is not null
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 00219753.0MP20 closedioritzCia It does not take into account the 'Rate' value defined in G/L Journal window 

-  Notes
(0074923)
hgbot (developer)
2015-02-25 18:20

Repository: erp/devel/pi
Changeset: e72f5b99ab8bcd4a2f5e74566397ab32711543ec
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Mon Feb 23 18:52:28 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e72f5b99ab8bcd4a2f5e74566397ab32711543ec [^]

Fixes issue 29029: SL_Journal_Period raises a NullPointer Exception

AcctSchema will be retrieved only if acctSchemaId is not null (G/L Journal Header tab). In other case (G/L Journal Batch tab) it will not.

---
M src/org/openbravo/erpCommon/ad_callouts/SL_Journal_Period.java
---
(0074926)
Sandrahuguet (developer)
2015-02-25 18:22

Code review + testing OK
(0074931)
aferraz (developer)
2015-02-25 18:27

Test case added in Testlink:
http://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-8046 [^]
(0075002)
hudsonbot (developer)
2015-02-26 22:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/bcc51efc87d5 [^]
Maturity status: Test
(0076195)
hgbot (developer)
2015-04-01 08:05

Repository: erp/backports/3.0PR15Q2
Changeset: 59ef94f008159dd15e1e873f70ee0468fa0b1484
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Mon Feb 23 18:52:28 2015 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR15Q2/rev/59ef94f008159dd15e1e873f70ee0468fa0b1484 [^]

Fixes issue 29029: SL_Journal_Period raises a NullPointer Exception

AcctSchema will be retrieved only if acctSchemaId is not null (G/L Journal Header tab). In other case (G/L Journal Batch tab) it will not.

---
M src/org/openbravo/erpCommon/ad_callouts/SL_Journal_Period.java
---
(0076280)
priyam (administrator)
2015-04-01 08:47

closed again, as the status changes due to merge of tag 15Q1.2 to backport repo Q2

- Issue History
Date Modified Username Field Change
2015-02-23 17:00 aferraz New Issue
2015-02-23 17:00 aferraz Assigned To => aferraz
2015-02-23 17:00 aferraz Modules => Core
2015-02-23 17:00 aferraz Triggers an Emergency Pack => No
2015-02-23 17:28 aferraz Regression level => Production - Confirmed Stable
2015-02-23 17:28 aferraz Regression date => 2013-01-30
2015-02-23 17:28 aferraz Regression introduced in release => 3.0MP20
2015-02-23 17:28 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/ddafe117203b20b2319a0f81db5a836af99bc44c [^]
2015-02-23 17:32 aferraz Relationship added caused by 0021975
2015-02-24 17:00 aferraz Priority normal => immediate
2015-02-25 18:20 hgbot Checkin
2015-02-25 18:20 hgbot Note Added: 0074923
2015-02-25 18:20 hgbot Status new => resolved
2015-02-25 18:20 hgbot Resolution open => fixed
2015-02-25 18:20 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e72f5b99ab8bcd4a2f5e74566397ab32711543ec [^]
2015-02-25 18:22 Sandrahuguet Review Assigned To => Sandrahuguet
2015-02-25 18:22 Sandrahuguet Note Added: 0074926
2015-02-25 18:22 Sandrahuguet Status resolved => closed
2015-02-25 18:22 Sandrahuguet Fixed in Version => 3.0PR15Q2
2015-02-25 18:27 aferraz Note Added: 0074931
2015-02-26 22:39 hudsonbot Checkin
2015-02-26 22:39 hudsonbot Note Added: 0075002
2015-04-01 08:05 hgbot Checkin
2015-04-01 08:05 hgbot Note Added: 0076195
2015-04-01 08:05 hgbot Status closed => resolved
2015-04-01 08:05 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/e72f5b99ab8bcd4a2f5e74566397ab32711543ec [^] => http://code.openbravo.com/erp/backports/3.0PR15Q2/rev/59ef94f008159dd15e1e873f70ee0468fa0b1484 [^]
2015-04-01 08:47 priyam Status resolved => closed
2015-04-01 08:47 priyam Note Added: 0076280


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker