Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028985
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfaceminoralways2015-02-18 17:392015-02-23 05:11
ReporterVictorVillarView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchFixed in SCM revisionabc5697a0872
ProjectionnoneETAnoneTarget Version3.0PR15Q1.2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Todbaz
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-12-24
Regression introduced in release3.0PR14Q3.4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/25794 [^]
Triggers an Emergency PackNo
Summary

0028985: It is not possible to freeze a column

DescriptionIt is not possible to freeze a column
Steps To ReproduceAs group admin role,
 Go to Purchase order window
  right click on one column. For instance: Organization.
  Click on 'Freeze Organization'
Realise that you can scroll to the right, and this column is not frozen (blocked)
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 00283793.0PR15Q2 closedAugustoMauch Unexpected behavior after setting some fields from a process definition 

-  Notes
(0074640)
AugustoMauch (developer)
2015-02-19 09:51

Changed to minor, as it fits best that criticity according to this document: http://wiki.openbravo.com/wiki/QA_Processes/Defects_Severity_Priority [^]
(0074645)
hgbot (developer)
2015-02-19 10:45

Repository: erp/devel/pi
Changeset: abc5697a0872e733ae8546a3ad2d6b23006ced37
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Feb 19 10:43:52 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/abc5697a0872e733ae8546a3ad2d6b23006ced37 [^]

Fixes issue 28985: Grid columns can be frozen

In this changeset [1], a function named fieldIsVisible was added to the OBViewGrid class, to control if a field was actually visible in the grid. The problem was that there was actually a function defined with that same name in the Smartclient's DataBoundComponent class, which is an OBViewGrid ancestor. This means that the fieldIsVisible function implemented in [1] is overwriting the original implementation, and this was not intended.

The fieldIsVisible function is invoked when a grid column is frozen, that is why the change made in [1] has created the current issue. To fix it, the name of OBViewGrid.fieldIsVisible function has been renamed to fieldIsVisibleInGrid. It has been checked that there is no function defined with that name in any OBViewGrid ancestor class.

[1] https://code.openbravo.com/erp/devel/pi/rev/25794 [^]

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0074646)
AugustoMauch (developer)
2015-02-19 10:57

A test has been created in testlink: http://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-8044 [^]

To automate this test the test's infrastructure must be updated, as currently it is not possible to freeze fields [1] nor to move columns [2]

[1] http://smartclient.com/docs/8.3/a/b/c/go.html#method..ListGrid.freezeField [^]
[2] http://smartclient.com/docs/8.3/a/b/c/go.html#method..ListGrid.reorderField [^]
(0074647)
AugustoMauch (developer)
2015-02-19 10:58

Test plan:
- Test that both the current issue, and the issue that caused it [1] are not reproducible.

[1] https://issues.openbravo.com/view.php?id=28379 [^]
(0074650)
dbaz (developer)
2015-02-19 11:49

Reviewed @ changeset 25997 - abc5697a0872
(0074788)
hudsonbot (developer)
2015-02-23 05:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6856352d7235 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-02-18 17:39 VictorVillar New Issue
2015-02-18 17:39 VictorVillar Assigned To => dbaz
2015-02-18 17:39 VictorVillar Modules => Core
2015-02-18 17:39 VictorVillar Regression level => Production - Confirmed Stable
2015-02-18 17:39 VictorVillar Triggers an Emergency Pack => No
2015-02-18 17:43 VictorVillar Issue Monitored: networkb
2015-02-18 18:15 eugeni Issue Monitored: eugeni
2015-02-18 18:26 dbaz Regression date => 2014-12-24
2015-02-18 18:26 dbaz Regression introduced in release => 3.0PR14Q3.4
2015-02-18 18:26 dbaz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/25794 [^]
2015-02-18 18:26 dbaz Assigned To dbaz => AugustoMauch
2015-02-19 09:51 AugustoMauch Note Added: 0074640
2015-02-19 09:51 AugustoMauch Severity major => minor
2015-02-19 10:34 AugustoMauch Relationship added caused by 0028379
2015-02-19 10:44 AugustoMauch Issue Monitored: dbaz
2015-02-19 10:44 AugustoMauch Review Assigned To => dbaz
2015-02-19 10:45 hgbot Checkin
2015-02-19 10:45 hgbot Note Added: 0074645
2015-02-19 10:45 hgbot Status new => resolved
2015-02-19 10:45 hgbot Resolution open => fixed
2015-02-19 10:45 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/abc5697a0872e733ae8546a3ad2d6b23006ced37 [^]
2015-02-19 10:57 AugustoMauch Note Added: 0074646
2015-02-19 10:58 AugustoMauch Note Added: 0074647
2015-02-19 11:49 dbaz Note Added: 0074650
2015-02-19 11:49 dbaz Status resolved => closed
2015-02-19 11:49 dbaz Fixed in Version => 3.0PR15Q2
2015-02-23 05:11 hudsonbot Checkin
2015-02-23 05:11 hudsonbot Note Added: 0074788


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker