Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028379
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2014-12-10 16:212015-01-07 10:10
ReportercaristuView Statuspublic 
Assigned ToAugustoMauch 
PriorityhighResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchFixed in SCM revision2cf47120feef
ProjectionnoneETAnoneTarget Version3.0PR15Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Todbaz
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2013-10-07
Regression introduced in release3.0MP29
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/94d0fb15191969d20c2f89b919bec8a95ad33110 [^]
Triggers an Emergency PackNo
Summary

0028379: Unexpected behavior after setting some fields from a process definition

DescriptionUnexpected behavior after setting some fields from a process definition
Steps To Reproduce1) Install the attached module which contains a process definition for the Goods Receipt window.
2) Go to the [Goods Receipt window]. Create a new record in the header. Go to the [Lines] tab and create a new record, leaving the "Storage Bin" field empty.
3) Click on the button that invokes the process definition (EM_Suptest_Process). A parameter window will appear to select a value that will be used to set the Storage Bin field for the line.
4) The process ends successfully and the value for the Storage Bin is displayed in grid view for the line and also is stored properly in the database.
5) Open the record in the [Lines tab] in form view. Notice that the UI detects changes in the record an now the Storage bin field appears empty.
6) This behavior is not happening with other type of fields, like Description.
TagsNo tags attached.
Attached Files? file icon com.openbravo.support.test-1.0.0.obx [^] (8,004 bytes) 2014-12-10 16:28

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0028382 acknowledgedplatform Clear value button for selectors is not working properly in grid view 
caused by feature request 00244033.0MP29 closedAugustoMauch When the grid calls the datasource, it should not retrieve the properties that are not shown in the grid. 
causes defect 00289853.0PR15Q1.2 closedAugustoMauch It is not possible to freeze a column 

-  Notes
(0072813)
hgbot (developer)
2014-12-24 11:14

Repository: erp/devel/pi
Changeset: 2cf47120feefbfbdb46ca2293391308230850860
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Dec 24 11:11:43 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/2cf47120feefbfbdb46ca2293391308230850860 [^]

Fixes issue 28379: Value from field is not lost after setting it with a process

This issue was caused from a bug in the OBViewGrid.processFICReturn function. There was some code that meant to save in the grid the value of fields that were not being shown in the grid, and that therefore were not returned by the datasource when the grid was loaded. The faulty condition to check if the value of the field was present in the grid was the following:

  if (field && !this.getRecord(rowNum)[field.property]) {

This condition is not proper because it does not check if the field is visible in the grid or not. This condition will evaluate to true if the value of that field is null, even if the field is being shown in the grid. Due to this when the value of the Storage Bin field was erased, its new null value was stored in the list of edited values of the grid, and this value took precedence over the Storage Bin value picked in the process.

To fix this, the condition has been improved to check if the field is actually being shown in the grid.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0072822)
dbaz (developer)
2014-12-24 15:09

Reviewed @ changeset 25596 - 2cf47120feef
(0073266)
hudsonbot (developer)
2014-12-30 23:28

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-12-10 16:21 caristu New Issue
2014-12-10 16:21 caristu Assigned To => AugustoMauch
2014-12-10 16:21 caristu Modules => Core
2014-12-10 16:21 caristu Triggers an Emergency Pack => No
2014-12-10 16:25 caristu Issue Monitored: networkb
2014-12-10 16:28 caristu Steps to Reproduce Updated View Revisions
2014-12-10 16:28 caristu File Added: com.openbravo.support.test-1.0.0.obx
2014-12-11 08:46 alostale Relationship added related to 0028382
2014-12-11 08:47 alostale Assigned To AugustoMauch => inigosanchez
2014-12-11 11:34 alostale Assigned To inigosanchez => NaroaIriarte
2014-12-23 09:35 NaroaIriarte Assigned To NaroaIriarte => AugustoMauch
2014-12-24 11:03 AugustoMauch Regression level => Production - Confirmed Stable
2014-12-24 11:03 AugustoMauch Regression date => 2013-10-07
2014-12-24 11:03 AugustoMauch Regression introduced in release => 3.0MP29
2014-12-24 11:03 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/94d0fb15191969d20c2f89b919bec8a95ad33110 [^]
2014-12-24 11:03 AugustoMauch Issue Monitored: dbaz
2014-12-24 11:03 AugustoMauch Review Assigned To => dbaz
2014-12-24 11:14 hgbot Checkin
2014-12-24 11:14 hgbot Note Added: 0072813
2014-12-24 11:14 hgbot Status new => resolved
2014-12-24 11:14 hgbot Resolution open => fixed
2014-12-24 11:14 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/2cf47120feefbfbdb46ca2293391308230850860 [^]
2014-12-24 15:09 dbaz Note Added: 0072822
2014-12-24 15:09 dbaz Status resolved => closed
2014-12-24 15:09 dbaz Fixed in Version => 3.0PR15Q1
2014-12-30 23:28 hudsonbot Checkin
2014-12-30 23:28 hudsonbot Note Added: 0073266
2015-01-07 10:10 alostale Relationship added caused by 0024403
2015-02-19 10:34 AugustoMauch Relationship added causes 0028985


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker