Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028912
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersmajoralways2015-02-10 19:382015-02-23 05:11
ReporterngarciaView Statuspublic 
Assigned ToSandrahuguet 
PriorityimmediateResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revisiond4473dc7f811
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toumartirena
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0028912: Modulescript needed in order to fix the payment proposal lines wrongly created because of 28591

DescriptionModulescript needed in order to fix the payment proposal lines wrongly created because of 28591
Steps To ReproduceAs system admin role:
   Update the instance to 3.0PR14Q3.5
As group admin role:
   Create two purchase invoices for the same business partner
   Create a payment out that pays these two invoices
   Reverse the payment
   Launch the Payment Monitor background process
   Create a payment proposal for the same business partner
   See that the paid amount in the lines is not correct
From database:
   Make a query to the fin_payment_scheduledetail to see that there is a record with the wrong amount
As system admin role:
   Update the instance to Q3.6
   Make a query to the fin_payment_scheduledetail to see that the record has the proper amount
   Go to the payment proposal window and see that the amount in the lines is not correct
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0028591 closedAtulOpenbravo Reversing a payment is creating wrong invoice payment plan details 

-  Notes
(0074446)
hgbot (developer)
2015-02-13 11:13

Repository: erp/devel/pi
Changeset: da4a7752b4671988c6f61cbad19a61f437a74139
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Fri Feb 13 09:24:33 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/da4a7752b4671988c6f61cbad19a61f437a74139 [^]

Fixed bug 28912 update modulescript Issue28591UpdatePSD

Modulescript Issue28591UpdatePSD should be updated in order
to fix the payment proposal lines wrongly created because of 28591

---
M modules/org.openbravo.advpaymentmngt/build/classes/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSD.class
M modules/org.openbravo.advpaymentmngt/build/classes/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSDData.class
M modules/org.openbravo.advpaymentmngt/src-util/modulescript/src/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSD.java
M modules/org.openbravo.advpaymentmngt/src-util/modulescript/src/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSD_data.xsql
M modules/org.openbravo.advpaymentmngt/src-util/modulescript/src/src/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSDData.java
---
(0074496)
Sandrahuguet (developer)
2015-02-16 08:53

Backed out changeset da4a7752b467

https://code.openbravo.com/erp/devel/pi/rev/d66afa655b19 [^]
(0074497)
hgbot (developer)
2015-02-16 08:54

Repository: erp/devel/pi
Changeset: d4473dc7f8119e288e66728e8a77cfd81db0505a
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Fri Feb 13 09:24:33 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/d4473dc7f8119e288e66728e8a77cfd81db0505a [^]

Fixed bug 28912 update modulescript Issue28591UpdatePSD

Modulescript Issue28591UpdatePSD should be updated in order
to fix the payment proposal lines wrongly created because of 28591

---
M modules/org.openbravo.advpaymentmngt/src-util/modulescript/src/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSD.java
M modules/org.openbravo.advpaymentmngt/src-util/modulescript/src/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSD_data.xsql
M modules/org.openbravo.advpaymentmngt/src-util/modulescript/src/src/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSDData.java
---
(0074532)
hgbot (developer)
2015-02-16 18:46

Repository: erp/devel/pi
Changeset: 1590e4506825ca332b7793bdc81c30d7ae72bc12
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Mon Feb 16 18:45:16 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/1590e4506825ca332b7793bdc81c30d7ae72bc12 [^]

related to issue 28912 .class files are missing in last commit

---
M modules/org.openbravo.advpaymentmngt/build/classes/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSD.class
M modules/org.openbravo.advpaymentmngt/build/classes/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSDData.class
---
(0074551)
umartirena (developer)
2015-02-17 13:08

Code Review + Testing OK
(0074751)
hudsonbot (developer)
2015-02-23 05:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6856352d7235 [^]
Maturity status: Test
(0074759)
hudsonbot (developer)
2015-02-23 05:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6856352d7235 [^]
Maturity status: Test
(0074767)
hudsonbot (developer)
2015-02-23 05:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6856352d7235 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-02-10 19:38 ngarcia New Issue
2015-02-10 19:38 ngarcia Assigned To => Sandrahuguet
2015-02-10 19:38 ngarcia Modules => Core
2015-02-10 19:38 ngarcia Resolution time => 1426460400
2015-02-10 19:38 ngarcia Triggers an Emergency Pack => No
2015-02-10 19:40 ngarcia Issue Monitored: networkb
2015-02-10 19:40 ngarcia Relationship added related to 0028591
2015-02-13 11:13 hgbot Checkin
2015-02-13 11:13 hgbot Note Added: 0074446
2015-02-13 11:13 hgbot Status new => resolved
2015-02-13 11:13 hgbot Resolution open => fixed
2015-02-13 11:13 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/da4a7752b4671988c6f61cbad19a61f437a74139 [^]
2015-02-16 08:53 Sandrahuguet Note Added: 0074496
2015-02-16 08:54 hgbot Checkin
2015-02-16 08:54 hgbot Note Added: 0074497
2015-02-16 08:54 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/da4a7752b4671988c6f61cbad19a61f437a74139 [^] => http://code.openbravo.com/erp/devel/pi/rev/d4473dc7f8119e288e66728e8a77cfd81db0505a [^]
2015-02-16 18:46 hgbot Checkin
2015-02-16 18:46 hgbot Note Added: 0074532
2015-02-17 09:05 Sandrahuguet Review Assigned To => umartirena
2015-02-17 13:08 umartirena Note Added: 0074551
2015-02-17 13:08 umartirena Status resolved => closed
2015-02-17 13:08 umartirena Fixed in Version => pi
2015-02-23 05:11 hudsonbot Checkin
2015-02-23 05:11 hudsonbot Note Added: 0074751
2015-02-23 05:11 hudsonbot Checkin
2015-02-23 05:11 hudsonbot Note Added: 0074759
2015-02-23 05:11 hudsonbot Checkin
2015-02-23 05:11 hudsonbot Note Added: 0074767


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker