Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028591
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersmajoralways2015-01-13 16:522016-02-02 09:34
ReporterngarciaView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchpiFixed in SCM revisiondad8f2ef7d46
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2014-04-22
Regression introduced in release3.0PR14Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/51d72e493b90896a089dca36e1a362347c15761a [^]
Triggers an Emergency PackYes
Summary

0028591: Reversing a payment is creating wrong invoice payment plan details

DescriptionWhen doing a Reverse Payment of a Payment that is paying more than one
invoice, the payment plan details generated have wrong amount. It seems that it is setting the total amount of the payment instead of the amount of the corresponding invoice amount paid in the payment. The same error happens when doing a payment with an invoice and a GL Item.
Steps To Reproduce0. Enable the Reverse Payment functionality as described in the following wiki document:
http://wiki.openbravo.com/wiki/Projects:Reversepayment/User_Manual [^]

1. Create 2 Sales Invoices using any business partner and product.
2. Pay both invoices in the same Payment In.
3. Reverse the created payment.
4. Go to one of the invoices and open the add payment pick and execute.
5. Check that the outstanding amount is the total amount of the reversed payment
instead of the expected payment.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on defect 0028686 closedairaceburu Reversing a payment is creating wrong invoice payment plan 
caused by defect 0026121 closedAtulOpenbravo Wrong payment schedule detail generated when running Reverse Payment process from Write-off payment 
related to defect 0028912 closedSandrahuguet Modulescript needed in order to fix the payment proposal lines wrongly created because of 28591 

-  Notes
(0073482)
AtulOpenbravo (developer)
2015-01-13 20:33

Test Plan
- Enable the Reverse Payment functionality as described in the following wiki document:
http://wiki.openbravo.com/wiki/Projects:Reversepayment/User_Manual [^] [^]

1. Create 2 Sales Invoices using any business partner and product.
2. Pay both invoices in the same Payment In.
3. Reverse the created payment.
4. Go to one of the invoices and open the add payment pick and execute.
5. Check that the outstanding amount is the expected payment amount.
(0073655)
hgbot (developer)
2015-01-20 18:35

Repository: erp/devel/pi
Changeset: 9c12d1443b200650ca55861bb6377d2b1d8e964c
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Tue Jan 20 15:42:13 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/9c12d1443b200650ca55861bb6377d2b1d8e964c [^]

Fixes Issue 28591:Reversing a payment is creating wrong invoice payment plan
details

Problem is Schedule detail was being updated by payment amount now it is taken
care to update using individual schedule detail amount while creating reverse
payment schedule and payment schedule details.

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/process/FIN_PaymentProcess.java
A modules/org.openbravo.advpaymentmngt/build/classes/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSD.class
A modules/org.openbravo.advpaymentmngt/build/classes/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSDData.class
A modules/org.openbravo.advpaymentmngt/src-util/modulescript/src/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSD.java
A modules/org.openbravo.advpaymentmngt/src-util/modulescript/src/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSD_data.xsql
A modules/org.openbravo.advpaymentmngt/src-util/modulescript/src/src/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSDData.java
---
(0073656)
Sandrahuguet (developer)
2015-01-20 18:36

Code review + testing OK
(0073669)
AtulOpenbravo (developer)
2015-01-21 03:52

Re-opened due to wrong fix pushed which fails int-inc-oracle try test.
(0073670)
hgbot (developer)
2015-01-21 04:03

Repository: erp/devel/pi
Changeset: dad8f2ef7d46cb0d4235c77a45842dc1a9ba9375
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Tue Jan 20 14:57:35 2015 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/dad8f2ef7d46cb0d4235c77a45842dc1a9ba9375 [^]

Fixes Issue 28591:Reversing a payment is creating wrong invoice payment plan
details

Problem is Schedule detail was being updated by payment amount now it is taken
care to update using individual schedule detail amount while creating reverse
payment schedule and payment schedule details. Modulescript to fix errorneous data
consists of update invoice paid, outstanding amt, update payment schedule received
and outstanding amount, update payment credit generated info if in case required.

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/process/FIN_PaymentProcess.java
A modules/org.openbravo.advpaymentmngt/build/classes/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSD.class
A modules/org.openbravo.advpaymentmngt/build/classes/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSDData.class
A modules/org.openbravo.advpaymentmngt/src-util/modulescript/src/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSD.java
A modules/org.openbravo.advpaymentmngt/src-util/modulescript/src/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSD_data.xsql
A modules/org.openbravo.advpaymentmngt/src-util/modulescript/src/src/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSDData.java
---
(0073677)
hgbot (developer)
2015-01-21 10:06

Repository: erp/devel/pi
Changeset: 235d47fa148da3752e54dccbef539650710464df
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Wed Jan 21 13:29:26 2015 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/235d47fa148da3752e54dccbef539650710464df [^]

Related to Issue 28591:Removed unwanted code from the modulescript to update
payment plan and payment plan details

---
M modules/org.openbravo.advpaymentmngt/build/classes/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSD.class
M modules/org.openbravo.advpaymentmngt/build/classes/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSDData.class
M modules/org.openbravo.advpaymentmngt/src-util/modulescript/src/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSD.java
M modules/org.openbravo.advpaymentmngt/src-util/modulescript/src/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSD_data.xsql
M modules/org.openbravo.advpaymentmngt/src-util/modulescript/src/src/org/openbravo/advpaymentmngt/modulescript/Issue28591UpdatePSDData.java
---
(0073678)
Sandrahuguet (developer)
2015-01-21 10:22

Code review + testing OK
(0074166)
hudsonbot (developer)
2015-02-04 20:34

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f36c91d0ad63 [^]
Maturity status: Test
(0074168)
hudsonbot (developer)
2015-02-04 20:34

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f36c91d0ad63 [^]
Maturity status: Test
(0074170)
hudsonbot (developer)
2015-02-04 20:34

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f36c91d0ad63 [^]
Maturity status: Test
(0074752)
hudsonbot (developer)
2015-02-23 05:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6856352d7235 [^]
Maturity status: Test
(0074753)
hudsonbot (developer)
2015-02-23 05:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6856352d7235 [^]
Maturity status: Test
(0074760)
hudsonbot (developer)
2015-02-23 05:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6856352d7235 [^]
Maturity status: Test
(0074761)
hudsonbot (developer)
2015-02-23 05:11

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6856352d7235 [^]
Maturity status: Test
(0079966)
hudsonbot (developer)
2015-09-01 00:03

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/880a20775a45 [^]
Maturity status: Test
(0079967)
hudsonbot (developer)
2015-09-01 00:03

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/880a20775a45 [^]
Maturity status: Test
(0083805)
hgbot (developer)
2016-02-02 09:34

Repository: tools/automation/int
Changeset: 266ab2fdd707a7a201eae0c7f17e4d4db3d7081c
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Fri Sep 25 09:31:29 2015 +0200
URL: http://code.openbravo.com/tools/automation/int/rev/266ab2fdd707a7a201eae0c7f17e4d4db3d7081c [^]

Related to issue 28591: Added some automated tests

---
M src-test/com/openbravo/test/integration/erp/gui/financial/receivablespayables/transactions/AddPaymentProcess.java
M src-test/com/openbravo/test/integration/erp/gui/financial/receivablespayables/transactions/paymentin/PaymentInTab.java
M src-test/com/openbravo/test/integration/erp/gui/financial/receivablespayables/transactions/paymentout/PaymentOutTab.java
M src-test/com/openbravo/test/integration/erp/gui/popups/RequestProcessPopUp.java
M src-test/com/openbravo/test/integration/erp/modules/client/application/gui/GeneratedTab.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/RegressionSuite.java
M src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/build.xml
M src-test/com/openbravo/test/integration/erp/testscripts/financial/receivablespayables/transactions/PaymentIn.java
M src-test/com/openbravo/test/integration/erp/testscripts/financial/receivablespayables/transactions/PaymentOut.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APRRegression018.java
A src-test/com/openbravo/test/integration/erp/modules/functionalteam/addpayment/testsuites/APR_Regressions/APRRegression019.java
---

- Issue History
Date Modified Username Field Change
2015-01-13 16:52 ngarcia New Issue
2015-01-13 16:52 ngarcia Assigned To => Sandrahuguet
2015-01-13 16:52 ngarcia Modules => Core
2015-01-13 16:52 ngarcia Triggers an Emergency Pack => No
2015-01-13 16:53 ngarcia Issue Monitored: networkb
2015-01-13 18:15 Sandrahuguet Assigned To Sandrahuguet => AtulOpenbravo
2015-01-13 18:16 ngarcia Regression level => Production - Confirmed Stable
2015-01-13 18:16 ngarcia Regression date => 2014-04-22
2015-01-13 18:16 ngarcia Regression introduced in release => 3.0PR14Q3
2015-01-13 18:16 ngarcia Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/51d72e493b90896a089dca36e1a362347c15761a [^]
2015-01-13 18:16 ngarcia Triggers an Emergency Pack No => Yes
2015-01-13 18:18 ngarcia Priority urgent => immediate
2015-01-13 18:25 AtulOpenbravo Status new => scheduled
2015-01-13 18:25 AtulOpenbravo fix_in_branch => pi
2015-01-13 18:32 ngarcia Relationship added caused by 0026121
2015-01-13 20:33 AtulOpenbravo Note Added: 0073482
2015-01-20 12:06 Sandrahuguet Relationship added depends on 0028686
2015-01-20 15:47 Sandrahuguet File Added: bug_28591.diff
2015-01-20 18:35 hgbot Checkin
2015-01-20 18:35 hgbot Note Added: 0073655
2015-01-20 18:35 hgbot Status scheduled => resolved
2015-01-20 18:35 hgbot Resolution open => fixed
2015-01-20 18:35 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/9c12d1443b200650ca55861bb6377d2b1d8e964c [^]
2015-01-20 18:36 Sandrahuguet Review Assigned To => Sandrahuguet
2015-01-20 18:36 Sandrahuguet Note Added: 0073656
2015-01-20 18:36 Sandrahuguet Status resolved => closed
2015-01-20 18:36 Sandrahuguet Fixed in Version => 3.0PR15Q2
2015-01-21 03:52 AtulOpenbravo Note Added: 0073669
2015-01-21 03:52 AtulOpenbravo Status closed => new
2015-01-21 03:52 AtulOpenbravo Resolution fixed => open
2015-01-21 03:52 AtulOpenbravo Fixed in Version 3.0PR15Q2 =>
2015-01-21 03:52 AtulOpenbravo Status new => scheduled
2015-01-21 04:03 hgbot Checkin
2015-01-21 04:03 hgbot Note Added: 0073670
2015-01-21 04:03 hgbot Status scheduled => resolved
2015-01-21 04:03 hgbot Resolution open => fixed
2015-01-21 04:03 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/9c12d1443b200650ca55861bb6377d2b1d8e964c [^] => http://code.openbravo.com/erp/devel/pi/rev/dad8f2ef7d46cb0d4235c77a45842dc1a9ba9375 [^]
2015-01-21 09:13 Sandrahuguet File Deleted: bug_28591.diff
2015-01-21 10:06 hgbot Checkin
2015-01-21 10:06 hgbot Note Added: 0073677
2015-01-21 10:22 Sandrahuguet Note Added: 0073678
2015-01-21 10:22 Sandrahuguet Status resolved => closed
2015-01-21 10:22 Sandrahuguet Fixed in Version => 3.0PR15Q2
2015-02-04 20:34 hudsonbot Checkin
2015-02-04 20:34 hudsonbot Note Added: 0074166
2015-02-04 20:34 hudsonbot Checkin
2015-02-04 20:34 hudsonbot Note Added: 0074168
2015-02-04 20:34 hudsonbot Checkin
2015-02-04 20:34 hudsonbot Note Added: 0074170
2015-02-10 19:40 ngarcia Relationship added related to 0028912
2015-02-23 05:11 hudsonbot Checkin
2015-02-23 05:11 hudsonbot Note Added: 0074752
2015-02-23 05:11 hudsonbot Checkin
2015-02-23 05:11 hudsonbot Note Added: 0074753
2015-02-23 05:11 hudsonbot Checkin
2015-02-23 05:11 hudsonbot Note Added: 0074760
2015-02-23 05:11 hudsonbot Checkin
2015-02-23 05:11 hudsonbot Note Added: 0074761
2015-09-01 00:03 hudsonbot Checkin
2015-09-01 00:03 hudsonbot Note Added: 0079966
2015-09-01 00:03 hudsonbot Checkin
2015-09-01 00:03 hudsonbot Note Added: 0079967
2016-02-02 09:34 hgbot Checkin
2016-02-02 09:34 hgbot Note Added: 0083805


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker