Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028873
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2015-02-05 13:202015-04-13 13:07
ReporterjecharriView Statuspublic 
Assigned Tomigueldejuana 
PriorityimmediateResolutionfixedFixed in VersionRR15Q2
StatusclosedFix in branchFixed in SCM revisionde1acb7a164d
ProjectionnoneETAnoneTarget VersionRR15Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToOrekaria
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0028873: Cash up is not working properly and success message can take minutes

DescriptionCash up is not working properly and success message can take minutes. The problem is that we are not showing success message until the process finished executing in the ERP.

The solution should be to work online as we do in offline:
-do the cash up
-show the success message
-in parallel execute the runSyncProcess
Steps To Reproduce-Go to Web POS
-Do a cash up

Verify that the cash up will take more time if you are online than offline
TagsNo tags attached.
Attached Filesdiff file icon issue28873posterminal.diff [^] (1,562 bytes) 2015-02-12 09:03 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0028215RR15Q1 closedmigueldejuana Logout when data is not synchronized shows javascript errors 
depends on backport 0029569RR15Q1.3 closedmigueldejuana Cash up is not working properly and success message can take minutes 

-  Notes
(0074363)
migueldejuana (developer)
2015-02-12 08:45

If we have sessions module installed, after doing the cashup we logout and it could give an error because ProcessCashClose is running but it doesn't affect to the flow. We should avoid showing this message avoiding doing logout while data is synchronizing (https://issues.openbravo.com/view.php?id=28215 [^])
(0074366)
migueldejuana (developer)
2015-02-12 09:04

I have attached a patch for Q3.5 --> issue28873posterminal.diff
(0074367)
hgbot (developer)
2015-02-12 09:07

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 3f936397a692ea269e2be88ec651f25ef43a9c0b
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Thu Feb 12 09:06:38 2015 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/3f936397a692ea269e2be88ec651f25ef43a9c0b [^]

Fixed issue 0028873: Cash up is not working properly and success message can take minutes

If objToSend is null, we must not send it to backend

---
M web/org.openbravo.mobile.core/source/model/ob-terminal-model.js
---
(0074368)
hgbot (developer)
2015-02-12 09:08

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 3407752f5c66a6af3d30316d8939b652f9a81ffd
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Thu Feb 12 09:05:44 2015 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/3407752f5c66a6af3d30316d8939b652f9a81ffd [^]

Fixed issue 0028873: Cash up is not working properly and success message can take minutes

We need to skip retrieving cashup from backend because we are processing the cashup and it is not processed yet.

---
M web/org.openbravo.retail.posterminal/js/closecash/model/cashup-model.js
M web/org.openbravo.retail.posterminal/js/utils/cashUpReportUtils.js
---
(0074448)
Orekaria (administrator)
2015-02-13 11:43

Working on Retail
(0076474)
hgbot (developer)
2015-04-13 12:35

Repository: retail/backports/3.0RR15Q1.3/org.openbravo.mobile.core
Changeset: daf76cf73c8f2af7f944f7b41dae012dc4e47e6c
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Thu Feb 12 09:06:38 2015 +0100
URL: http://code.openbravo.com/retail/backports/3.0RR15Q1.3/org.openbravo.mobile.core/rev/daf76cf73c8f2af7f944f7b41dae012dc4e47e6c [^]

Fixed issue 0028873, fixes issue 29569: Cash up is not working properly and success message can take minutes

If objToSend is null, we must not send it to backend

---
M web/org.openbravo.mobile.core/source/model/ob-terminal-model.js
---
(0076476)
hgbot (developer)
2015-04-13 12:35

Repository: retail/backports/3.0RR15Q1.3/org.openbravo.retail.posterminal
Changeset: de1acb7a164df1941cd9fbd7ef5261cb45562d5e
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Thu Feb 12 09:05:44 2015 +0100
URL: http://code.openbravo.com/retail/backports/3.0RR15Q1.3/org.openbravo.retail.posterminal/rev/de1acb7a164df1941cd9fbd7ef5261cb45562d5e [^]

Fixed issue 0028873, fixes issue 29569: Cash up is not working properly and success message can take minutes

We need to skip retrieving cashup from backend because we are processing the cashup and it is not processed yet.

---
M web/org.openbravo.retail.posterminal/js/closecash/model/cashup-model.js
M web/org.openbravo.retail.posterminal/js/utils/cashUpReportUtils.js
---

- Issue History
Date Modified Username Field Change
2015-02-05 13:20 jecharri New Issue
2015-02-05 13:20 jecharri Assigned To => marvintm
2015-02-05 13:20 jecharri Triggers an Emergency Pack => No
2015-02-05 13:23 jecharri Description Updated View Revisions
2015-02-12 08:43 migueldejuana Relationship added related to 0028215
2015-02-12 08:45 migueldejuana Note Added: 0074363
2015-02-12 09:03 migueldejuana File Added: issue28873posterminal.diff
2015-02-12 09:04 migueldejuana Note Added: 0074366
2015-02-12 09:07 hgbot Checkin
2015-02-12 09:07 hgbot Note Added: 0074367
2015-02-12 09:07 hgbot Status new => resolved
2015-02-12 09:07 hgbot Resolution open => fixed
2015-02-12 09:07 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/3f936397a692ea269e2be88ec651f25ef43a9c0b [^]
2015-02-12 09:08 hgbot Checkin
2015-02-12 09:08 hgbot Note Added: 0074368
2015-02-12 09:08 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/3f936397a692ea269e2be88ec651f25ef43a9c0b [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/3407752f5c66a6af3d30316d8939b652f9a81ffd [^]
2015-02-12 12:40 migueldejuana Assigned To marvintm => migueldejuana
2015-02-13 11:43 Orekaria Review Assigned To => Orekaria
2015-02-13 11:43 Orekaria Note Added: 0074448
2015-02-13 11:43 Orekaria Status resolved => closed
2015-02-13 11:43 Orekaria Fixed in Version => RR15Q2
2015-04-13 12:05 marvintm Status closed => new
2015-04-13 12:05 marvintm Resolution fixed => open
2015-04-13 12:05 marvintm Fixed in Version RR15Q2 =>
2015-04-13 12:05 marvintm Status new => scheduled
2015-04-13 12:05 marvintm Status scheduled => resolved
2015-04-13 12:05 marvintm Resolution open => fixed
2015-04-13 12:06 marvintm Status resolved => new
2015-04-13 12:06 marvintm Resolution fixed => open
2015-04-13 12:06 marvintm Status new => scheduled
2015-04-13 12:06 marvintm Status scheduled => resolved
2015-04-13 12:06 marvintm Fixed in Version => RR15Q2
2015-04-13 12:06 marvintm Resolution open => fixed
2015-04-13 12:06 marvintm Status resolved => closed
2015-04-13 12:35 hgbot Checkin
2015-04-13 12:35 hgbot Note Added: 0076474
2015-04-13 12:35 hgbot Status closed => resolved
2015-04-13 12:35 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/3407752f5c66a6af3d30316d8939b652f9a81ffd [^] => http://code.openbravo.com/retail/backports/3.0RR15Q1.3/org.openbravo.mobile.core/rev/daf76cf73c8f2af7f944f7b41dae012dc4e47e6c [^]
2015-04-13 12:35 hgbot Checkin
2015-04-13 12:35 hgbot Note Added: 0076476
2015-04-13 12:35 hgbot Fixed in SCM revision http://code.openbravo.com/retail/backports/3.0RR15Q1.3/org.openbravo.mobile.core/rev/daf76cf73c8f2af7f944f7b41dae012dc4e47e6c [^] => http://code.openbravo.com/retail/backports/3.0RR15Q1.3/org.openbravo.retail.posterminal/rev/de1acb7a164df1941cd9fbd7ef5261cb45562d5e [^]
2015-04-13 13:07 Orekaria Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker