Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028712
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2015-01-21 12:382015-03-02 20:31
ReportercaristuView Statuspublic 
Assigned Toalostale 
PriorityurgentResolutionfixedFixed in Version3.0PR15Q2
StatusclosedFix in branchpiFixed in SCM revisionbecbc7144120
ProjectionnoneETAnoneTarget Version3.0PR15Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0028712: Records selection is lost in pick and execute window under some circumnstances

DescriptionRecords selection is lost in pick and execute window under some circumstances. It happen when selecting records from different pages.
Steps To Reproduce1) Install the attached module
2) Go to the [Sales Order] window. Click on the EM_Suptest_Proc which opens a P&E window.
3) Select a couple of records
4) Filter by docno column in order to display a record from another page. Select one of that records
5) Remove the filter
6) Select another record
7) Apply the same filter applied in 4). Notice that the selected record in 4) appears unselected
TagsNo tags attached.
Attached Files? file icon com.openbravo.support.test-1.0.0.obx [^] (23,955 bytes) 2015-01-21 12:38

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00284683.0PR15Q2 closedAugustoMauch Some values entered by a selection function are lost in P&E windows under some circumstances 
related to defect 00225223.0MP20 closedAugustoMauch In Pick&Execute windows a removed selection appears when sorting the columns 
related to defect 0028923 closedplatform The multiple selector on the processdefinition does not maintain the selections of records from a position bigger than 76 
related to defect 0029028 acknowledgedplatform Selected record is lost after executing a pick and execute process under some circumnstances 
related to defect 0029145 closedSandrahuguet Used credit is not correct under certain circumstances 
causes defect 0029032 closedAugustoMauch int-basic-pgsql/oracle tests are broken due to change in pick and execute windows 
causes defect 0029140 closedalostale Credit selected in the grid is not used when the payment is processed 

-  Notes
(0074798)
alostale (developer)
2015-02-23 11:11

Note that following the described steps till 5 and submitting the form, the record selected in a different page is not sent to the backend as part of the selection.
(0074800)
hgbot (developer)
2015-02-23 11:23

Repository: erp/devel/pi
Changeset: d061c9e837aa5a0ce0a7fb221e1ac8c822748988
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Feb 23 11:17:39 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/d061c9e837aa5a0ce0a7fb221e1ac8c822748988 [^]

fixed bug 28712: record selection lost in p&e grid if data has multiple pages

  In P&E grid with data displayed in several pages, if part of the selection was
  not in the 1st page two errors occured:

    -If after selecting a record in 2nd page another one in the 1st page was selected,
     selection of record in 2nd page was lost
    -If record in 2nd page was selected by using a filter, the filter was removed, and
     the p&e was submitted, the selection was not sent to backend

  The problem is in SC grid.getSelectedRecords which returns records only in current
  page.

  To solve this a cache of selected/unselected records is completelly maintained for p&e
  grids without using getSelectedRecords, this is used also to send the selected recors
  on p&e submission.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-pickeditgrid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
---
(0074811)
AugustoMauch (developer)
2015-02-23 15:46

Reopened because apparently the fix has broken ci [1], [2]

[1] http://ci.openbravo.com/job/int-basic-pgsql/772/ [^]
[2] http://ci.openbravo.com/job/int-basic-oracle/780/ [^]
(0074813)
AugustoMauch (developer)
2015-02-23 17:49

Set as resolved again, the CI break will be dealt with in another issue
(0074829)
AugustoMauch (developer)
2015-02-24 10:59

Reopened because the fix has broken ci [1], [2], and fixing those broken tests is not trivial

[1] http://ci.openbravo.com/job/int-basic-pgsql/772/ [^]
[2] http://ci.openbravo.com/job/int-basic-oracle/780/ [^]
(0074830)
hgbot (developer)
2015-02-24 11:08

Repository: erp/devel/pi
Changeset: b8e08285349001bc1d72d2a0a49f40be59a1e2db
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Feb 24 11:07:02 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/b8e08285349001bc1d72d2a0a49f40be59a1e2db [^]

Fixes issue 29032, related with issue 28712: Backs out changeset d061c9e837aa

This changeset has been backed out as it is breaking the int-basic-pgsql and int-basic-oracle tests.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-pickeditgrid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
---
(0074838)
AugustoMauch (developer)
2015-02-24 11:28

This changeset [1] was causing at least one regression:

As QA Testing Admin:
- Open the Sales Order window
- Create a new record, use the Customer A business partner
- Create a new line
- Book the record
- Click on the Add Payment button. The first line of the P&E grid will be selected, but some events that should have been triggered have not taken place properly. The Expected Payment read-only parameter should be equals to the Amount column of the selected row, but it is empty.
- Deselect the row and select it again. Check that now the value of the Expected Payment parameter is OK.

[1] https://issues.openbravo.com/view.php?id=28712#c74800 [^]
(0074889)
hudsonbot (developer)
2015-02-24 23:09

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6c8e140b31ec [^]
Maturity status: Test
(0074895)
hudsonbot (developer)
2015-02-24 23:09

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6c8e140b31ec [^]
Maturity status: Test
(0075028)
hgbot (developer)
2015-02-27 12:43

Repository: erp/mods/com.openbravo.support.test
Changeset: 66afed4b598638dd0409fd4237e3e37b6b612c7b
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Feb 27 11:53:49 2015 +0100
URL: http://code.openbravo.com/erp/mods/com.openbravo.support.test/rev/66afed4b598638dd0409fd4237e3e37b6b612c7b [^]

added p&e for issue 28712

---
R src-db/database/model/modifiedTables/C_ORDER.xml
R src-db/database/model/modifiedTables/M_INOUTLINE.xml
R src-db/database/model/views/SUPTEST_ORDERLINE_V.xml
R src-db/database/sourcedata/AD_COLUMN.xml
R src-db/database/sourcedata/AD_FIELD.xml
R src-db/database/sourcedata/AD_MENU.xml
R src-db/database/sourcedata/AD_MODULE.xml
R src-db/database/sourcedata/AD_MODULE_DBPREFIX.xml
R src-db/database/sourcedata/AD_MODULE_DEPENDENCY.xml
R src-db/database/sourcedata/AD_PACKAGE.xml
R src-db/database/sourcedata/AD_REFERENCE.xml
R src-db/database/sourcedata/AD_TAB.xml
R src-db/database/sourcedata/AD_TABLE.xml
R src-db/database/sourcedata/AD_TREENODE.xml
R src-db/database/sourcedata/AD_WINDOW.xml
R src-db/database/sourcedata/OBUIAPP_PARAMETER.xml
R src-db/database/sourcedata/OBUIAPP_PROCESS.xml
R src-db/database/sourcedata/OBUIAPP_REF_WINDOW.xml
R src-db/database/sourcedata/OBUIAPP_VIEW_IMPL.xml
R src/TestButler.java
R src/TestDate.java
R src/com/openbravo/support/test/MyComponentProvider.java
R src/com/openbravo/support/test/SetStorageBinHandler.java
R src/com/openbravo/support/test/SupSelectOrderLines.java
R src/com/openbravo/support/test/SupSelectOrderLines.java~
R src/com/openbravo/support/test/TestButler.java
R web/com.openbravo.support.test/js/myCalendar.js
R web/com.openbravo.support.test/js/onSelect.js
R web/com.openbravo.support.test/js/onSelect.js~
---
(0075053)
hgbot (developer)
2015-03-02 08:45

Repository: erp/devel/pi
Changeset: becbc7144120c7e6b95f93309b9d2617648547bf
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Feb 26 11:26:38 2015 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/becbc7144120c7e6b95f93309b9d2617648547bf [^]

fixed bug 28712: record selection lost in p&e grid if data has multiple pages

  In P&E grid with data displayed in several pages, if part of the selection was
  not in the 1st page two errors occured:

    -If after selecting a record in 2nd page another one in the 1st page was selected,
     selection of record in 2nd page was lost
    -If record in 2nd page was selected by using a filter, the filter was removed, and
     the p&e was submitted, the selection was not sent to backend

  The problem is in SC grid.getSelectedRecords which returns records only in current
  page.

  To solve this a cache of selected/unselected records is completelly maintained for p&e
  grids without using getSelectedRecords, this is used also to send the selected recors
  on p&e submission.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-pickeditgrid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
---
(0075075)
AugustoMauch (developer)
2015-03-02 13:04

Code reviewed and verified in pi@fc4236ca4ff7
(0075107)
hudsonbot (developer)
2015-03-02 20:31

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9d659cacae03 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-01-21 12:38 caristu New Issue
2015-01-21 12:38 caristu Assigned To => AugustoMauch
2015-01-21 12:38 caristu File Added: com.openbravo.support.test-1.0.0.obx
2015-01-21 12:38 caristu Modules => Core
2015-01-21 12:38 caristu Triggers an Emergency Pack => No
2015-01-21 12:38 caristu Issue Monitored: networkb
2015-01-21 12:38 caristu Relationship added related to 0028468
2015-01-21 12:49 heccam Issue Monitored: heccam
2015-01-29 12:26 alostale Note Added: 0073893
2015-01-29 12:27 alostale Assigned To AugustoMauch => caristu
2015-01-29 12:27 alostale Status new => feedback
2015-01-29 13:07 alostale Assigned To caristu => alostale
2015-01-29 13:07 alostale Status feedback => new
2015-01-29 13:07 alostale Status new => acknowledged
2015-02-12 13:41 egoitz Relationship added related to 0028923
2015-02-17 13:40 alostale Note Deleted: 0073893
2015-02-19 12:52 alostale Status acknowledged => scheduled
2015-02-19 12:52 alostale Assigned To alostale => NaroaIriarte
2015-02-19 12:52 alostale fix_in_branch => pi
2015-02-23 09:42 alostale Relationship added related to 0022522
2015-02-23 10:19 AugustoMauch Assigned To NaroaIriarte => alostale
2015-02-23 11:11 alostale Note Added: 0074798
2015-02-23 11:11 alostale Review Assigned To => AugustoMauch
2015-02-23 11:11 alostale fix_in_branch pi =>
2015-02-23 11:23 hgbot Checkin
2015-02-23 11:23 hgbot Note Added: 0074800
2015-02-23 11:23 hgbot Status scheduled => resolved
2015-02-23 11:23 hgbot Resolution open => fixed
2015-02-23 11:23 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d061c9e837aa5a0ce0a7fb221e1ac8c822748988 [^]
2015-02-23 15:46 AugustoMauch Note Added: 0074811
2015-02-23 15:46 AugustoMauch Status resolved => new
2015-02-23 15:46 AugustoMauch Resolution fixed => open
2015-02-23 16:17 caristu Relationship added related to 0029028
2015-02-23 16:18 caristu Relationship deleted related to 0029028
2015-02-23 17:37 alostale Relationship added related to 0029028
2015-02-23 17:48 AugustoMauch Status new => scheduled
2015-02-23 17:48 AugustoMauch fix_in_branch => pi
2015-02-23 17:49 AugustoMauch Note Added: 0074813
2015-02-23 17:49 AugustoMauch Status scheduled => resolved
2015-02-23 17:49 AugustoMauch Resolution open => fixed
2015-02-23 18:13 AugustoMauch Relationship added causes 0029032
2015-02-24 10:59 AugustoMauch Note Added: 0074829
2015-02-24 10:59 AugustoMauch Status resolved => new
2015-02-24 10:59 AugustoMauch Resolution fixed => open
2015-02-24 11:08 hgbot Checkin
2015-02-24 11:08 hgbot Note Added: 0074830
2015-02-24 11:28 AugustoMauch Note Added: 0074838
2015-02-24 17:08 alostale Status new => scheduled
2015-02-24 23:09 hudsonbot Checkin
2015-02-24 23:09 hudsonbot Note Added: 0074889
2015-02-24 23:09 hudsonbot Checkin
2015-02-24 23:09 hudsonbot Note Added: 0074895
2015-02-27 12:43 hgbot Checkin
2015-02-27 12:43 hgbot Note Added: 0075028
2015-03-02 08:45 hgbot Checkin
2015-03-02 08:45 hgbot Note Added: 0075053
2015-03-02 08:45 hgbot Status scheduled => resolved
2015-03-02 08:45 hgbot Resolution open => fixed
2015-03-02 08:45 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/d061c9e837aa5a0ce0a7fb221e1ac8c822748988 [^] => http://code.openbravo.com/erp/devel/pi/rev/becbc7144120c7e6b95f93309b9d2617648547bf [^]
2015-03-02 13:04 AugustoMauch Note Added: 0075075
2015-03-02 13:04 AugustoMauch Status resolved => closed
2015-03-02 13:04 AugustoMauch Fixed in Version => 3.0PR15Q2
2015-03-02 20:31 hudsonbot Checkin
2015-03-02 20:31 hudsonbot Note Added: 0075107
2015-03-05 12:34 AugustoMauch Relationship added causes 0029140
2015-03-05 17:07 alostale Relationship added related to 0029145


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker