Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028651
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformtrivialalways2015-01-18 17:232015-05-07 22:16
ReporterrjapoovaView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q3
StatusclosedFix in branchFixed in SCM revisionf1075c59ffbf
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0PR14Q4SCM revision 
Review Assigned ToAugustoMauch
Web browserGoogle Chrome
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2013-09-01
Regression introduced in release3.0PR14Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/015591a05799 [^]
Triggers an Emergency PackNo
Summary

0028651: Transaction Type field is incorrectly flagged as red when transactions are entered in grid mode

DescriptionIn the Financial Account window, when entering a transaction manually in grid mode, you need to specify the Transaction Type (BP Deposit, BP Withdrawal, etc.).

When changing this field, the field is flagged as red.

This indicates that there is something wrong with the logic around this field.

The red flag can be safely ignored and users can continue successfully.
Steps To ReproduceLook at this video for the first 30 seconds:
https://drive.google.com/file/d/0B2uCUQlrOPvIMEhPWVF3STdINTA/view?usp=sharing [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0026189 closedalostale [PR14Q2] In Business partner combo box, keyed values get deleted 
depends on backport 00294663.0PR15Q2 closedalostale Transaction Type field is incorrectly flagged as red when transactions are entered in grid mode 
depends on backport 00294673.0PR15Q1.3 closedalostale Transaction Type field is incorrectly flagged as red when transactions are entered in grid mode 
caused by feature request 0025574 closeddbaz Upgrade SmartClient 10.0d 

-  Notes
(0076106)
dmitry_mezentsev (developer)
2015-03-28 12:40

1. Happens the same in all List References, for example, Product window --> Product Type, but at the same time behavior is different (no highlight) if it is TableDir reference, for example Product window --> Product Category (btw in 14Q2 even in Product Category the behavior was the same - red highlight till the selection is finished).
2. IMHO red highlight till selection is not finished is too much but for David to decide.
(0076171)
hgbot (developer)
2015-03-31 12:46

Repository: erp/devel/pi
Changeset: f1075c59ffbf77b5c44898fa2f901c0df8dc169e
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Mar 31 12:45:26 2015 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f1075c59ffbf77b5c44898fa2f901c0df8dc169e [^]

fixed bug 28651: list reference are validated while typing

  This caused to see the field in red as non valid while typing to filter a value.

  It has been fixed in the same way selector reference does: preventing validation
  on filterComplete. A new OBComboBoxItem class has been implemented in order to
  make both list and selectors (including table and tableDir) extend it preventing
  in this manner code duplicities.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/ApplicationComponentProvider.java
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-list.js
M modules/org.openbravo.userinterface.selector/web/org.openbravo.userinterface.selector/js/ob-selector-item.js
A modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-combo.js
---
(0076178)
AugustoMauch (developer)
2015-03-31 16:22

Code reviewed and verified in pi@f1075c59ffbf
(0076680)
AugustoMauch (developer)
2015-04-22 10:20

Created test in testlink: https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-8205 [^]
(0077106)
hudsonbot (developer)
2015-05-07 22:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a1817f84bd8b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2015-01-18 17:23 rjapoova New Issue
2015-01-18 17:23 rjapoova Assigned To => dmiguelez
2015-01-18 17:23 rjapoova Web browser => Google Chrome
2015-01-18 17:23 rjapoova Modules => Core
2015-01-18 17:23 rjapoova Triggers an Emergency Pack => No
2015-03-28 12:40 dmitry_mezentsev Note Added: 0076106
2015-03-28 12:41 dmitry_mezentsev Web browser Google Chrome => Google Chrome
2015-03-28 12:41 dmitry_mezentsev Assigned To dmiguelez => platform
2015-03-28 12:41 dmitry_mezentsev Status new => acknowledged
2015-03-31 10:08 alostale Review Assigned To => AugustoMauch
2015-03-31 10:08 alostale Web browser Google Chrome => Google Chrome
2015-03-31 10:08 alostale Regression introduced in release => 3.0PR14Q2
2015-03-31 10:08 alostale Priority normal => immediate
2015-03-31 10:08 alostale Category 09. Financial management => A. Platform
2015-03-31 10:09 alostale Assigned To platform => alostale
2015-03-31 10:18 alostale Status acknowledged => scheduled
2015-03-31 11:22 alostale Relationship added related to 0026189
2015-03-31 11:24 alostale Web browser Google Chrome => Google Chrome
2015-03-31 11:24 alostale Regression level => Production - Confirmed Stable
2015-03-31 11:24 alostale Regression date => 2013-09-01
2015-03-31 11:24 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/015591a05799 [^]
2015-03-31 11:24 alostale Relationship added caused by 0025574
2015-03-31 12:46 hgbot Checkin
2015-03-31 12:46 hgbot Note Added: 0076171
2015-03-31 12:46 hgbot Status scheduled => resolved
2015-03-31 12:46 hgbot Resolution open => fixed
2015-03-31 12:46 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/f1075c59ffbf77b5c44898fa2f901c0df8dc169e [^]
2015-03-31 16:22 AugustoMauch Note Added: 0076178
2015-03-31 16:22 AugustoMauch Status resolved => closed
2015-03-31 16:22 AugustoMauch Fixed in Version => 3.0PR15Q3
2015-04-22 10:20 AugustoMauch Note Added: 0076680
2015-05-07 22:16 hudsonbot Checkin
2015-05-07 22:16 hudsonbot Note Added: 0077106


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker