Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028261
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2014-11-24 15:222014-12-30 23:26
ReporteralostaleView Statuspublic 
Assigned Toinigosanchez 
PrioritynormalResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchFixed in SCM revision3702a2c3cb7e
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0028261: Weekdays process scheduling doesn't work

DescriptionWhenever a process is tried to be scheduled to Weekdays an error is thrown.
Steps To Reproduce-Create a new Process Request
-Schedule it as Daily, Weekdays
-Click the Schedule button -> Error is trhown
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00280033.0PR15Q1 closedinigosanchez The daily background process is executed incorrectly when changing from summer time to winter time 

-  Notes
(0072030)
hgbot (developer)
2014-11-26 13:30

Repository: erp/devel/pi
Changeset: 3702a2c3cb7e97364aab76b4b0aed22ae76f35b7
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Mon Dec 08 10:38:25 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/3702a2c3cb7e97364aab76b4b0aed22ae76f35b7 [^]

Fixes issue 28261: Weekdays process scheduling doesn't work.

Whenever a process is tried to be scheduled to Weekdays an error is thrown.
It was happening because optionDaily value is "D" and OBScheduler.java
expected "W".

It has been solved by changing value expected to "D".

---
M src/org/openbravo/scheduling/OBScheduler.java
---
(0072121)
alostale (developer)
2014-11-28 12:33

code reviewed

tested:
*Verified the actual ref list value is D, not W
*Scheduled process for weed days
(0073145)
hudsonbot (developer)
2014-12-30 23:26

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-11-24 15:22 alostale New Issue
2014-11-24 15:22 alostale Assigned To => inigosanchez
2014-11-24 15:22 alostale Modules => Core
2014-11-24 15:22 alostale Triggers an Emergency Pack => No
2014-11-24 15:22 alostale Relationship added related to 0028003
2014-11-24 15:24 alostale Summary Weekdays interval doesn't work => Weekdays process scheduling doesn't work
2014-11-26 13:29 inigosanchez Review Assigned To => alostale
2014-11-26 13:29 inigosanchez Resolution open => fixed
2014-11-26 13:30 hgbot Checkin
2014-11-26 13:30 hgbot Note Added: 0072030
2014-11-26 13:30 hgbot Status new => resolved
2014-11-26 13:30 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3702a2c3cb7e97364aab76b4b0aed22ae76f35b7 [^]
2014-11-28 12:33 alostale Note Added: 0072121
2014-11-28 12:33 alostale Status resolved => closed
2014-11-28 12:33 alostale Fixed in Version => 3.0PR15Q1
2014-12-30 23:26 hudsonbot Checkin
2014-12-30 23:26 hudsonbot Note Added: 0073145


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker