Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028003
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2014-10-28 13:082018-10-30 10:17
ReporteregoitzView Statuspublic 
Assigned Toinigosanchez 
PrioritynormalResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchFixed in SCM revision22b389ae2545
ProjectionnoneETAnoneTarget Version3.0PR15Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0028003: The daily background process is executed incorrectly when changing from summer time to winter time

DescriptionThe daily background process is executed incorrectly when changing from summer time to winter time.
ON that case the it is executed one hour before the scheduled time.

Steps To Reproduce-Define a background process to be executed every day at 12:00
-one night change the hour from 3:00 to 2:00
-Next day the process is executed at 11:00

The process has been executed after 24 hours, but that is not the correct time.
Proposed SolutionCheck on the OBSchedule.java that line:

trigger = TriggerUtils.makeHourlyTrigger(interval * 24);


Also could be a bug on the quartz library.

TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
has duplicate defect 0035516 closedegoitz The background process are executed on an incorrect hour after the change of the time on the server (summer time) 
related to defect 0028261 closedinigosanchez Weekdays process scheduling doesn't work 
related to defect 0039564 acknowledgedplatform weird scheduled Process Request defaults 

-  Notes
(0071523)
inigosanchez (developer)
2014-11-10 11:37

The behavior described in "Steps To Reproduce" is correct because in that case 24 hours have elapsed.

It has been fixed the problem when a process is scheduled every day without choosing the option "Every n days". This case had a bad behavior.
(0071525)
hgbot (developer)
2014-11-10 12:05

Repository: erp/devel/pi
Changeset: 22b389ae25454ae90b481b661d2d1279b9caf339
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Mon Nov 10 12:01:36 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/22b389ae25454ae90b481b661d2d1279b9caf339 [^]

Fixes issue 28003: Daily background process is executed incorrectly sometimes.

The daily background process is executed incorrectly when it is not selected option "Every n days".

Now, it has been fixed the problem when a process is scheduled every day without choosing the option "Every n days" by using a cron expression like this:
final String cronExpression = second + " " + minute + " " + hour + " ? * *";

Now, a daily background process has been executed every day at same hour.

---
M src/org/openbravo/scheduling/OBScheduler.java
---
(0071938)
alostale (developer)
2014-11-24 15:17

code reviewed

tested:
-Daily interval works as expected
-Every n days interval creates a every (24hrs x n) interval, meaning execution is triggered after this period regardless DST changes
(0073034)
hudsonbot (developer)
2014-12-30 23:24

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0107650)
alostale (developer)
2018-10-30 10:17

Note in more recent Quartz versions it is possible to schedule actual evey n days (rather than every 24*n hours) using quartz cron expressions.

- Issue History
Date Modified Username Field Change
2014-10-28 13:08 egoitz New Issue
2014-10-28 13:08 egoitz Assigned To => AugustoMauch
2014-10-28 13:08 egoitz Modules => Core
2014-10-28 13:08 egoitz Triggers an Emergency Pack => No
2014-11-03 09:08 egoitz Target Version => 3.0PR15Q1
2014-11-04 16:16 alostale Assigned To AugustoMauch => inigosanchez
2014-11-10 11:37 inigosanchez Note Added: 0071523
2014-11-10 12:05 hgbot Checkin
2014-11-10 12:05 hgbot Note Added: 0071525
2014-11-10 12:05 hgbot Status new => resolved
2014-11-10 12:05 hgbot Resolution open => fixed
2014-11-10 12:05 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/22b389ae25454ae90b481b661d2d1279b9caf339 [^]
2014-11-10 12:10 inigosanchez Status resolved => new
2014-11-10 12:10 inigosanchez Resolution fixed => open
2014-11-10 12:10 inigosanchez Issue Monitored: alostale
2014-11-10 12:11 inigosanchez Review Assigned To => alostale
2014-11-10 12:11 inigosanchez Status new => scheduled
2014-11-10 13:49 inigosanchez Status scheduled => resolved
2014-11-10 13:49 inigosanchez Resolution open => fixed
2014-11-24 15:17 alostale Note Added: 0071938
2014-11-24 15:17 alostale Status resolved => closed
2014-11-24 15:17 alostale Fixed in Version => 3.0PR15Q1
2014-11-24 15:22 alostale Relationship added related to 0028261
2014-12-30 23:24 hudsonbot Checkin
2014-12-30 23:24 hudsonbot Note Added: 0073034
2017-03-15 14:17 alostale Relationship added related to 0035516
2017-03-15 16:24 egoitz Relationship replaced has duplicate 0035516
2018-10-30 10:17 alostale Note Added: 0107650
2018-10-30 10:27 alostale Relationship added related to 0039564


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker