Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028220
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2014-11-18 18:352014-12-30 23:25
ReporterAugustoMauchView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchFixed in SCM revision78de53e9fc72
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0028220: If lazy filtering is configure in a subtab, filtering by one of its foreign keys does not apply selected parent filter

DescriptionIf a subtab is configured to use lazy filtering, when the dropdown of one of its foreign key filters is opened the datasource request is done without filtering by the record selected in the parent tab.

This results in a datasource request that performs very badly.
Steps To Reproduce- Login as System Administrator-
- Open the Grid Configuration at System Level window
- Create a new record, check Lazy Filtering on Grid
- Open the Window, Tabs and Fields window
- Press enter in the header filter editor to load the records
- Select any record
- In the Tab subtab, open the dropdown filter of the Table column. Check that is loaded not only with the tables used in this window, but with all the tables defined in ad_table.
TagsPerformance
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by feature request 0028284 closedAugustoMauch Grid Configuration for High Volume Windows 
related to defect 0028229 closedAugustoMauch Error in Pick and Execute windows when using Lazy Filtering 

-  Notes
(0071793)
hgbot (developer)
2014-11-18 18:46

Repository: erp/devel/pi
Changeset: 78de53e9fc7253115774a818f3cce620f2589d41
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue Nov 18 18:43:55 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/78de53e9fc7253115774a818f3cce620f2589d41 [^]

Fixes bug 28220:FK no longer filtered without applying selected parent criteria

The problem was the following. If a tab was configured to use lazy filtering, when one of its foreign keys is filtered the criteria is obtained from the current values of the filter editor, instead of directly calling the getCriteria function of the grid.

The problem is that the criteria was not being passed to the OBViewGrid.convertCriteria function, which among other things adds the criteria to filter by the record selected in the parent tab. The result was that the dropdown contained way more records than it should, and that the query to retrieve the records could have very bad performance if the table associated with the tab contained many records.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-fk-filter.js
---
(0071800)
alostale (developer)
2014-11-19 09:07

Code reviewed.

Tested:
-Having lazy filtering:
 * FK drop downs in subtabs filter correctly by its parent
 * they apply correctly additional criterias
 * filtering in parent tabs works correctly
-Without lazy filtering FK drops downs are not affected
(0073079)
hudsonbot (developer)
2014-12-30 23:25

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-11-18 18:35 AugustoMauch New Issue
2014-11-18 18:35 AugustoMauch Assigned To => AugustoMauch
2014-11-18 18:35 AugustoMauch Modules => Core
2014-11-18 18:35 AugustoMauch Triggers an Emergency Pack => No
2014-11-18 18:35 AugustoMauch Tag Attached: Performance
2014-11-18 18:44 AugustoMauch Issue Monitored: alostale
2014-11-18 18:44 AugustoMauch Review Assigned To => alostale
2014-11-18 18:46 hgbot Checkin
2014-11-18 18:46 hgbot Note Added: 0071793
2014-11-18 18:46 hgbot Status new => resolved
2014-11-18 18:46 hgbot Resolution open => fixed
2014-11-18 18:46 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/78de53e9fc7253115774a818f3cce620f2589d41 [^]
2014-11-19 09:07 alostale Note Added: 0071800
2014-11-19 09:07 alostale Status resolved => closed
2014-11-19 09:07 alostale Fixed in Version => 3.0PR15Q1
2014-11-19 18:02 AugustoMauch Relationship added related to 0028229
2014-11-26 08:04 alostale Relationship added caused by 0028284
2014-12-30 23:25 hudsonbot Checkin
2014-12-30 23:25 hudsonbot Note Added: 0073079


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker