Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028229
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2014-11-19 18:022014-12-30 23:25
ReporterAugustoMauchView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchFixed in SCM revisionbae727490668
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0028229: Error in Pick and Execute windows when using Lazy Filtering

DescriptionIf the user configures Lazy Filtering in a P&E window and clicks on the 'Apply Changes' button the data is not loaded and an error is shown in the chrome debugger console.
Steps To ReproduceAs System Admin:
- Open the Grid Configuration at System Level
- Create a new record, set Lazy Filtering on Grid = true.
- Open the Window, Tabs and Fields window
- Select the RFC Order Pick / Edit Lines window
- Remove the filter clause from its header tab. This will make it easier to have data in the P&E without the need of cleaning the filters

As F&B Admin:
- Open the Return to Vendor window
- Create a record.
- Click the Pick/Edit Lines button
- Without clearing the filters or modifying the filter editor, click on the button to apply the current filters. No data will be shown, and an error will be displayed in the debugger console.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0028220 closedAugustoMauch If lazy filtering is configure in a subtab, filtering by one of its foreign keys does not apply selected parent filter 
caused by feature request 0028284 closedAugustoMauch Grid Configuration for High Volume Windows 

-  Notes
(0071806)
hgbot (developer)
2014-11-19 18:10

Repository: erp/devel/pi
Changeset: bae7274906682cc39d3bf4a74b0363a913f938e0
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Nov 19 18:09:26 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/bae7274906682cc39d3bf4a74b0363a913f938e0 [^]

Fixes issue 28229: Lazy Filtering works properly in P&E windows

There was a problem when the button to apply the current filters (only shown when lazy filtering is configured for a tab) was pressed in a P&E window. If the filters were not changed before pressing the button, the grid.refreshGrid function was invoked, and this function was not defined for P&E windows. This function has been defined now. Also, a flag has been added to detect when the filterClause is removed, to allow refreshing the grid in that case even if the filter editor is not changed.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-grid.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-pick-and-execute-grid.js
---
(0071866)
alostale (developer)
2014-11-21 08:33

Code reviewed

Tested in P&E grid with and without default filters
Tested in regular grids
(0073085)
hudsonbot (developer)
2014-12-30 23:25

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-11-19 18:02 AugustoMauch New Issue
2014-11-19 18:02 AugustoMauch Assigned To => AugustoMauch
2014-11-19 18:02 AugustoMauch Modules => Core
2014-11-19 18:02 AugustoMauch Triggers an Emergency Pack => No
2014-11-19 18:02 AugustoMauch Relationship added related to 0028220
2014-11-19 18:02 AugustoMauch Issue Monitored: alostale
2014-11-19 18:02 AugustoMauch Review Assigned To => alostale
2014-11-19 18:10 hgbot Checkin
2014-11-19 18:10 hgbot Note Added: 0071806
2014-11-19 18:10 hgbot Status new => resolved
2014-11-19 18:10 hgbot Resolution open => fixed
2014-11-19 18:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/bae7274906682cc39d3bf4a74b0363a913f938e0 [^]
2014-11-21 08:33 alostale Note Added: 0071866
2014-11-21 08:33 alostale Status resolved => closed
2014-11-21 08:33 alostale Fixed in Version => 3.0PR15Q1
2014-11-26 08:04 alostale Relationship added caused by 0028284
2014-12-30 23:25 hudsonbot Checkin
2014-12-30 23:25 hudsonbot Note Added: 0073085


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker