Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0028099
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2014-11-05 18:162014-12-30 23:24
ReporterngarciaView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchpiFixed in SCM revision7fe38ad774a2
ProjectionnoneETAnoneTarget Version3.0PR15Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2013-12-16
Regression introduced in release3.0PR14Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/a03e8e035119 [^]
Triggers an Emergency PackNo
Summary

0028099: Dot separated date format is not working

DescriptionDot separated date format is not working
Steps To ReproduceChange in the Openbravo.properties file the '-' by '.' for:

dateFormat.js
dateFormat.java
dateTimeFormat.java

ant compile.complete.deploy

As group admin role:
   Open Sales Invoice window
   Select an Invoice Date through the Calendar
   Check the field remains empty
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by feature request 0025574 closeddbaz Upgrade SmartClient 10.0d 

-  Notes
(0071468)
hgbot (developer)
2014-11-06 17:55

Repository: erp/devel/pi
Changeset: 7fe38ad774a2d0db833ef7e9f4de01ca4ec315ac
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Nov 06 17:53:38 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/7fe38ad774a2d0db833ef7e9f4de01ca4ec315ac [^]

Fixes issue 28099: '.' works as date separator

If a dot was used as date separator, the dates were shown empty in the UI. This was caused by this implementation of the isSeparator function:

  isSeparator: function (str, position) {
    return str.charAt(position) === '-' || str.charAt(position) === '\\' || str.charAt(position) === '/';
  },

The list of possible separators was hardcoded, and it did not take into the account the dot. This has been fixed by also checking the value returned by the OB.Utilities.Date.getDateSeparator function, that given a date format it returns its separator.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-date.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-utilities-date.js
---
(0071470)
AugustoMauch (developer)
2014-11-06 18:21

Test case created in test link: Communit-7897:28099: Dot separated date format is not working
(0071509)
alostale (developer)
2014-11-10 08:53

Tested with for the following cases.


Separators: - and . for date, date-time, absolute date and absolute date-time. In form and in date filter selector:

typing 1 --> converts to 1st of current month (1-11-2014)
typing 1-12 (when having . as separator, both 1.12 and 1-12 work)--> converts to 1-12 of current year (1-12-2014)
typing 1-12-2014 (when having . as separator, both 1.12.2014 and 1-12-2014 work)--> keeps selected date (1-12-2014)
select date from calendar widget

In date filter selector:
Using popup to select from-to dates
(0073024)
hudsonbot (developer)
2014-12-30 23:24

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-11-05 18:16 ngarcia New Issue
2014-11-05 18:16 ngarcia Assigned To => AugustoMauch
2014-11-05 18:16 ngarcia Modules => Core
2014-11-05 18:16 ngarcia Triggers an Emergency Pack => No
2014-11-05 18:17 ngarcia Issue Monitored: networkb
2014-11-06 10:38 ngarcia Regression level => Production - Confirmed Stable
2014-11-06 10:38 ngarcia Priority high => immediate
2014-11-06 17:26 AugustoMauch Regression date => 2013-12-16
2014-11-06 17:26 AugustoMauch Regression introduced in release => 3.0PR14Q2
2014-11-06 17:26 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/a03e8e035119 [^]
2014-11-06 17:54 AugustoMauch Issue Monitored: alostale
2014-11-06 17:54 AugustoMauch Review Assigned To => alostale
2014-11-06 17:55 hgbot Checkin
2014-11-06 17:55 hgbot Note Added: 0071468
2014-11-06 17:55 hgbot Status new => resolved
2014-11-06 17:55 hgbot Resolution open => fixed
2014-11-06 17:55 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/7fe38ad774a2d0db833ef7e9f4de01ca4ec315ac [^]
2014-11-06 17:56 AugustoMauch Status resolved => new
2014-11-06 17:56 AugustoMauch Resolution fixed => open
2014-11-06 17:57 AugustoMauch Status new => scheduled
2014-11-06 17:57 AugustoMauch fix_in_branch => pi
2014-11-06 17:57 AugustoMauch Status scheduled => resolved
2014-11-06 17:57 AugustoMauch Resolution open => fixed
2014-11-06 18:21 AugustoMauch Note Added: 0071470
2014-11-07 08:38 alostale Status resolved => new
2014-11-07 08:38 alostale Resolution fixed => open
2014-11-07 08:38 alostale Relationship added caused by 0025574
2014-11-07 08:39 alostale Status new => scheduled
2014-11-07 08:39 alostale Status scheduled => resolved
2014-11-07 08:39 alostale Resolution open => fixed
2014-11-10 08:54 alostale Note Added: 0071509
2014-11-10 08:54 alostale Status resolved => closed
2014-11-10 08:54 alostale Fixed in Version => 3.0PR15Q1
2014-12-30 23:24 hudsonbot Checkin
2014-12-30 23:24 hudsonbot Note Added: 0073024


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker