Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027912
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2014-10-20 12:542014-12-30 23:23
ReporterSandrahuguetView Statuspublic 
Assigned ToAugustoMauch 
PriorityurgentResolutionfixedFixed in Version3.0PR15Q1
StatusclosedFix in branchFixed in SCM revision6c68dafcdfac
ProjectionnoneETAnoneTarget Version3.0PR14Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0027912: DateTime fields not properly formated to local time zone in grids of parameter windows

Descriptionwhen defining a grid using parameter windows, if one of the fields contained is defined as datetime, the value displayed is not properly converted and it shows the UTC date, instead of the data in the client timezone.
Steps To ReproduceUsing the QA Testing role:

Go to Financial Account Window.

Select Spain Bank financial account

Create a Transaction Manually in Transaction Tab:

    Transaction Type: BP Withdrawal
    GL Item: Salaries
    Withdrawal Amount: 100.00
    Business Partner: Vendor A
    Transaction Date: Today

Process the Transaction

 Create a Bank Statement Header:

    Name: TestReconciliationWith002
    Transaction Date: 02/10/2014

Create a Bank Statement Line:

    Transaction Date: 02/10/2014
    Reference No.: 123456
    Business Partner: Vendor A
    GL Item: Salaries
    Amount Out: 100.00

Process the Bank Statement


     

Click on Match Statement Button.

Once the parameter window appears right click on row headers to show bslUpdated column.

Realize that value displayed does not match with bankstatement line updated field in bankstatement line tab.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0038489pi closedcaristu Wrong displayed value of a table reference inside a pick and execute when using hql query 
blocks defect 00279133.0PR14Q4 closededuardo_Argal System throws error message when user try to match bank statement lines with OB transactions manually 

-  Notes
(0071047)
AugustoMauch (developer)
2014-10-20 15:31
edited on: 2014-10-20 16:37

Only happens when using datasources that extend ReadOnlyDataSourceService

(0071050)
hgbot (developer)
2014-10-20 16:45

Repository: erp/devel/pi
Changeset: 9035351134407dbcbe0b02826eeebc910edf74b5
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Mon Oct 20 16:44:30 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/9035351134407dbcbe0b02826eeebc910edf74b5 [^]

Fixes issue 27912: Time&DateTime fields are properly handled in P&E Windows

The values of Time and DateTime fields were not being properly handled, as they where not converted from the server timezone offset to UTC before being sent to the client. This happened
because the DataToJsonConverter.convertToJsonObjects method did not perform the conversion.

Now it does, when possible. For the conversion to be done properly, the Property associated with the column value must be passed to the convertPrimitiveValue method. This will be done a
s long as the tableId parameter is sent in the datasource request, and as long as the property name can be inferred from the column name.

The QueryListDataSource extends ReadOnlyDataSourceService, but the tableId is not passed, so this changeset does not fix this case, that will be address in a separate issue.

---
M modules/org.openbravo.service.datasource/src/org/openbravo/service/datasource/ReadOnlyDataSourceService.java
M modules/org.openbravo.service.json/src/org/openbravo/service/json/DataToJsonConverter.java
---
(0071161)
alostale (developer)
2014-10-24 10:52

code reviewed

Tested with date time + absolute date time, both working fine.
(0072951)
hudsonbot (developer)
2014-12-30 23:23

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test
(0072954)
hudsonbot (developer)
2014-12-30 23:23

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-10-20 12:54 Sandrahuguet New Issue
2014-10-20 12:54 Sandrahuguet Assigned To => AugustoMauch
2014-10-20 12:54 Sandrahuguet Modules => Core
2014-10-20 12:54 Sandrahuguet Triggers an Emergency Pack => No
2014-10-20 12:59 sureshbabu Relationship added blocks 0027913
2014-10-20 13:20 AugustoMauch Summary DateTime fields not properly formated to local time zone => DateTime fields not properly formated to local time zone in grid parameters
2014-10-20 13:20 AugustoMauch Description Updated View Revisions
2014-10-20 13:53 sureshbabu Relationship deleted blocks 0027913
2014-10-20 15:13 sureshbabu Relationship added blocks 0027913
2014-10-20 15:15 AugustoMauch Steps to Reproduce Updated View Revisions
2014-10-20 15:31 AugustoMauch Note Added: 0071047
2014-10-20 15:43 AugustoMauch Note Edited: 0071047 View Revisions
2014-10-20 16:36 AugustoMauch Summary DateTime fields not properly formated to local time zone in grid parameters => DateTime fields not properly formated to local time zone in grids of parameter windows
2014-10-20 16:36 AugustoMauch Note Edited: 0071047 View Revisions
2014-10-20 16:37 AugustoMauch Note Edited: 0071047 View Revisions
2014-10-20 16:37 AugustoMauch Issue Monitored: alostale
2014-10-20 16:37 AugustoMauch Review Assigned To => alostale
2014-10-20 16:45 hgbot Checkin
2014-10-20 16:45 hgbot Note Added: 0071050
2014-10-20 16:45 hgbot Status new => resolved
2014-10-20 16:45 hgbot Resolution open => fixed
2014-10-20 16:45 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/9035351134407dbcbe0b02826eeebc910edf74b5 [^]
2014-10-20 18:24 hgbot Checkin
2014-10-20 18:24 hgbot Note Added: 0071061
2014-10-20 18:24 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/9035351134407dbcbe0b02826eeebc910edf74b5 [^] => http://code.openbravo.com/erp/devel/pi/rev/6c68dafcdfac6ce159a78ee7347ecba3fdd3a340 [^]
2014-10-21 17:38 gorka_gil Note Deleted: 0071061
2014-10-24 10:52 alostale Note Added: 0071161
2014-10-24 10:52 alostale Status resolved => closed
2014-10-24 10:52 alostale Fixed in Version => 3.0PR15Q1
2014-12-30 23:23 hudsonbot Checkin
2014-12-30 23:23 hudsonbot Note Added: 0072951
2014-12-30 23:23 hudsonbot Checkin
2014-12-30 23:23 hudsonbot Note Added: 0072954
2018-05-29 10:29 caristu Relationship added related to 0038489


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker