Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027636
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2014-09-18 12:442014-09-26 11:44
ReportercaristuView Statuspublic 
Assigned ToAugustoMauch 
PriorityurgentResolutionfixedFixed in Version3.0PR14Q4
StatusclosedFix in branchFixed in SCM revision509bb26b8f7e
ProjectionnoneETAnoneTarget Version3.0PR14Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0027636: Absolute Date Time fields are not handling properly DST changes of the timezone

DescriptionAbsolute Date Time and Absolute Time fields are not handling properly the clock changes in the timezone
Steps To Reproduce1) Create a new column of type Absolute Date Time and create its corresponding field.
2) Having the client in GMT+2, try to set the following date time: 26-10-2014 01:00:00. Notice that the data changes when saving the record to 26-10-2014 02:00:00. This is happening because the DST change in 2014 for GMT+2 is on 26-10-2014.
3) The same behavior occurs for Absolute Time fields.
Proposed SolutionIt should be taken into account if the timezone changes when converting the dates: http://wiki.openbravo.com/wiki/Projects/Absolute_DateTime_Reference/Technical_Documentation#Logic_related_explanation [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00275103.0PR14Q4 closedAugustoMauch Absolute Time is not displaying the absolute time when the timezone changes 

-  Notes
(0070323)
AugustoMauch (developer)
2014-09-24 19:47

Not a risky fix, because the correction is only applied when the timezone offset of the date changes, and that will only happen for a very reduced number of hours in a year.
(0070324)
hgbot (developer)
2014-09-24 19:49

Repository: erp/devel/pi
Changeset: 509bb26b8f7edc38293b7c97bef0371fb9bd2b8e
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Sep 24 19:43:54 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/509bb26b8f7edc38293b7c97bef0371fb9bd2b8e [^]

Fixes issue 27636: Absolute Date Time field works properly with offset change

The problem was that if the date selected in an absolute datetime field was very close to a timezone offset change, the date was automatically changed. The original entered date was modified in the OB.Utilities.Date.addTimezoneOffset function. Now, if inside this function the date timezone offset is modified, the proper correction is applied.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-utilities-date.js
---
(0070362)
hudsonbot (developer)
2014-09-25 11:30

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/63604e8e17b7 [^]
Maturity status: Test
(0070432)
shankarb (developer)
2014-09-26 11:44

Code reviewed and verified in pi changeset 653cc6909012.

- Issue History
Date Modified Username Field Change
2014-09-18 12:44 caristu New Issue
2014-09-18 12:44 caristu Assigned To => AugustoMauch
2014-09-18 12:44 caristu Modules => Core
2014-09-18 12:44 caristu Triggers an Emergency Pack => No
2014-09-18 12:44 caristu Issue Monitored: networkb
2014-09-18 12:56 caristu Relationship added related to 0027510
2014-09-18 13:04 caristu version => pi
2014-09-18 13:04 caristu Target Version => 3.0PR14Q4
2014-09-22 14:32 inigosanchez Assigned To AugustoMauch => inigosanchez
2014-09-23 09:54 inigosanchez Assigned To inigosanchez => shankarb
2014-09-24 19:14 AugustoMauch Assigned To shankarb => AugustoMauch
2014-09-24 19:46 AugustoMauch Issue Monitored: shankarb
2014-09-24 19:46 AugustoMauch Review Assigned To => shankarb
2014-09-24 19:47 AugustoMauch Note Added: 0070323
2014-09-24 19:49 hgbot Checkin
2014-09-24 19:49 hgbot Note Added: 0070324
2014-09-24 19:49 hgbot Status new => resolved
2014-09-24 19:49 hgbot Resolution open => fixed
2014-09-24 19:49 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/509bb26b8f7edc38293b7c97bef0371fb9bd2b8e [^]
2014-09-25 11:30 hudsonbot Checkin
2014-09-25 11:30 hudsonbot Note Added: 0070362
2014-09-26 11:44 shankarb Note Added: 0070432
2014-09-26 11:44 shankarb Status resolved => closed
2014-09-26 11:44 shankarb Fixed in Version => 3.0PR14Q4


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker