Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027568
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Discounts and Promotionsmajoralways2014-09-09 19:232014-10-31 03:46
ReporterjecharriView Statuspublic 
Assigned Tomigueldejuana 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchpiFixed in SCM revision97eec3d5f5ca
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toszapata
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0027568: Add pack button in the ERP is not taking into account cash VAT new functionality

DescriptionAdd pack button in the ERP is not taking into account cash VAT new functionality
Steps To Reproduce-Configure and organization to use cash VAT
http://wiki.openbravo.com/wiki/Cash_VAT_Management/User_Documentation [^]

-After that configure a product with tax category and tax rate (only one tax rate in that category)
-Check the tax rate as cash vat tax
-Define a pack that adds 5 units of above product

-Create and order
-Press in "Add pack"
-verify that you will receive nullpointer exception because it is not able to get the tax because is doing the request to get the query without p_forcedcashvat parameter of function c_gettax.
Proposed Solution-Manage the nullpointer exception
-include the parameter in the function depending if it is necessary or not
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0070857)
hgbot (developer)
2014-10-10 09:18

Repository: erp/pmods/org.openbravo.retail.discounts
Changeset: 97eec3d5f5cae631946f7fdf6ec7e84a5bbb78f0
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Fri Oct 10 09:17:58 2014 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.discounts/rev/97eec3d5f5cae631946f7fdf6ec7e84a5bbb78f0 [^]

Fixed issue 0027568: Add pack button in the ERP is not taking into account cash VAT new functionality

It happens when exists a configuration error. In the fix we only handle NPE.

---
M src-db/database/sourcedata/AD_MESSAGE.xml
M src/org/openbravo/retail/discounts/AddPack.java
---
(0070858)
migueldejuana (developer)
2014-10-10 09:21

Review cash VAT configuration to avoid this problem. Be sure that the Organization have cash VAT checked. Also in the Tax rate used, review if cash VAT is checked and in Accounting, fill Tax Due Transitory and Tax Credit Transitory.

- Issue History
Date Modified Username Field Change
2014-09-09 19:23 jecharri New Issue
2014-09-09 19:23 jecharri Assigned To => marvintm
2014-09-09 19:23 jecharri Triggers an Emergency Pack => No
2014-09-09 19:23 jecharri Proposed Solution updated
2014-10-10 09:18 hgbot Checkin
2014-10-10 09:18 hgbot Note Added: 0070857
2014-10-10 09:18 hgbot Status new => resolved
2014-10-10 09:18 hgbot Resolution open => fixed
2014-10-10 09:18 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.discounts/rev/97eec3d5f5cae631946f7fdf6ec7e84a5bbb78f0 [^]
2014-10-10 09:21 migueldejuana Note Added: 0070858
2014-10-20 16:35 migueldejuana Assigned To marvintm => migueldejuana
2014-10-20 16:35 migueldejuana Status resolved => new
2014-10-20 16:35 migueldejuana Resolution fixed => open
2014-10-20 16:36 migueldejuana Status new => scheduled
2014-10-20 16:36 migueldejuana fix_in_branch => pi
2014-10-20 16:36 migueldejuana Status scheduled => resolved
2014-10-20 16:36 migueldejuana Resolution open => fixed
2014-10-31 03:46 szapata Review Assigned To => szapata
2014-10-31 03:46 szapata Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker