Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0027234
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajorhave not tried2014-07-30 10:572014-08-08 18:54
ReporterjonalegriaesarteView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q4
StatusclosedFix in branchFixed in SCM revision286896a13002
ProjectionnoneETAnoneTarget Version3.0PR14Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0PR14Q2.4SCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2014-03-13
Regression introduced in release3.0PR14Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/2ac8f916576971d180a9cfe45ca4829591a90bae [^]
Triggers an Emergency PackNo
Summary

0027234: Invoice terms field does not appear in sales order window

DescriptionInvoice terms field does not appear in sales order window. It only appears if the user creates the header, save it, and refresh the header
Steps To Reproduce- Sales order window, create a new one. Invoice terms is not shown
- Select a business partner and save it. Invoice terms is not shown
- Refresh the header. Invoice terms is shown
Same happens with Scheduled delivered date
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00172393.0RC7 closedmarvintm Invoice terms field dissapear without no reason in sales order window 
caused by defect 00259513.0PR14Q2 closedAugustoMauch The displaylogic is not working if an auxiliary input is used. 

-  Notes
(0069028)
alostale (developer)
2014-08-01 12:33

The problem is caused because Invoice Terms field has a display logic based on ORDERTYPE auxiliary input.

This auxiliary input has a SQL logic that cannot be executed on new because it is based on c_order_id which doesn't exist yet in new. But is recal

Previous to fix for issue 0025951 the flow in NEW mode was:

1.1. compute auxiliary inputs
1.2. compute columns values (defaults can be based on auxiliary inputs)
1.3. recompute auxiliary inputs (covering the case of auxiliary inputs based on defaults of columns)
1.4. calculate callouts

After 0025951 the flow is:

2.1. compute auxiliary inputs
2.2. compute column values
2.3. calculate callouts
2.4. recompute auxiliary inputs (covering the case of auxiliary input based on value computed by a callout)

The problem in this case is previous to 0025951, ORDERTYPE was correctly calculated in step 1.4. After it, it's calculated in step 2.3 but overwritten in 2.4
(0069029)
alostale (developer)
2014-08-01 12:35

The proposed fix prevents overwriting in step 2.4 in case it was calculated in 2.3.

It has been tested for:
* This case
* Issue 0025951
* Issue 0017239
(0069030)
hgbot (developer)
2014-08-01 12:38

Repository: erp/devel/pi
Changeset: 286896a130028f4ee03f995d138da7400a21bae2
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Aug 01 12:37:37 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/286896a130028f4ee03f995d138da7400a21bae2 [^]

fixed bug 27234: fixed auxiliary inputs set by callouts in mode NEW

 don't overwrite auxiliary inputs calculated by callouts when in NEW mode

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/FormInitializationComponent.java
---
(0069031)
shankarb (developer)
2014-08-01 13:29

Code reviewed and verified in pi changeset 286896a13002.
(0069089)
hgbot (developer)
2014-08-05 14:23

Repository: erp/devel/pi
Changeset: 64fb37a18f496c4dd34f0a8af16470a7f6db6878
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Aug 04 08:58:43 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/64fb37a18f496c4dd34f0a8af16470a7f6db6878 [^]

related to bug 27234: added test case

---
A src-test/org/openbravo/test/datasource/FICTest.java
---
(0069252)
hudsonbot (developer)
2014-08-08 18:54

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/4450016dee64 [^]
Maturity status: Test
(0069266)
hudsonbot (developer)
2014-08-08 18:54

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/4450016dee64 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-07-30 10:57 jonalegriaesarte New Issue
2014-07-30 10:57 jonalegriaesarte Assigned To => AtulOpenbravo
2014-07-30 10:57 jonalegriaesarte Modules => Core
2014-07-30 10:57 jonalegriaesarte Resolution time => 1406844000
2014-07-30 10:57 jonalegriaesarte Regression level => Production - Confirmed Stable
2014-07-30 10:57 jonalegriaesarte Triggers an Emergency Pack => No
2014-07-30 11:16 heccam Issue Monitored: heccam
2014-07-30 12:45 AtulOpenbravo Status new => scheduled
2014-07-30 12:45 AtulOpenbravo fix_in_branch => pi
2014-08-01 10:43 AtulOpenbravo Assigned To AtulOpenbravo => alostale
2014-08-01 11:21 alostale Regression date => 2014-03-13
2014-08-01 11:21 alostale Regression introduced in release => 3.0PR14Q2
2014-08-01 11:21 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/2ac8f916576971d180a9cfe45ca4829591a90bae [^]
2014-08-01 11:21 alostale fix_in_branch pi =>
2014-08-01 11:21 alostale Relationship added caused by 0025951
2014-08-01 12:13 alostale Review Assigned To => AugustoMauch
2014-08-01 12:17 alostale Relationship added related to 0017239
2014-08-01 12:33 alostale Note Added: 0069028
2014-08-01 12:35 alostale Note Added: 0069029
2014-08-01 12:38 hgbot Checkin
2014-08-01 12:38 hgbot Note Added: 0069030
2014-08-01 12:38 hgbot Status scheduled => resolved
2014-08-01 12:38 hgbot Resolution open => fixed
2014-08-01 12:38 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/286896a130028f4ee03f995d138da7400a21bae2 [^]
2014-08-01 12:46 alostale Regression level Production - Confirmed Stable => Production - QA Approved
2014-08-01 13:11 alostale Review Assigned To AugustoMauch => shankarb
2014-08-01 13:29 shankarb Note Added: 0069031
2014-08-01 13:29 shankarb Status resolved => closed
2014-08-01 13:29 shankarb Fixed in Version => 3.0PR14Q4
2014-08-05 14:23 hgbot Checkin
2014-08-05 14:23 hgbot Note Added: 0069089
2014-08-08 18:54 hudsonbot Checkin
2014-08-08 18:54 hudsonbot Note Added: 0069252
2014-08-08 18:54 hudsonbot Checkin
2014-08-08 18:54 hudsonbot Note Added: 0069266


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker