Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025951
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2014-03-11 13:362014-07-07 11:38
ReporteregoitzView Statuspublic 
Assigned ToAugustoMauch 
PriorityhighResolutionfixedFixed in Version3.0PR14Q2
StatusclosedFix in branchFixed in SCM revision2ac8f9165769
ProjectionnoneETAnoneTarget Version3.0PR14Q2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0025951: The displaylogic is not working if an auxiliary input is used.

DescriptionThe displaylogic is not working if an auxiliary input is used.
Steps To Reproduce-Login to the application
-go to tax rate window
-Edit the "Entregas IVA 21%" tax rate by changing the value on the Base Amount field from "line net amount" to "Alternate Tax Base Amount"
-SAve
-Create a new sales invoice
-Add a line
-Select the product "Agua sin Gas 1L".
-The "Entregas IVA 21%" is assigned to the tax rate window
*A new field "alternate taxable amount" should be shown but it is not
-After save if you refresh the window the fields is shown.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0025581 closedAugustoMauch Display logic is not working fine for warehouse picking list lines tab 
related to defect 00172393.0RC7 closedmarvintm Invoice terms field dissapear without no reason in sales order window 
related to defect 00260083.0PR14Q2 closedAugustoMauch Problem while picking a business partner using a selector 
causes defect 00272343.0PR14Q4 closedalostale Invoice terms field does not appear in sales order window 

-  Notes
(0065090)
AugustoMauch (developer)
2014-03-12 11:01

This issue is not a regression. When the user picks a Product, a call to the FIC is done in CHANGE mode. Auxiliary inputs are not computed in CHANGE mode [1] since May 2011 [2] to prevent accidentally resetting them.

[1] https://code.openbravo.com/erp/devel/pi/file/143dbdd74f2b/modules/org.openbravo.client.application/src/org/openbravo/client/application/window/FormInitializationComponent.java#l848 [^]
[2] https://code.openbravo.com/erp/devel/pi/rev/7b921a4dc6a21a693d86ca1ad37b739aadfbccb2 [^]
(0065135)
hgbot (developer)
2014-03-13 13:52

Repository: erp/devel/pi
Changeset: 2ac8f916576971d180a9cfe45ca4829591a90bae
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Mar 13 13:47:53 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/2ac8f916576971d180a9cfe45ca4829591a90bae [^]

Fixes bug 25951:Auxiliary inputs are executed when FIC is called in CHANGE mode

Before this change, the FIC did not execute the auxiliary inputs when it was called in CHANGE mode. This was done to prevent resetting auxiliary inputs that ha
d been modified in callouts.

This made impossible to use auxiliary inputs in display logic, because they would not be updated until the records was refreshed. To fix this while allowing to
 overwrite auxiliary inputs from callouts, this has been done:
- The list of auxiliary inputs modified in callouts is persisted. This list is reset when the FIC is called in a mode other than CHANGE (originally in this cas
e all the auxiliary inputs were being updated, regardless of whether they had been modified by a callout).
- If the FIC is called in CHANGE mode, then only the auxiliary inputs that have not been modified by callouts are recalculated.
- The auxiliary inputs are now executed after the callouts are run, in order to be able to use the updated data in the auxiliary input calculation.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/FormInitializationComponent.java
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/ob-view-form.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0065181)
hudsonbot (developer)
2014-03-15 03:04

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8396ec753aec [^]
Maturity status: Test
(0065263)
alostale (developer)
2014-03-18 14:51

Code reviewed

Tested:
-Steps to reproduce
-issue 0017239 is not reproducible
(0068549)
ravioberp (reporter)
2014-07-07 11:38

It seems this issue has not been fixed in PR14Q2. In sales invoice window
1. I added a new record in Sales Invoice Header.
2. Under the lines tab, i have created a line item withe a product a product "Zumo de Naranja Bio 0,33L". Now It should show a field AttributeSetValue under MoreInformation Section. But it was not getting displayed.

But it gets displayed after save and refresh the lines tab.

- Issue History
Date Modified Username Field Change
2014-03-11 13:36 egoitz New Issue
2014-03-11 13:36 egoitz Assigned To => dmiguelez
2014-03-11 13:36 egoitz Modules => Core
2014-03-11 13:36 egoitz Triggers an Emergency Pack => No
2014-03-11 13:36 egoitz Relationship added related to 0025581
2014-03-11 13:36 egoitz Regression level => Production - QA Approved
2014-03-11 13:36 egoitz Assigned To dmiguelez => AugustoMauch
2014-03-12 10:23 AugustoMauch Summary The displaylogic is not working when the an auxiliar input . => The displaylogic is not working if an auxiliary input is used.
2014-03-12 10:23 AugustoMauch Description Updated View Revisions
2014-03-12 11:01 AugustoMauch Regression level Production - QA Approved =>
2014-03-12 11:01 AugustoMauch Note Added: 0065090
2014-03-12 11:01 AugustoMauch Priority immediate => high
2014-03-12 11:05 AugustoMauch Relationship added related to 0017239
2014-03-12 13:58 jonalegriaesarte Target Version => PR14Q2
2014-03-12 14:13 AugustoMauch Status new => scheduled
2014-03-12 14:13 AugustoMauch fix_in_branch => pi
2014-03-13 13:49 AugustoMauch Issue Monitored: shankarb
2014-03-13 13:49 AugustoMauch Review Assigned To => shankarb
2014-03-13 13:49 AugustoMauch fix_in_branch pi =>
2014-03-13 13:50 AugustoMauch Issue End Monitor: shankarb
2014-03-13 13:50 AugustoMauch Issue Monitored: alostale
2014-03-13 13:50 AugustoMauch Review Assigned To shankarb => alostale
2014-03-13 13:52 hgbot Checkin
2014-03-13 13:52 hgbot Note Added: 0065135
2014-03-13 13:52 hgbot Status scheduled => resolved
2014-03-13 13:52 hgbot Resolution open => fixed
2014-03-13 13:52 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/2ac8f916576971d180a9cfe45ca4829591a90bae [^]
2014-03-14 17:21 AugustoMauch Relationship added related to 0026008
2014-03-15 03:04 hudsonbot Checkin
2014-03-15 03:04 hudsonbot Note Added: 0065181
2014-03-18 14:51 alostale Note Added: 0065263
2014-03-18 14:51 alostale Status resolved => closed
2014-03-18 14:51 alostale Fixed in Version => PR14Q2
2014-07-07 11:38 ravioberp Note Added: 0068549
2014-08-01 11:21 alostale Relationship added causes 0027234


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker