Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026992
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2014-07-01 20:202014-08-08 18:53
ReporterjecharriView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q4
StatusclosedFix in branchFixed in SCM revision119c05bb76af
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browserGoogle Chrome
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0026992: "SUM" Summarize field does not show the total in widgets with huge quantity of data

Description"SUM" Summarize field does not show the total in widgets with huge quantity of data
Steps To Reproduce-Login as system with "Query/List widget" module in development
-Go to "Widget" window
-Find widget "Invoices to pay"
-Change the query
remove line "and inv.paymentComplete = false" to have more invoices
-Change the column "Amount" and set a "SUM" summarize filte

Login to ERP with "F&B admin" role and insert the widget. If you press in show all results, you will see that summarize field does not work, only if you filter the data withou not huge quantity of data, summarize field workd
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
causes defect 00291743.0PR15Q2 closedAugustoMauch Summarize fields are not displayed in widgets 

-  Notes
(0068592)
hgbot (developer)
2014-07-11 14:40

Repository: erp/devel/pi
Changeset: 119c05bb76af1d1f6f681ac60a1c8eb3afe1a10c
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Jul 11 14:37:33 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/119c05bb76af1d1f6f681ac60a1c8eb3afe1a10c [^]

Fixes issue 26992: Summary fields are not properly calculated in Query widgets

The problem was that the calculation of the values of the summary fields was being done in the client side, so not all the data was cached in the client, they were not calculated.

To fix this, two changes have been done:
- OBQueryListGrid now obtains the values of the summary fields from the server
- the QueryListDataSource is now able to obtain the values of the summary fields

---
M modules/org.openbravo.client.querylist/src/org/openbravo/client/querylist/QueryListDataSource.java
M modules/org.openbravo.client.querylist/web/org.openbravo.client.querylist/js/ob-querylist-widget.js
---
(0068593)
AugustoMauch (developer)
2014-07-11 14:43

Test Plan:
- Test the three available summary functions: sum, avg and count.
- Test having one summary function, and several summary functions at the same time.

Note that in Query/List widgets the summary functions only have effect on numeric columns.
(0068603)
alostale (developer)
2014-07-14 10:19

Code review + testing:

-These aggregate columns can have performance problems in case the set of data they are computed with is big. A restriction similar to standard grid should be implemented in order to skip this computation if the number of records is big enough.
(0068632)
AugustoMauch (developer)
2014-07-15 10:31

The limit of maximum records is not applied to the summary functions, but to the groupings: http://wiki.openbravo.com/wiki/Project/Summary_Grouping_Filter_TestPlan#Test:_control_of_grouping_by_preferences. [^]
(0068762)
alostale (developer)
2014-07-21 13:39

Code reviewed + tested
(0069153)
hudsonbot (developer)
2014-08-08 18:53

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/4450016dee64 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-07-01 20:20 jecharri New Issue
2014-07-01 20:20 jecharri Assigned To => AugustoMauch
2014-07-01 20:20 jecharri Web browser => Google Chrome
2014-07-01 20:20 jecharri Modules => Core
2014-07-01 20:20 jecharri Triggers an Emergency Pack => No
2014-07-03 09:55 jonalegriaesarte Web browser Google Chrome => Google Chrome
2014-07-03 10:30 jonalegriaesarte Web browser Google Chrome => Google Chrome
2014-07-11 14:31 AugustoMauch Issue Monitored: alostale
2014-07-11 14:31 AugustoMauch Review Assigned To => alostale
2014-07-11 14:31 AugustoMauch Web browser Google Chrome => Google Chrome
2014-07-11 14:40 hgbot Checkin
2014-07-11 14:40 hgbot Note Added: 0068592
2014-07-11 14:40 hgbot Status new => resolved
2014-07-11 14:40 hgbot Resolution open => fixed
2014-07-11 14:40 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/119c05bb76af1d1f6f681ac60a1c8eb3afe1a10c [^]
2014-07-11 14:43 AugustoMauch Note Added: 0068593
2014-07-14 10:19 alostale Note Added: 0068603
2014-07-15 10:31 AugustoMauch Note Added: 0068632
2014-07-21 13:39 alostale Note Added: 0068762
2014-07-21 13:39 alostale Status resolved => closed
2014-07-21 13:39 alostale Fixed in Version => 3.0PR14Q4
2014-08-08 18:53 hudsonbot Checkin
2014-08-08 18:53 hudsonbot Note Added: 0069153
2015-03-09 17:09 AugustoMauch Relationship added causes 0029174


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker