Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026984
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfaceminoralways2014-07-01 10:512014-09-30 16:45
ReportercaristuView Statuspublic 
Assigned Todbaz 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q3
StatusclosedFix in branchFixed in SCM revisionf1c53461ec96
ProjectionnoneETAnoneTarget Version3.0PR14Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2014-02-26
Regression introduced in release3.0PR14Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/20eb3426d990 [^]
Triggers an Emergency PackNo
Summary

0026984: Unable to close the Show Log window

DescriptionUnable to close the "Show Log" window
Steps To Reproduce1) Go to Module Management window
2) Install a new Module
3) Click on the "rebuild now" link. The "Rebuild the System" window is opened.
4) Click on the "Show Log" window
5) Notice that is not possible to minime, maximize or close this window.The following error is being raised in the console: "Uncaught SyntaxError: Unexpected identifier"
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0068489)
dbaz (developer)
2014-07-01 17:03

The problems is that now Smartclient in its internal logic build functions using the popup name. The only popup that has an space in core is this one (Show Log).

Smartclient tries to do something like

Show Log_a3rf8f349.flash()

and it crashes because of that space.

The solution has two parts:
* Change the 'Show Log' popup name to 'ShowLog'
* Ensure that if there is a module implementing a popup with a name with spaces, the spaces are converted to "_". This was done in the past only for IE, now it is done for all browsers.
(0068490)
dbaz (developer)
2014-07-01 17:07

Since these popups are old 2.50 deprecated technology and since the fix is robust enough and in legacy code, it doesn't make any sense to prepare an automated test case for this regression.

It is almost impossible that in the future this isolated popup cannot be closed while the other application popups can be closed.
(0068492)
hgbot (developer)
2014-07-01 17:11

Repository: erp/devel/pi
Changeset: f1c53461ec96651fdae45996e488f2cd357c85ad
Author: David Baz Fayos <david.baz <at> openbravo.com>
Date: Tue Jul 01 17:11:20 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f1c53461ec96651fdae45996e488f2cd357c85ad [^]

Fixed issue 26984: 'Show Log' popup can be closed again

---
M src/org/openbravo/erpCommon/ad_process/ApplyModules.html
M src/org/openbravo/erpCommon/security/Login.html
M src/org/openbravo/erpCommon/security/Login_F1.html
M web/js/utils.js
---
(0068494)
shankarb (developer)
2014-07-02 06:53

Code reviewed and verified in pi changeset d84acc99f234.
(0068515)
hudsonbot (developer)
2014-07-02 16:47

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/e8fdcd7d974b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-07-01 10:51 caristu New Issue
2014-07-01 10:51 caristu Assigned To => dbaz
2014-07-01 10:51 caristu Modules => Core
2014-07-01 10:51 caristu Triggers an Emergency Pack => No
2014-07-01 10:51 caristu Issue Monitored: networkb
2014-07-01 11:28 caristu Priority high => immediate
2014-07-01 15:37 caristu Target Version PR14Q3 => PR14Q4
2014-07-01 16:24 dbaz Regression level => Production - QA Approved
2014-07-01 16:24 dbaz Regression date => 2014-02-26
2014-07-01 16:24 dbaz Regression introduced in release => PR14Q2
2014-07-01 16:24 dbaz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/20eb3426d990 [^]
2014-07-01 16:54 dbaz Review Assigned To => shankarb
2014-07-01 16:54 dbaz Issue Monitored: shankarb
2014-07-01 17:03 dbaz Note Added: 0068489
2014-07-01 17:07 dbaz Note Added: 0068490
2014-07-01 17:07 caristu Target Version PR14Q4 => PR14Q3
2014-07-01 17:11 hgbot Checkin
2014-07-01 17:11 hgbot Note Added: 0068492
2014-07-01 17:11 hgbot Status new => resolved
2014-07-01 17:11 hgbot Resolution open => fixed
2014-07-01 17:11 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/f1c53461ec96651fdae45996e488f2cd357c85ad [^]
2014-07-02 06:53 shankarb Note Added: 0068494
2014-07-02 06:53 shankarb Status resolved => closed
2014-07-02 06:53 shankarb Fixed in Version => PR14Q3
2014-07-02 16:47 hudsonbot Checkin
2014-07-02 16:47 hudsonbot Note Added: 0068515
2014-09-30 16:45 plujan Regression introduced in release PR14Q2 => 3.0PR14Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker