Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026684
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2014-05-23 16:272014-06-27 04:06
ReporteralostaleView Statuspublic 
Assigned Toshankarb 
PrioritynormalResolutionfixedFixed in Version3.0PR14Q3
StatusclosedFix in branchFixed in SCM revision23c896bf9a39
ProjectionnoneETAnoneTarget Version3.0PR14Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0026684: Alert datasource has no pagination

DescriptionWhen Alert Management window is opened, the requests to Alert datasource are launched without pagination. This can cause memory issues in case the number of active alerts for current role are big enough.
Steps To ReproduceOpen Alert Management and check datasource requests are not paginated
TagsPerformance
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00266833.0PR14Q3 closedalostale prevent unpaged datasource requests 
related to defect 00267343.0PR14Q3 closedshankarb Business Partner selector stops working in Financial Account window 

-  Notes
(0068337)
hgbot (developer)
2014-06-26 12:43

Repository: erp/devel/pi
Changeset: 23c896bf9a39d7288890b5d5520563de04174e64
Author: Shankar Balachandran <shankar.balachandran <at> openbravo.com>
Date: Thu Jun 26 14:24:16 2014 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/23c896bf9a39d7288890b5d5520563de04174e64 [^]

Fixes Issue 26684: Alert datasource has no pagination

Added pagination parameters to datasource request.
Since the request was done manually, the parameters had to be included.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/alert-management/ob-alert-grid.js
---
(0068345)
shankarb (developer)
2014-06-26 13:33

The sample alert created from F&B to generate more rows.

select c_invoice_id as referencekey_id,
       documentno as record_id,
       0 as ad_role_id,
       null as ad_user_id,
       ad_column_identifier('C_Invoice',c_invoice_id,'en_US') as description,
       'Y' as isActive,
        ad_org_id,
        ad_client_id,
        now() as created,
        0 as createdBy,
        now() as updated,
        0 as updatedBy
from c_invoice
where DateInvoiced<now()

tab - Header - Sales Invoice
(0068370)
AugustoMauch (developer)
2014-06-26 17:26

Code reviewed and verified in pi@174b96a6fa01
(0068387)
hudsonbot (developer)
2014-06-27 04:06

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c5640d5a10d4 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-05-23 16:27 alostale New Issue
2014-05-23 16:27 alostale Assigned To => AugustoMauch
2014-05-23 16:27 alostale Modules => Core
2014-05-23 16:27 alostale Triggers an Emergency Pack => No
2014-05-23 16:27 alostale Relationship added related to 0026683
2014-05-23 16:39 alostale Tag Attached: Performance
2014-06-03 14:49 alostale Relationship added related to 0026734
2014-06-04 08:36 shankarb Assigned To AugustoMauch => shankarb
2014-06-26 12:42 shankarb Review Assigned To => AugustoMauch
2014-06-26 12:42 shankarb Issue Monitored: AugustoMauch
2014-06-26 12:43 hgbot Checkin
2014-06-26 12:43 hgbot Note Added: 0068337
2014-06-26 12:43 hgbot Status new => resolved
2014-06-26 12:43 hgbot Resolution open => fixed
2014-06-26 12:43 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/23c896bf9a39d7288890b5d5520563de04174e64 [^]
2014-06-26 13:33 shankarb Note Added: 0068345
2014-06-26 17:26 AugustoMauch Note Added: 0068370
2014-06-26 17:26 AugustoMauch Status resolved => closed
2014-06-26 17:26 AugustoMauch Fixed in Version => PR14Q3
2014-06-27 04:06 hudsonbot Checkin
2014-06-27 04:06 hudsonbot Note Added: 0068387


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker