Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026683
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2014-05-23 16:242014-06-11 20:14
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PrioritynormalResolutionfixedFixed in Version3.0PR14Q3
StatusclosedFix in branchFixed in SCM revisione60dfabc36f9
ProjectionnoneETAnoneTarget Version3.0PR14Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0026683: prevent unpaged datasource requests

DescriptionUnder some unknown circumstances datasource for standard view is fetched without pagination. If data in that entity is big this can cause memory problem is server.
Steps To ReproduceUnknown
Proposed SolutionAll datasources should be fetched with pagination from client side.

Fetches for standard views/selectors can be enforced to have pagination. If for some bug pagination is not added, it is preferable to abort the fetch informing the user about this situation in order to be able to report where the problem is than continue with the fetch being possible to get an OOM error.

Other manual datasources should also include pagination, but they cannot be enforced in order to prevent they to stop working. In this case a message will be logged in server log.
 
TagsPerformance
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00266843.0PR14Q3 closedshankarb Openbravo ERP Alert datasource has no pagination 
related to defect 00267343.0PR14Q3 closedshankarb Openbravo ERP Business Partner selector stops working in Financial Account window 
related to defect 00268383.0PR14Q3 closedshankarb Openbravo ERP Unpaged request in Financial Account Transaction 
related to defect 0027807 closedmtaal Retail Modules When loading the model for a postterminal the request to the datasources are being done without pagination 
related to defect 00302043.0PR15Q4 closedcaristu Openbravo ERP prevent unpaged datsource request from manual sources 

-  Notes
(0067469)
hgbot (developer)
2014-05-27 14:19

Repository: erp/devel/pi
Changeset: e60dfabc36f951772337c8c10569b25901f79280
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue May 27 14:17:08 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/e60dfabc36f951772337c8c10569b25901f79280 [^]

fixed bug 26683: prevent unpaged datasource requests

  -unpaged requests for standard windows grids raise an exception
  -other unpged requests are served but a warn message is logged

---
M modules/org.openbravo.service.json/src-db/database/sourcedata/AD_MESSAGE.xml
M modules/org.openbravo.service.json/src/org/openbravo/service/json/DefaultJsonDataService.java
M modules/org.openbravo.service.json/src/org/openbravo/service/json/JsonConstants.java
---
(0067500)
hudsonbot (developer)
2014-05-27 23:09

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/15bdf44a37ae [^]
Maturity status: Test
(0067575)
hgbot (developer)
2014-05-29 14:41

Repository: erp/devel/pi
Changeset: 2ede1e6ee2605a885c2dc71b591c4dcbb08a73a7
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu May 29 14:40:23 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/2ede1e6ee2605a885c2dc71b591c4dcbb08a73a7 [^]

related to bug 26734, related to bug 26683

  Do not fail for unpaged slector datasource requests till selectors are properly
  fixed. This is done in order to complete CI

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/DefaultJsonDataService.java
---
(0067591)
hudsonbot (developer)
2014-05-29 23:05

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/bd7f8b6f935a [^]
Maturity status: Test
(0067802)
hgbot (developer)
2014-06-06 10:24

Repository: erp/devel/pi
Changeset: d3f182d722d11dfc51cc892cb8df977164576739
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Jun 06 10:23:01 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/d3f182d722d11dfc51cc892cb8df977164576739 [^]

related to issue 26683: don't warn on unpaged export

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/DefaultJsonDataService.java
---
(0067838)
dmitry_mezentsev (developer)
2014-06-10 10:09

Not closed for 14 days!!

Please use below to make sure it does not happen again:
https://issues.openbravo.com/changelog_all.html [^]
(0067888)
hudsonbot (developer)
2014-06-10 22:24

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/763f16c2ad2e [^]
Maturity status: Test
(0067913)
shankarb (developer)
2014-06-11 20:14

Code reviewed and verified in pi changeset 2b8030095ea6

- Issue History
Date Modified Username Field Change
2014-05-23 16:24 alostale New Issue
2014-05-23 16:24 alostale Assigned To => alostale
2014-05-23 16:24 alostale Modules => Core
2014-05-23 16:24 alostale Triggers an Emergency Pack => No
2014-05-23 16:25 alostale Target Version => PR14Q3
2014-05-23 16:25 alostale Tag Attached: Performance
2014-05-23 16:27 alostale Relationship added related to 0026684
2014-05-26 13:09 egoitz Fixed in Version => 3.0MP30.3
2014-05-27 13:22 egoitz Issue Monitored: egoitz
2014-05-27 14:19 alostale Review Assigned To => shankarb
2014-05-27 14:19 hgbot Checkin
2014-05-27 14:19 hgbot Note Added: 0067469
2014-05-27 14:19 hgbot Status new => resolved
2014-05-27 14:19 hgbot Resolution open => fixed
2014-05-27 14:19 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e60dfabc36f951772337c8c10569b25901f79280 [^]
2014-05-27 23:09 hudsonbot Checkin
2014-05-27 23:09 hudsonbot Note Added: 0067500
2014-05-29 14:32 alostale Relationship added duplicate of 0026734
2014-05-29 14:41 hgbot Checkin
2014-05-29 14:41 hgbot Note Added: 0067575
2014-05-29 14:42 alostale Relationship replaced related to 0026734
2014-05-29 23:05 hudsonbot Checkin
2014-05-29 23:05 hudsonbot Note Added: 0067591
2014-06-06 10:24 hgbot Checkin
2014-06-06 10:24 hgbot Note Added: 0067802
2014-06-10 10:09 dmitry_mezentsev Note Added: 0067838
2014-06-10 22:24 hudsonbot Checkin
2014-06-10 22:24 hudsonbot Note Added: 0067888
2014-06-11 11:24 alostale Relationship added related to 0026838
2014-06-11 20:14 shankarb Note Added: 0067913
2014-06-11 20:14 shankarb Status resolved => closed
2014-06-11 20:14 shankarb Fixed in Version 3.0MP30.3 => PR14Q3
2014-10-08 17:25 egoitz Relationship added related to 0027807
2015-06-18 14:13 alostale Relationship added duplicate of 0030204
2015-07-22 09:43 alostale Relationship replaced related to 0030204


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker