Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026562
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementminoralways2014-05-15 18:422014-12-30 23:22
ReportermaiteView Statuspublic 
Assigned Tovmromanos 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchpiFixed in SCM revisionbe7a8c0af5dc
ProjectionnoneETAnoneTarget Version3.0PR15Q1
OSAnyDatabasePostgreSQLJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0026562: Improve error message when Unprocessing a Tax Payment with related Payment posted

DescriptionIMPORTANT: Only reproducible in PostgreSQL!

At the moment, error showed is "Document already Posted." but user does not know that document he should unpost is related payment
Steps To Reproduce1. Follow tax payment guide and process record using option "generate payment"=Y: http://wiki.openbravo.com/wiki/Tax_Payment [^]
2. Access Payment in/Payment out window and search for created payment. Ensure that it is posted
3. Navigate to GL Journal window from Tax Payment header and ensure that journal is unpost
4. Try to run "Unprocess" process and realize that error "Document already Posted." is obtained

Error needs to be improved to let user know what Payment should be unposted
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0027753 closedvmromanos Tax Payment Unprocess when Generate Payment = Y - ORACLE 

-  Notes
(0070685)
vmromanos (developer)
2014-10-03 11:58

I'm able to unprocess the tax payment regardless the payment is still posted.
Not sure whether this situation is a bug or not, but, after a quick code review, it's evident that the process only checks whether the gl journal is posted or not before unprocessing.

IMHO the unprocess should also delete (or at least reactivate) the previously created payment. Probably we should enter a design defect to study this situation
(0070694)
vmromanos (developer)
2014-10-03 13:53

Reopen: After talking to Maite we have realized that the bug is only reproducible in Postgres.

However we have observed that the behavior in Oracle is totally different to PostgreSQL. It's reported at 0027753
(0070737)
hgbot (developer)
2014-10-06 12:13

Repository: erp/devel/pi
Changeset: be7a8c0af5dc08aa6f98fdcda45b0c690ebc79ad
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Mon Oct 06 11:25:38 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/be7a8c0af5dc08aa6f98fdcda45b0c690ebc79ad [^]

Fixed bug 26562: Error message Unprocessing TaxPayment related to posted Payment

Improved the error message shown when unprocessing a Tax Payment related to a posted Payment.
Besides, the Payment field is shown when the Tax Payment is related to a payment to make it easier to identify the payment.
Finally the "Generate Payment" field is always shown because it had no sense to hide it when the record was processed.

---
M modules/org.openbravo.advpaymentmngt/src-db/database/model/functions/APRM_TAX_PAYMENT.xml
M src-db/database/sourcedata/AD_FIELD.xml
M src-db/database/sourcedata/AD_MESSAGE.xml
---
(0070909)
maite (developer)
2014-10-13 16:44

verified
(0072902)
hudsonbot (developer)
2014-12-30 23:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/6525fe229e06 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-05-15 18:42 maite New Issue
2014-05-15 18:42 maite Assigned To => dmiguelez
2014-05-15 18:42 maite Modules => Core
2014-05-15 18:42 maite Triggers an Emergency Pack => No
2014-05-15 18:43 maite Assigned To dmiguelez => jonalegriaesarte
2014-05-19 14:33 jonalegriaesarte Assigned To jonalegriaesarte => pramakrishnan
2014-06-16 12:48 jonalegriaesarte Target Version PR14Q3 => PR14Q4
2014-09-29 16:12 jonalegriaesarte Target Version 3.0PR14Q4 => 3.0PR15Q1
2014-10-03 11:45 vmromanos Assigned To pramakrishnan => vmromanos
2014-10-03 11:58 vmromanos Review Assigned To => vmromanos
2014-10-03 11:58 vmromanos Note Added: 0070685
2014-10-03 11:58 vmromanos Status new => closed
2014-10-03 11:58 vmromanos Resolution open => unable to reproduce
2014-10-03 12:17 vmromanos Relationship added related to 0027753
2014-10-03 13:53 vmromanos Note Added: 0070694
2014-10-03 13:53 vmromanos Status closed => new
2014-10-03 13:53 vmromanos Resolution unable to reproduce => open
2014-10-03 13:55 vmromanos Description Updated View Revisions
2014-10-06 11:02 vmromanos Status new => scheduled
2014-10-06 11:02 vmromanos fix_in_branch => pi
2014-10-06 12:13 hgbot Checkin
2014-10-06 12:13 hgbot Note Added: 0070737
2014-10-06 12:13 hgbot Status scheduled => resolved
2014-10-06 12:13 hgbot Resolution open => fixed
2014-10-06 12:13 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/be7a8c0af5dc08aa6f98fdcda45b0c690ebc79ad [^]
2014-10-13 16:44 maite Note Added: 0070909
2014-10-13 16:44 maite Status resolved => closed
2014-12-30 23:22 hudsonbot Checkin
2014-12-30 23:22 hudsonbot Note Added: 0072902


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker