Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026555
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformcriticalhave not tried2014-05-15 11:532014-10-01 16:39
ReporterAugustoMauchView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q3
StatusclosedFix in branchFixed in SCM revisiond6181edcf7b3
ProjectionnoneETAnoneTarget Versionpi
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2014-01-29
Regression introduced in release3.0PR14Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/fe1b26c8cee8 [^]
Triggers an Emergency PackNo
Summary

0026555: Problem in initialization of CanvasItem when a new record is created in grid mode.

DescriptionProblem in initialization of CanvasItem when a new record is created in grid mode. When a record is created, the CanvasItem column is being initialized to null, even if it has a default value.
Steps To ReproduceAs F&B Admin:
- Open the Return to Vendor window
- Create a new record in grid view. Check that the Total Gross Amount field has been initialized to an empty string, it should have been initialized to '0.00'. This field is a CanvasItem.
- Try so save the record. You can't because the Total Gross Amount has not been initialized, and you can set its value manually because it is read only.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0067140)
AugustoMauch (developer)
2014-05-15 11:54

There are two workarounds for this issue:
- Create the record in form view
- Hide the column in the grid view
(0067143)
hgbot (developer)
2014-05-15 12:19

Repository: erp/devel/pi
Changeset: d6181edcf7b39d855f43cca8678991ff954bf2be
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu May 15 12:11:43 2014 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/d6181edcf7b39d855f43cca8678991ff954bf2be [^]

Fixes issue 26555: Bad initialization of CanvasItem in grid view.

The problem was the following:
- The shouldSaveValue of the CanvasItems have always been false, but until this Smartclient upgrade this was not enforced.
- After the upgrade of Smartclient the shouldSaveValue is actually being enforced, the value returned from the FIC for this column is not being saved in the form values.

To fix this, the shouldSaveValue of the CanvasItem class has been set to true. The only consequence of this change is that the value of the CanvasItems should now be stored in the form values, see http://www.smartclient.com/docs/9.1/a/b/c/go.html#attr..CanvasItem.shouldSaveValue [^]

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-canvas.js
---
(0067188)
hudsonbot (developer)
2014-05-16 07:19

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/649d0b7eba54 [^]
Maturity status: Test
(0067203)
alostale (developer)
2014-05-16 09:41

Code reviewed
Tested creating records in Return to Vendor:
-In grid view with Total Gross Amount field shown (this case was failing before)
-In grid view with Total Gross Amount field hidden
-In form view

- Issue History
Date Modified Username Field Change
2014-05-15 11:53 AugustoMauch New Issue
2014-05-15 11:53 AugustoMauch Assigned To => AugustoMauch
2014-05-15 11:53 AugustoMauch Modules => Core
2014-05-15 11:53 AugustoMauch Triggers an Emergency Pack => No
2014-05-15 11:54 AugustoMauch Note Added: 0067140
2014-05-15 11:55 AugustoMauch Regression level => Production - QA Approved
2014-05-15 11:55 AugustoMauch Regression date => 2014-01-29
2014-05-15 11:55 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/fe1b26c8cee8 [^]
2014-05-15 12:14 AugustoMauch Issue Monitored: alostale
2014-05-15 12:15 AugustoMauch Review Assigned To => alostale
2014-05-15 12:19 hgbot Checkin
2014-05-15 12:19 hgbot Note Added: 0067143
2014-05-15 12:19 hgbot Status new => resolved
2014-05-15 12:19 hgbot Resolution open => fixed
2014-05-15 12:19 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d6181edcf7b39d855f43cca8678991ff954bf2be [^]
2014-05-16 07:19 hudsonbot Checkin
2014-05-16 07:19 hudsonbot Note Added: 0067188
2014-05-16 09:41 alostale Note Added: 0067203
2014-05-16 09:41 alostale Status resolved => closed
2014-05-16 09:41 alostale Fixed in Version => PR14Q3
2014-10-01 16:39 plujan Regression introduced in release => 3.0PR14Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker