Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026512
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2014-05-12 17:022014-10-01 18:59
ReportermalsasuaView Statuspublic 
Assigned Toszapata 
PriorityimmediateResolutionfixedFixed in VersionRR14Q4
StatusclosedFix in branchFixed in SCM revisione40925774f15
ProjectionnoneETAnoneTarget VersionRR14Q3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression levelCoding ( Testing )
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0026512: amounts in return receipts are wrong calculated

Descriptionwhen a return is paid in WEBPOS, the payment and transaction generated in ERP are wrong, the amount is positive and it should be a negative amount
Steps To Reproduce. in WEB POS
 . create a return order: total 20 eur

. in ERP
 . go to financial account:
  . transaction:
   deposit amount: 20
   withdrawal amount: 0
 -->> it is wrong. The correct is:
   deposit amount: 0
   withdrawal amount: 20
  
 . go to payment related to transaction:
  . invoiced amount: -20
  . expected amount: -20
  . received amount: 20
 -->> it is wrong. The correct is:
  . received amount: -20
TagsRegression
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0027359 closedmtaal Web POS is calculating the returns using the gross instead of qty 

-  Notes
(0067233)
Orekaria (administrator)
2014-05-17 10:03

Verify also with foreign currencies (USD in sampledata)
(0068381)
hgbot (developer)
2014-06-27 01:37

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: fb13283ef0c47c442bdf734d755e045b182b9ce9
Author: Salvador Zapata <salvador.zapata <at> gmail.com>
Date: Thu Jun 26 20:33:43 2014 -0300
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/fb13283ef0c47c442bdf734d755e045b182b9ce9 [^]

Fixed issue 26512: Take into account the sign of the order

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0068403)
Orekaria (administrator)
2014-06-27 13:00

Tested in *.retail.posterminal rev 3691
(0068734)
marvintm (developer)
2014-07-18 14:42

The fix is not completely correct, because it doesn't fix the root cause of the problem.

The root cause of the problem is that the payment information is being sent incorrectly by the client side.

In case of returns, the payment amount should be negative, and currently (in Q3) it's being sent as a positive amount. This is a behavior which has happened in Q3 (in Q2 it worked correctly), so we need to investigate why this change happened, revert this fix, and do a proper fix which causes the original problem.
(0068738)
hgbot (developer)
2014-07-18 22:57

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 419c97a6e65361543a06ddfb61d2ba12819e9600
Author: Salvador Zapata <salvador.zapata <at> gmail.com>
Date: Fri Jul 18 17:57:05 2014 -0300
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/419c97a6e65361543a06ddfb61d2ba12819e9600 [^]

Fixed issue 26512: Change amounts before synchronize the order

---
M web/org.openbravo.retail.posterminal/js/data/dataordersave.js
---
(0068803)
hgbot (developer)
2014-07-22 13:03

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 9dad219fc35ace999f401b0dc1ff4093260211cd
Author: Salvador Zapata <salvador.zapata <at> gmail.com>
Date: Tue Jul 22 08:02:45 2014 -0300
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/9dad219fc35ace999f401b0dc1ff4093260211cd [^]

Fixed issue 26512: Backout wrong change

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0068911)
dmitry_mezentsev (developer)
2014-07-28 12:31

The issue is not closed for 10 days.
Please take an action!
(0070121)
sureshbabu (reporter)
2014-09-15 12:40

able to reproduce in live builds.
(0070424)
hgbot (developer)
2014-09-26 09:17

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: e40925774f1518ef4f37d967e6784385b1d5a1b9
Author: Miguel de Juana <miguel.dejuana <at> openbravo.com>
Date: Fri Sep 26 09:17:06 2014 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e40925774f1518ef4f37d967e6784385b1d5a1b9 [^]

Fixed issue 0026512: amounts in return receipts are wrong calculated

Somewhere in the code was introcuded a regression. A fix was done to solve this issue but it was looking qty of the order instead of checking gross of the order.

---
M web/org.openbravo.retail.posterminal/js/data/dataordersave.js
---
(0070427)
migueldejuana (developer)
2014-09-26 09:37

I couldn't find where was introduced the regression

- Issue History
Date Modified Username Field Change
2014-05-12 17:02 malsasua New Issue
2014-05-12 17:02 malsasua Assigned To => malsasua
2014-05-12 17:02 malsasua Triggers an Emergency Pack => No
2014-05-12 18:13 malsasua version RR14Q2 =>
2014-05-12 18:13 malsasua Target Version => RR14Q3
2014-05-17 10:03 Orekaria Note Added: 0067233
2014-06-20 09:16 malsasua Regression level => Coding ( Testing )
2014-06-20 09:16 malsasua Tag Attached: Regression
2014-06-27 01:37 hgbot Checkin
2014-06-27 01:37 hgbot Note Added: 0068381
2014-06-27 01:37 hgbot Status new => resolved
2014-06-27 01:37 hgbot Resolution open => fixed
2014-06-27 01:37 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/fb13283ef0c47c442bdf734d755e045b182b9ce9 [^]
2014-06-27 13:00 Orekaria Review Assigned To => Orekaria
2014-06-27 13:00 Orekaria Note Added: 0068403
2014-06-27 13:00 Orekaria Status resolved => closed
2014-06-27 13:00 Orekaria Fixed in Version => RR14Q3
2014-07-18 14:42 marvintm Assigned To malsasua => szapata
2014-07-18 14:42 marvintm Note Added: 0068734
2014-07-18 14:42 marvintm Status closed => new
2014-07-18 14:42 marvintm Resolution fixed => open
2014-07-18 14:43 marvintm Fixed in Version RR14Q3 =>
2014-07-18 22:57 hgbot Checkin
2014-07-18 22:57 hgbot Note Added: 0068738
2014-07-18 22:57 hgbot Status new => resolved
2014-07-18 22:57 hgbot Resolution open => fixed
2014-07-18 22:57 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/fb13283ef0c47c442bdf734d755e045b182b9ce9 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/419c97a6e65361543a06ddfb61d2ba12819e9600 [^]
2014-07-22 13:03 hgbot Checkin
2014-07-22 13:03 hgbot Note Added: 0068803
2014-07-22 13:03 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/419c97a6e65361543a06ddfb61d2ba12819e9600 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/9dad219fc35ace999f401b0dc1ff4093260211cd [^]
2014-07-28 12:31 dmitry_mezentsev Note Added: 0068911
2014-07-28 15:31 marvintm Review Assigned To Orekaria => marvintm
2014-07-28 15:31 marvintm Status resolved => closed
2014-07-28 15:31 marvintm Fixed in Version => RR14Q3
2014-09-15 12:40 sureshbabu Note Added: 0070121
2014-09-15 12:40 sureshbabu Status closed => new
2014-09-15 12:40 sureshbabu Resolution fixed => open
2014-09-15 12:40 sureshbabu Fixed in Version RR14Q3 =>
2014-09-26 09:17 hgbot Checkin
2014-09-26 09:17 hgbot Note Added: 0070424
2014-09-26 09:17 hgbot Status new => resolved
2014-09-26 09:17 hgbot Resolution open => fixed
2014-09-26 09:17 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/9dad219fc35ace999f401b0dc1ff4093260211cd [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/e40925774f1518ef4f37d967e6784385b1d5a1b9 [^]
2014-09-26 09:37 migueldejuana Note Added: 0070427
2014-09-27 01:11 mtaal Relationship added related to 0027359
2014-10-01 18:59 marvintm Status resolved => closed
2014-10-01 18:59 marvintm Fixed in Version => RR14Q4


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker