Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0026457
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersminoralways2014-05-05 16:192014-11-07 15:46
ReporterngarciaView Statuspublic 
Assigned ToAugustoMauch 
PriorityhighResolutionfixedFixed in Version3.0PR14Q4
StatusclosedFix in branchFixed in SCM revision65b98d7a5bf5
ProjectionnoneETAnoneTarget Version3.0PR14Q4
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toshankarb
Web browser
ModulesQuery/List widget
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0026457: Invoices to pay widget shows incorrect Date when the system is in a previous time zone

DescriptionInvoices to pay widget shows incorrect Date when the system is in a previous time zone
Steps To ReproduceAccess the application from a machine with a timezone previous to the timezone of the machine where the application is running
As group admin role:
   Add the Invoices to pay widget in the workspace
   Check that the date shown is one day before the invoice date
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0027501 closedAugustoMauch Time and DateTime fields are not converted to the local timezone in Query/List Widgets 

-  Notes
(0069847)
hgbot (developer)
2014-08-28 18:37

Repository: erp/devel/pi
Changeset: 65b98d7a5bf570f1f26ff96fc3c25fd3323644b4
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Fri Aug 29 01:35:03 2014 +0900
URL: http://code.openbravo.com/erp/devel/pi/rev/65b98d7a5bf570f1f26ff96fc3c25fd3323644b4 [^]

Fixes issue 26457: Date columns not properly displayed in query/list widgets

The problem was that all date columns were being stored internally as DateTime column, so they were being treated as such and were being converted to the local timezone. As these dates at a time of 00:00:00, if the client whose timezone < the timezone of the server, the datetime shown was the previous one.

To fix this, Date columns are not sent as proper dates, instead of as DateTimes. This way the date columns will show the same value in all clients, regardless of their time zones.

---
M modules/org.openbravo.client.querylist/src/org/openbravo/client/querylist/QueryListDataSource.java
---
(0069848)
AugustoMauch (developer)
2014-08-28 18:39

Test plan:
- Apart from checking that the original issue is not reproducible, check that dateTime parameters are shown properly. To test this you can follow the steps to reproduce this issue: https://issues.openbravo.com/view.php?id=27501 [^]
(0069860)
hudsonbot (developer)
2014-08-29 15:53

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/af520c9729b9 [^]
Maturity status: Test
(0069872)
shankarb (developer)
2014-09-01 05:59

Code reviewed and verified in pi changeset 611572b5205f

- Issue History
Date Modified Username Field Change
2014-05-05 16:19 ngarcia New Issue
2014-05-05 16:19 ngarcia Assigned To => jonalegriaesarte
2014-05-05 16:19 ngarcia Modules => Query/List widget
2014-05-05 16:19 ngarcia Triggers an Emergency Pack => No
2014-05-05 16:20 ngarcia Issue Monitored: networkb
2014-05-19 14:33 jonalegriaesarte Assigned To jonalegriaesarte => pramakrishnan
2014-06-16 12:48 jonalegriaesarte Target Version PR14Q3 => PR14Q4
2014-07-30 08:53 AtulOpenbravo Assigned To pramakrishnan => AtulOpenbravo
2014-07-30 08:53 AtulOpenbravo Status new => scheduled
2014-07-30 08:53 AtulOpenbravo fix_in_branch => pi
2014-07-30 10:59 ngarcia fix_in_branch pi =>
2014-07-30 10:59 ngarcia Steps to Reproduce Updated View Revisions
2014-08-26 11:55 AtulOpenbravo Assigned To AtulOpenbravo => AugustoMauch
2014-08-28 07:57 shankarb Assigned To AugustoMauch => shankarb
2014-08-28 18:12 AugustoMauch Relationship added related to 0027501
2014-08-28 18:12 AugustoMauch Assigned To shankarb => AugustoMauch
2014-08-28 18:35 AugustoMauch Issue Monitored: shankarb
2014-08-28 18:35 AugustoMauch Review Assigned To => shankarb
2014-08-28 18:37 hgbot Checkin
2014-08-28 18:37 hgbot Note Added: 0069847
2014-08-28 18:37 hgbot Status scheduled => resolved
2014-08-28 18:37 hgbot Resolution open => fixed
2014-08-28 18:37 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/65b98d7a5bf570f1f26ff96fc3c25fd3323644b4 [^]
2014-08-28 18:39 AugustoMauch Note Added: 0069848
2014-08-29 15:53 hudsonbot Checkin
2014-08-29 15:53 hudsonbot Note Added: 0069860
2014-09-01 05:59 shankarb Note Added: 0069872
2014-09-01 05:59 shankarb Status resolved => closed
2014-09-01 05:59 shankarb Fixed in Version => 3.0PR14Q4
2014-11-07 15:46 eugeni Issue Monitored: eugeni


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker