Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0025972
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajorhave not tried2014-03-12 15:272014-03-17 18:51
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR14Q2
StatusclosedFix in branchFixed in SCM revision31ec6d0191e3
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2014-02-04
Regression introduced in release
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/e698ee97b844cfac10002299da1281ca8ee08789 [^]
Triggers an Emergency PackNo
Summary

0025972: incorrect navigation to windows with default saved view

DescriptionDirect navigation to a window with a default saved view causes the direct filter not to be applied. The view switches from form to grid and the default view is applied.
Steps To Reproduce-In BP window apply a filter and save it as default saved view
-Open any existent Sales Order and navigate to its BP
-BP tab is opened in form for a moment and then it's switched to grid view applying the filter defined in the default saved view

Note after SC upgrade when switch to grid is not present and the window appears blank as reported in 0025919
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00256363.0PR14Q2 closedalostale Saved view filter reapplied after adding a column in grid 
depends on defect 0025919 closedalostale direct navigation to window with default saved view not working 

-  Notes
(0065166)
hgbot (developer)
2014-03-14 15:53

Repository: erp/devel/pi
Changeset: 31ec6d0191e3b96e1d2223d2fda459cd49a1233f
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Mar 14 15:53:10 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/31ec6d0191e3b96e1d2223d2fda459cd49a1233f [^]

fixed bug 25919, fixed bug 25972

  Preventing double request when in direct navigation to a window with a
  default saved view.

  This case cause after SC upgrade not to navigate to form view (nor to
  show grid) because datasource was in an incorrecte status.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-window.js
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/personalization/ob-manage-views.js
---
(0065167)
alostale (developer)
2014-03-14 16:05

Tested navigating to windows with default saved view and windows without default saved view to main and children tabs
(0065187)
hudsonbot (developer)
2014-03-15 03:04

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8396ec753aec [^]
Maturity status: Test
(0065208)
hgbot (developer)
2014-03-17 11:08

Repository: erp/devel/pi
Changeset: f98bc5e90f33a2761dc8bcf708b3d7729a343c4f
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Mar 17 11:08:09 2014 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/f98bc5e90f33a2761dc8bcf708b3d7729a343c4f [^]

related to bug 25972: fixed incorrect reference

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-window.js
---
(0065212)
AugustoMauch (developer)
2014-03-17 12:48

Code reviewed and verified in pi@f98bc5e90f33

It has been tested both in header tabs and in subtabs.
(0065242)
hudsonbot (developer)
2014-03-17 18:51

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/e9fe33009b65 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2014-03-12 15:27 alostale New Issue
2014-03-12 15:27 alostale Assigned To => AugustoMauch
2014-03-12 15:27 alostale Modules => Core
2014-03-12 15:27 alostale Triggers an Emergency Pack => No
2014-03-12 15:27 alostale Relationship added related to 0025636
2014-03-12 15:28 alostale Regression level => Pre packaging ( pi )
2014-03-12 15:28 alostale Regression date => 2014-02-04
2014-03-12 15:28 alostale Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/e698ee97b844cfac10002299da1281ca8ee08789 [^]
2014-03-12 15:31 alostale Steps to Reproduce Updated View Revisions
2014-03-12 15:31 alostale Relationship added depends on 0025919
2014-03-14 15:50 alostale Assigned To AugustoMauch => alostale
2014-03-14 15:53 hgbot Checkin
2014-03-14 15:53 hgbot Note Added: 0065166
2014-03-14 15:53 hgbot Status new => resolved
2014-03-14 15:53 hgbot Resolution open => fixed
2014-03-14 15:53 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/31ec6d0191e3b96e1d2223d2fda459cd49a1233f [^]
2014-03-14 16:05 alostale Note Added: 0065167
2014-03-15 03:04 hudsonbot Checkin
2014-03-15 03:04 hudsonbot Note Added: 0065187
2014-03-17 09:26 alostale Review Assigned To => AugustoMauch
2014-03-17 11:08 hgbot Checkin
2014-03-17 11:08 hgbot Note Added: 0065208
2014-03-17 12:48 AugustoMauch Note Added: 0065212
2014-03-17 12:48 AugustoMauch Status resolved => closed
2014-03-17 12:48 AugustoMauch Fixed in Version => PR14Q2
2014-03-17 18:51 hudsonbot Checkin
2014-03-17 18:51 hudsonbot Note Added: 0065242


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker